Audacity crashes

I love the simplicity of Audacity but I have a couple of problems running it on my Mac. OS X El Capitan Version 10.11.6.
When I wake up the computer after Sleep or Shutdown Audacity will not record.
I have to restart the computer to get Audacity running again.
Is there a fix for that?
SECONDLY: After using Audacity for a while, the digital playback starts to break up (like the file is corrupted), but when I save the file and play it back as an MP3 the playback is normal.
It seems like the file corruption (pops and crackles in the tracks) is only in the Audacity playback program.
Is there a fix for that?

You did not say what version of Audacity you are using (see the pink panel at the top of the page).

I suggest you use the latest Audacity 2.1.3 from Audacity ® | Download for Mac OS.

What Mac is it? Apple logo > About This Mac.

What recording device is it (make and model number) and how does it connect to the computer?

When the computer wakes and you try to record, is there an “error opening sound device” or does the recording cursor stall? Or are you saying as per the subject title that Audacity force quits itself?

If it’s a USB device, stalling might be “normal”. Does the same thing happen in GarageBand or other recording applications?

Please see Why do I hear clicky playback on Mac?


Gale, thanks for the reply.
I’m using Audacity 2.1.3.
This is a Mac Mini with a 2.6 GHz Intel Core i5 Processor
I’m recording through Neumann TLM 103 Microphone connected to an Lexicon I-onix U22 audio interface that connects by USB to the Mac Mini.
There is no error opening sound. The record cursor doesn’t stall it just flatlines across the page, which is my clue to restart the computer.
After the restart it records fine for a couple of hours but eventually the file starts to sound corrupted - small pops at first, than crackles, and eventually you can’t hear it through Audacity anymore until you restart.
The file does not actually seem to be corrupted because I can save it as an MP3 and plays back perfectly.
This does not happen with other applications like Garage band or Reaper.
However, when it works I much prefer Audacity over those others.
Thanks for you help.

If the recording itself is not corrupted then your answer is in the link I posted before: Why do I hear clicky playback on Mac?. The prime recommendation there is to reduce Audacity’s “Audio to buffer” setting in Recording Preferences. It is possible this may help prevent flatlining too, but USB interfaces don’t record for ever without rebooting the computer.

Try recording at a modest sample rate of 44100 Hz (project rate bottom left of Audacity). Open Applications/Utilities/Audio MIDI Setup and set the output and input of the interface to 44100 Hz too.

If you want a higher rate, choose from 48000 Hz, 88200 Hz or 96000 Hz because those are the only other native rates that the interface supports. And if you choose a higher rate, again set Audio MIDI Setup to the same rate as Audacity project rate. Mismatched sample rates are a prime reason for USB recordings not working correctly.

Higher rates put more strain on the computer and interface and increase the likelihood of recording glitches.


Thank you very much. I’ll give the sample rate a try.
Also, any idea when Audacity will be compatible with Mac’s Sierra operating system?

It already is - I have 2.1.2 2.1.3 and the latest alpha all running sweetly on my Macbook Pro under macOS 10.12.3 Sierra


I’m thrilled it’s working for you.
Ever since the Sierra install, Audacity has been crippled.
I open the program, hit record, and it opens a track but it freezes.
I click record again it opens a separate track and it just flat lines. It doesn’t record the audio.
Any theories as to what might be going wrong?
Many thanks

Please note that officially, Audacity only has partial Support for Mac Sierra - but the problems we know about are with losing access to plugins and libraries, and problems with multiple users using Audacity, not with recording. Only a minority of machines may be affected by that.


Have you acted on the advice I last wrote out for you?

Let me repeat it for you because it is important for using external devices. Click the link in blue text to read more.

Note that your I-ONIX is discontinued. According to I-ONIX U22 | Lexicon Pro - Legendary Reverb and Effects | English the last version of macOS supported by its drivers is Mountain Lion. If you installed drivers for it you could perhaps try uninstalling them and see if it runs better with the Mac built-in USB Audio drivers. But check the above about buffer and sample rates before you mess around with drivers.


I just got a new audio interface RME Babyface Pro that I’d like to use with Audacity, but I’m getting some serious latency issues. I’m running this through a MacBook Air running Mac OS Sierra 10.12.1. I’m using Audacity 2.1.3. The Sample rate is running at 44,100Hz. My microphone (Sennheiser 416) is plugged into the interface and the interface is plug into the laptop by USB. Any ideas on how to resolve the latency issue. s

So no problem with crashing or freezing now?

Please use more words to describe the latency issue.

Set Babyface as the Audacity playback and recording device and monitor by plugging headphones into the Babyface. Turn off Transport > Software Playthrough in Audacity. That should deal with playthrough latency.

Are you recording overdubs on top of a track already in Audacity and the new track does not line up with the previous one? If so, that is recording latency. Here is how to set Audacity up to correct for that: Latency Test.


I ran the first aide program on the Mac Mini sierra operating system and that seemed to correct the problem. I love Audacity and it is now working with Sierra. Thank you so much for your help. My other problem is with the new audio interface (Babyface Pro) I’m using on a MacBook Air laptop which I wrote you about earlier. There’s a bad latency problem. I’ll be anxious to hear about a possible solution. Again, many thanks.

You mean, that solved the crashing problem you had at first?

Did you see my reply Audacity crashes - #12 by Gale_Andrews ? There are two types of latency, “playthrough latency” when you hear yourself late when you are monitoring the recording, and “recording latency” which makes a second recorded track misaligned with the first track. I described how to address both.

If my answer does not solve the problem, please describe the exact symptoms of “bad latency”. Perhaps you refer to something other than latency.


The 10.12.5 update for Sierra has been available since a few days. It’s supposed to fix problems with USB and Bluetooth audio, especially for USB mics and headsets.

Get it while it’s warm!