AU Files Not Recognized by Repair Tools But Open in Audacity

city 2.0.5 was recording live from a mic connected to a USB Soundcard (Focusrite) when Win 7 froze necessitating a system reboot.

Audacity offered to recover the recording but could not and suggested Import Raw Data. The AU files are audible after importing as Raw Data and as Audio. Using Import Raw Data some files sound strange and have a wave form which does look nor sound like speech.

auinfo.exe shows the files as:
File type: AU (.snd)
Endianness: Little (naitive)
Header size: 12380 bytes
Audio data size: not specified
Sample format: 32-bit IEEE floating point (6)
Sample rate: 44100 hz
Channels: 1 (mono)

The files were renamed for use with aud_recover.exe but the resulting file had similar issues as Import Raw Data, i.e. the waveforms were not like speech.

audacity_recovery.exe was used but its error message was that it could not find any files to be recovered.

There are 777 files. Each file can be spliced in Audacity and/or converted in WAV files but this is laborious.

Can anyone suggest a less labour intensive method?

I would expect one or two tiny files to be damaged at the end of the capture when the machine went down, but if you have more than that, then the capture was being damaged during the show.

If the normal recovery processes failed then there be no convenient way to put the show back together.

I assume you followed this document.


Why did it freeze? Did you run out of power? If Windows is freezing you need to find out why.

Do you have the correct drivers and firmware for the Focusrite?

What exactly happened? Was the recording silenced? If there were errors, exactly what did they say? Did you look at Help > Show Log… ?

The Automatic Crash Recovery dialogue does not suggest Import Raw Data.

If you mean they were too slow or fast, try setting the track rate to the rate the project was. You can do this at “Set Rate” in the Track Drop-Down Menu ( Audacity Manual ).

Then you did not rename the files correctly.

Why do you need to do this? What is the problem with the autosave file at UsersAppDataRoamingAudacityAutoSave ? If you can still launch Audacity and have it offer recovery, please try that, then attach the log from Help > Show Log… and attach the autosave file (as above).

To see the autosave file, you may need to set Windows to show hidden files and folders. See here for how to do that: How to see hidden files in Windows .

To attach files to your reply, please see: .

You can regenerate a project file from the AU files using an experimental script, but you would have to install Python and be comfortable using a command prompt. It would be easier to use the autosave file.


Yes, the last few files sounded like chipmunk, speeded up speech.

If the normal recovery processes failed then there be no convenient way to put the show back together.

I assume you followed this document.
Audacity Manual

The Auto Recovery failed.
The log shows

15:42:37: Audacity 2.0.5
15:42:41: Trying to load FFmpeg libraries...
15:42:41: Trying to load FFmpeg libraries from default path, 'C:Program Files (x86)Ffmpeg For Audacityavformat-52.dll'.
15:42:41: Looking up PATH environment variable...
15:42:41: PATH = 'C:Program Files (x86)NVIDIA CorporationPhysXCommon;C:Program FilesJavajre7bin;C:Windowssystem32;C:...............

15:42:41: Checking that 'C:Program Files (x86)Ffmpeg For Audacity' is in PATH...
15:42:41: Warning: FFmpeg directory is not in PATH.
15:42:41: Temporarily appending ';C:Program Files (x86)Ffmpeg For Audacity' to PATH...
15:42:41: Checking for monolithic avformat from 'C:Program Files (x86)Ffmpeg For Audacityavformat-52.dll'.
15:42:42: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: the specified procedure could not be found.)
15:42:42: avformat not monolithic
15:42:42: Loading avutil from 'C:Program Files (x86)Ffmpeg For Audacityavutil-50.dll'.
15:42:42: Loading avcodec from 'C:Program Files (x86)Ffmpeg For Audacityavcodec-52.dll'.
15:42:42: Loading avformat from 'C:Program Files (x86)Ffmpeg For Audacityavformat-52.dll'.
15:42:42: Returning PATH to previous setting...
15:42:42: Actual avutil path C:Program Files (x86)Ffmpeg For Audacityavutil-50.dll
15:42:42: Actual avcodec path C:Program Files (x86)Ffmpeg For Audacityavcodec-52.dll
15:42:42: Actual avformat path C:Program Files (x86)Ffmpeg For Audacityavformat-52.dll
15:42:42: Importing symbols...
15:42:42: All symbols loaded successfully. Initializing the library.
15:42:42: Retrieving FFmpeg library version numbers:
15:42:42:    AVCodec version 0x344802 - 52.72.2 (built against 0x344802 - 52.72.2)
15:42:42:    AVFormat version 0x344002 - 52.64.2 (built against 0x344002 - 52.64.2)
15:42:42:    AVUtil version 0x320f01 - 50.15.1 (built against 0x320f01 - 50.15.1)
15:42:42: FFmpeg libraries loaded successfully.
15:42:45: File name is C:Users---AppDataRoamingAudacityAutoSaveNew Project - 2014-03-23 14-43-11 N-8.autosave
15:42:45: Mime type is *
15:42:45: Opening with libsndfile
15:42:45: Opening with liboggvorbis
15:42:45: Opening with libflac
15:42:45: Opening with lof
15:42:45: Opening with libav
15:42:45: Error: FFmpeg : av_find_stream_info() failed for file C:Users---AppDataRoamingAudacityAutoSaveNew Project - 2014-03-23 14-43-11 N-8.autosave
15:42:45: Error: Importer::Import: Opening failed.

You can’t recover a project by dragging the autosave file into Audacity.

Did you read my post ( AU Files Not Recognized by Repair Tools But Open in Audacity - #3 by Gale_Andrews )? If Audacity is running, open Windows Task Manager (CTRL + SHIFT + ESC). Click the “Processes” tab. Right-click over audacity.exe and choose “End Process Tree”.

Restart Audacity. If you see the Automatic Crash Recovery dialogue, please attach the autosave file and attach the new Log. Please see here for how to attach files: .


It has not frozen much recently. There are several suspects:

  • PerfectDisk which runs as a service - but it seems to have played well with the current configuration.
  • Focusrite Scarlett 2i2 USB Soundcard because pulling USB cable out can cause freeze, however the cable was not touched.

I wondered today if Audacity’s Real Time Conversion might have played a role? It had been set to Best Quality, but this has worked well on many occasions.

Yes, the latest: Scarlett plug-in suite 1.5 (Windows)

The screen froze at the end of live spoken broadcast, about 80 minutes, whilst Audacity was recording off the Scarlett 2i2 on the same machine as the broadcast. As the music played after the speech, the computer froze. The computer had to be restarted. No error messages were seen. No investigation was made to look for an Audacity Help Log.

The Error Importing message includes "try importing it using “Import Raw” ". Is that not “Import Raw Data”?

It did not seem to be an issue of slow or fast. to test if speed was a factor the Playback Speed slider was moved across its spectrum.

Some .AU tracks looked like a rectangle from beginning to end. But other .AU tracks looked like normal speech. These AU Files were sampled from the first 250 files, long before the computer froze. Oddly, Audacity froze just now when after one AU and then view switching from waveform to spectrogram. On the second playback, the “needle” did not move over the timeline although the audio could be heard. On the third playback, nothing happened although Audacity’s menu option could be selected. It seems that Playback had stopped. Note that Focusrite 2i2 was not used during this test. Audacity could not be closed. A Windows “ding” sound was heard when trying to close Audacity. Process Explorer showed Audacity as using 23% CPU and over 1000 KB.

The files were initially named with their time stamp. Later they were numbered in time sequence. Finally a sample of 3 files were combined by renaming the AU files using this format: b00NNN (where N = number)(but produced wrong sounds) and then using aud_recover.exe in “”

The autosave files exists, the auto recovery failed. The log is pasted in the reply above to Koz.

Willing to try anything. including another audio editor especially if it has a drag and drop timeline like Adobe Premiere. I would then only have to drop 777 files on it!


Yes, the last few files sounded like chipmunk, speeded up speech.

That would normally be a sample rate issue (kHz). Or, it could be a mono/stereo issue. When you import the raw data, you may have to guess at some of these things.

But if you entered 44,100Hz, I’d be surprised if that was too fast… I wouldn’t expect anything less than 44.1kHz from the Alesis interface.

If the data is truly mono, and you import the raw data as stereo, it’s going to play-back at twice the speed.

…when Win 7 froze necessitating a system reboot.

Computers are the least reliable things we own! :frowning: If you are recording something critical and there’s no possibility of “take-2”, I always recommend a backup system recording in parallel.

…Same thing if you are using a computer for a live performance and the show can’t continue if there’s a computer failure… You need a backup system ready to go!

The autosave file was not dragged into Audacity.
Audacity offered to recover the project upon start up.

Yes. I was replying to it and have now.

I did that earlier and subsequently recovered the AU file with Import Raw Data as a test for my reply above. It could not be done when the computer crashed and that project so far cannot be recovered although there are AU files.

See attached.
New Project - 2014-03-24 16-11-00 N-1.COPY.autosave (937 Bytes)
2014.03 .24-Audacity-Log.txt (2.33 KB)

Mono mic, recorded as a single track, imported as mono. Always working in 44,100Hz.

Good advice. I had a solid state recorder with its own mic as back up. Unfortunately it has some hiss despite being expensive which is why I want to recover the adacity project.

Taking a hint from Gale, I renamed a small sample of files using B0000[n].au format for Audacity Recovery Utility 1.1

It worked!

I will try it on the remaining 770 files

Running the ARU on a large number of files, it creates a large WAV but this is not recognised as a WAV file

Will make further tests

I would caution against running invasive monitoring tools during recording. You want to shut down as many other programs and processes as possible when recording.

Windows 7 has automated defragmentation built in if you allow the computer to be idle and switched on for a reasonable length of time.

Fairly obviously, the last thing you want to do is defragment the drive when recording.

I very much doubt that is an issue. You seem to be recording at 44100 Hz.

There may be a memory dump which could pinpoint the cause of the freeze. Please see: Audacity Manual .

“Import Raw” means “Import Raw Data”, yes.

But the Automatic Crash Recovery dialogue and any errors that are flagged do not give “error importing” or suggest that you use Import Raw. Nothing is being imported when you restart Audacity and Audacity tries to recover the project, or even if you drag the autosave file to the Audacity icon to restart Audacity. So there will be no import failure for the autosave file shown in the log. (I just tried it).

Dragging the autosave file into Audacity or using File > Import > Audio… will produce an import error because you are not supposed to recover a project that way.

You appear to be recording at 44100 Hz according to the autosave file, so an AU file will play at the correct speed without rate changing.

I can’t comment without seeing an AU file that seems to be corrupted.

But I think you have serious problems on your computer.

Please see here for the correct way to first time sort AU files then rename them:
Missing features - Audacity Support .

If you do not time sort the files first, they will be recovered in the wrong order.

The log shows no errors other than an autosave file was imported.

That doesn’t explain what happened and what errors you saw when you restarted Audacity, before you used import raw data on an AU file. The log file you attached doesn’t explain what happened when you first started Audacity after the freeze.

Did you see flat lines instead of your recording, or did Audacity complain about missing or orphaned files?

Note there is no need to use Import Raw for AU files, you can just import them normally. Audacity does not suggest you recover projects by import raw.

As previously explained, the other tool requires you to install Python and use the command-line. It is not a drag-and-drop interface.

You would install python 2.7.6 , then use the script here which would attempt to create a new AUP file from the data: .

Just so you know, the “New Project - 2014-03-24 16-11-00 N-1.COPY.autosave” you attached only links to one AU file so is useless for recovering the project. If you restarted Audacity after the freeze and it tried to recover from that autosave file, it would warn you about 776 orphan block files.


Obviously you are not fully following Missing features - Audacity Support .

You should not use the 1.2 Recovery Utility on more than about 800 AU files.

I would suggest you make a backup copy of the _data folder before sorting and renaming any more files in it, just in case you make a mistake somewhere.