-9997 Invalid Sample Rate

When I try to record I am getting error -9997.

I’m using Audacity 2.4.2 on Windows 10 with Behringuer UMC1820 (Windows WASAPI mode) for both input and output. Sample rate: 32mb, Freq: 48000Hz. Same with every project rate.
Im trying to record six simultaneous tracks. No other programs are running.

No other programs are running.

Does it work in stereo (2-channels) at 44100 sample rate? I know that’s not the goal, but we should establish the system works at all, ever. Wouldn’t we feel silly if after days of troubleshooting, the UMC1820 is broken.

Koz

It work in stereo at 44100Hz in WindowsDirect mode but not in WASAPI.

And thanks, BTW :slight_smile:

Sorry about the delays. Forum posts must be read by an elf before they become visible. Don’t ever try to sell us anything. That’s the kiss of death.

This is where I turn you over to a Windows elf which I’m not. I know there are tricks to getting multi-track to work. Something about proper sacrifices at a full moon.

Koz

For WASAPI you may have to set the number of channels, bitdepth and sampling rate in windows itself, the UMC driver and Audacity to the same settings manually.

Cheers.

I assume you have [speaker icon]>Sounds>Recording>[UMC1820]>Properties>Advanced also set to 48000.

Check out this thread: Problems Using Behringer UMC1820 interface
and this one: Behringer UMC1820 PC Issue

For multi-track recording with Behringer, you may need to use ASIO. First, have you tried MME or Windows DirectSound? You can also check for a different driver on the Behringer web site. If you need ASIO, other software packages including Reaper and Cakewalk may support multi-track recording from Behringer with ASIO. For licensing reasons, Audacity does not ship with ASIO.

If you have the drive, you can compile your own version of Audacity with ASIO, which should allow multi-track recording with your UMC1820. See here: ASIO support in Audacity 2.4.2 - #13 by jademan (BTW this is what I do for my multi-track Behringer).

I hope this helps. :smiley: