Queen Mary Vamp plugin fails

Help for Audacity on Windows.
Forum rules
ImageThis forum is for Audacity on Windows.
Please state which version of Windows you are using,
and the exact three-section version number of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
Elfis
Posts: 9
Joined: Thu Mar 04, 2021 6:10 am
Operating System: Windows 10

Queen Mary Vamp plugin fails

Post by Elfis » Sat May 08, 2021 3:26 am

Hello All,

I am trying to enable the Queen Mary Vamp plugin but I get an error that says it can't load the library. I'm using Windows 10 and am on Audacity version 3.0.2. I was on a later version of 2.x and had the same problem. I was hoping an upgrade to 3.0.2 would fix the problem but it did not.

I read there was at one time a problem with the Queen Mary Vamp plugin on Windows 10 OS....but I thought it had been fixed with an upgraded version prior to (1.8.0).

The plugin shows up in the "Manage Plug ins" dialogue box but when I try to enable it I either get the error mentioned above or it just sits there and does nothing.

Does anyone have any suggestions?

steve
Site Admin
Posts: 81869
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Queen Mary Vamp plugin fails

Post by steve » Sat May 08, 2021 12:41 pm

See if this post helps: viewtopic.php?p=356081#p356081
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

Elfis
Posts: 9
Joined: Thu Mar 04, 2021 6:10 am
Operating System: Windows 10

Re: Queen Mary Vamp plugin fails

Post by Elfis » Sat May 08, 2021 3:59 pm

Thanks Steve. I appreciate you responding and trying to help.

I had already seen that thread and tried it to no avail..... I can see the plugin available in the manage plugins dialogue box but it doesn't work.... At first it showed up as being "New" and when it wouldn't "Enable" I tried changing it to "Disabled" which it did take....but then it would not allow me to switch back out of the "Disabled" state....I even went into the pluginregistry.cfg file and manipulated the plugin to show that it's enabled but the plugin still doesn't load the effects..... Apparently, from a popup I got, it can't register, whatever that means, so it fails to load....Now I don't even get the popup any longer.....

See attachment for the fail notice....download/file.php?mode=view&id=31621
Attachments
QM fail.png
QM fail.png (69.84 KiB) Viewed 116 times

steve
Site Admin
Posts: 81869
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Queen Mary Vamp plugin fails

Post by steve » Sat May 15, 2021 5:21 pm

Elfis wrote:
Sat May 08, 2021 3:59 pm
I had already seen that thread and tried it to no avail.....
but you're still installing the Vamp plug-ins in the wrong place.
That post points to this page in the manual: https://manual.audacityteam.org/man/ana ... .html#vamp
which says that for 64-bit Windows, Vamp plug-ins need to be copied to:

Code: Select all

C:\Program Files (x86)\Vamp Plugins
Also, double check that you have the correct version of the Vamp plug-ins.
I've just tested with "qm-vamp-plugins-1.7-win32.zip" and it works fine with Audacity 3.0.2 (you have to extract the contents of the ZIP file and put them into: C:\Program Files (x86)\Vamp Plugins\
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

Post Reply