Play using macros/Cut preview has a progress bar

Feedback and Reviews for Audacity 3.x
Forum rules
This board is ONLY for general feedback and discussion about Audacity 3.X.

If you require help, or think you have found a "bug", please post on the forum board relevant to your operating system.
Windows
Mac OS X
GNU/Linux and Unix-like
Post Reply
pokery
Posts: 3
Joined: Sun Apr 04, 2021 3:27 pm
Operating System: Windows 10

Play using macros/Cut preview has a progress bar

Post by pokery » Sun Apr 04, 2021 3:36 pm

Audacity 3.0.0
Windows 10

I use the various macros that involve playing audio. In 2.4.x, I could play fine using commands like "Play After Selection End" but now, there is a progress bar that appears while playing. The title is "Progesss" and the progress bar is as long as the audio I want to play. This also happens when I press the C key to do cut preview. The "Play" macro command works like it did in 2.4.x

I presume what is happening is that it now believes the playing is something to be counted in the overall macro progress so it gives the progress bar but what it actually does is create lag. "Cut preview" is barely usable as a result.

Love Audacity and thanks for the update!

jademan
Forum Crew
Posts: 1278
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: Play using macros/Cut preview has a progress bar

Post by jademan » Mon Apr 05, 2021 3:43 pm

pokery wrote:
Sun Apr 04, 2021 3:36 pm
"Cut preview" is barely usable as a result.
Thank you for your report. There was another report of potential conflicts of the progress bar during macros when invoked by a python script. Perhaps there is a solution that could address both situations.

Can you provide a clear example demonstrating you issue? Thanks.

steve
Site Admin
Posts: 81231
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Play using macros/Cut preview has a progress bar

Post by steve » Mon Apr 05, 2021 5:41 pm

jademan wrote:
Mon Apr 05, 2021 3:43 pm
There was another report of potential conflicts of the progress bar during macros when invoked by a python script.
I think that's been fixed for Audacity 3.0.1 (scheduled for release later this month).

I was not able to reproduce any problem with Cut Preview.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

pokery
Posts: 3
Joined: Sun Apr 04, 2021 3:27 pm
Operating System: Windows 10

Re: Play using macros/Cut preview has a progress bar

Post by pokery » Tue Apr 06, 2021 3:01 am

steve wrote:
Mon Apr 05, 2021 5:41 pm
I was not able to reproduce any problem with Cut Preview.
Sorry, I should have clarified that it is Cut Preview as a macro command. I realised that I had changed the C key to a 2 step macro (zero crossing, then cut preview).

steve
Site Admin
Posts: 81231
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Play using macros/Cut preview has a progress bar

Post by steve » Tue Apr 06, 2021 9:58 am

pokery wrote:
Tue Apr 06, 2021 3:01 am
Sorry, I should have clarified that it is Cut Preview as a macro command. I realised that I had changed the C key to a 2 step macro (zero crossing, then cut preview).
I still can't reproduce the problem. The macro works fine for me with those two commands.

When the "Audacity 3.0.1 release candidate" becomes available, please try that to see if it makes any difference.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

pokery
Posts: 3
Joined: Sun Apr 04, 2021 3:27 pm
Operating System: Windows 10

Re: Play using macros/Cut preview has a progress bar

Post by pokery » Sat May 01, 2021 4:29 am

steve wrote:
Tue Apr 06, 2021 9:58 am
pokery wrote:
Tue Apr 06, 2021 3:01 am
Sorry, I should have clarified that it is Cut Preview as a macro command. I realised that I had changed the C key to a 2 step macro (zero crossing, then cut preview).
I still can't reproduce the problem. The macro works fine for me with those two commands.

When the "Audacity 3.0.1 release candidate" becomes available, please try that to see if it makes any difference.
The issue is still there in Audacity 3.0.2 for me. Try creating a macro that just contains the "Play after seletion end" function, select a bit of audio and run it. A progress bar should appear during playback instead of just playing it.

jademan
Forum Crew
Posts: 1278
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: Play using macros/Cut preview has a progress bar

Post by jademan » Sun May 02, 2021 11:31 am

pokery wrote:
Sat May 01, 2021 4:29 am
The issue is still there in Audacity 3.0.2 for me. Try creating a macro that just contains the "Play after seletion end" function, select a bit of audio and run it. A progress bar should appear during playback instead of just playing it.
I can confirm the progress bar appears in 3.0.2.
pokery wrote:
Sun Apr 04, 2021 3:36 pm
it gives the progress bar but what it actually does is create lag.
For my limited testing with a single short audio clip, I noticed no degradation in time (over for example Extra > Transport > Play After Selection End). Note that the developers are currently conducting a study of Macros and their interactions.

Post Reply