Label Cursor bug introduced in v3.1.0

Feedback and Reviews for Audacity 3.x
Forum rules
This board is ONLY for general feedback and discussion about Audacity 3.X.

If you require help, or think you have found a "bug", please post on the forum board relevant to your operating system.
Windows
Mac OS X
GNU/Linux and Unix-like
Post Reply
domenicostefani
Posts: 2
Joined: Mon Dec 20, 2021 2:29 pm
Operating System: Windows 10

Label Cursor bug introduced in v3.1.0

Post by domenicostefani » Mon Dec 20, 2021 3:14 pm

Hi, I would like to report a bug that seems to have been introduced in version 3.1.0
The bug, which I will now explain in detail, was present in at least version 3.1.0 and the latest 3.1.2 on a Windows 10 computer (Not tested on other OSs).
Versions 3.0.2 and 3.0.5 instead work correctly (Both on Windows 10 and Ubuntu 20.04).

Issue
The issue is with the cursor NOT snapping to the position of a single-point label when clicking on its textbox.

Details
The snapping behavior was present in at least version 3.0.2 and 3.0.5, and it is crucial for precise alignment of the position of labels.
I used to be able to click on the text of a point label (not region) and have the cursor automatically align with the position of the label.
Then I would move around the label and the cursor moved along with the label itself, which helped to align it to events in the audio signal.

Now I can still click on the textbox of a label (and edit the text) but the cursor remains where it is.
Moving the label results in having no precise idea of where it is with respect to the signal on other tracks.

Attachments
The following attachments show how, in the newer version, the textbox of the label is selected but the cursor is still somewhere else.
Please, disregard the fact that on these screenshots the cursor is always at the beginning of some activity in the signal: my point is that the cursor used to be automatically aligned with the actual position of the label, which in the first case (working) corresponds also to the beginning of a note in the signal, while in the second (not working) it corresponds to few ms before.

Working function (v3.0.2, Windows 10):
working3-0-2.jpg
working3-0-2.jpg (177.69 KiB) Viewed 195 times


Not working (v3.1.0, Windows 10):
notworking3-1-0.jpg
notworking3-1-0.jpg (167.15 KiB) Viewed 195 times
I hope this can be fixed in the next release, it is really useful for onset labeling on music datasets :)
Have a nice day.

waxcylinder
Forum Staff
Posts: 14974
Joined: Tue Jul 31, 2007 11:03 am
Operating System: Windows 10

Re: Label Cursor bug introduced in v3.1.0

Post by waxcylinder » Mon Dec 20, 2021 4:57 pm

I have logged this as a regression bug on GitHub

Clicking in a label's text box fails to move the cursor #2319
https://github.com/audacity/audacity/issues/2319

As I note in the bug thread:
a) There is mitigation for region labels as you can now click on the label's drag-bar.
b) There is no mitigation for point labels as there is no drag-bar for a point label.

Thanks for the report :) 8-)

Peter
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * FAQ * * * * * Tutorials * * * * * Audacity Manual * * * * *

waxcylinder
Forum Staff
Posts: 14974
Joined: Tue Jul 31, 2007 11:03 am
Operating System: Windows 10

Re: Label Cursor bug introduced in v3.1.0

Post by waxcylinder » Mon Dec 20, 2021 5:07 pm

@domenicostefani:

your workaround is to hover in the waveform near the label position and when the yellow snap guide appears on the waveform clock to move the cursor there (the yellow snap guide is "sticky" in regard to the label).

Peter
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * FAQ * * * * * Tutorials * * * * * Audacity Manual * * * * *

domenicostefani
Posts: 2
Joined: Mon Dec 20, 2021 2:29 pm
Operating System: Windows 10

Re: Label Cursor bug introduced in v3.1.0

Post by domenicostefani » Mon Jan 10, 2022 11:00 am

Thank you very much

Post Reply