mute track macro not working

Questions, discussion and recipes for scripting and batch processing in Audacity.
See also the "Scripting" section of the Audacity manual.
Forum rules
If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like
babag
Posts: 33
Joined: Fri Sep 18, 2020 10:09 pm
Operating System: Linux *buntu

mute track macro not working

Post by babag » Sun Nov 08, 2020 6:50 pm

couple of things. first, i tried to mute a track using:

MuteTracks:

found that in the manual but it throws an error:
Your batch command of MuteTracks was not recognized.
same for 'unmutetracks.'

i did find that MuteAllTracks and UnmuteAllTracks both worked, as did TrackMute. problem with TrackMute, though, is that it is a toggle and requires focus to be set. i was hoping for a simple command to set the state either on or off.

second, somewhere in the manual i found a note that i could comment in macros with the # symbol but that also threw up an error.

editing my post before i even am posting it, here. found that i can use 'set track,' turning all options off except the 'mute' checkboxes. still new enough at this that i'm confused as to why i have to check two (both) boxes to have the mute apply. it seems that selecting both checkboxes selects 'mute' and selecting only the left checkbox selects 'unmute.' confusing but seems to work.

thanks,
babag

babag
Posts: 33
Joined: Fri Sep 18, 2020 10:09 pm
Operating System: Linux *buntu

Re: mute track macro not working

Post by babag » Sun Nov 08, 2020 6:57 pm

actually, maybe the easiest thing i'm finding, which avoids the checkboxes altogether is manually adding this:

Code: Select all

SetTrack:Mute="1"
or this:

Code: Select all

SetTrack:Mute="0"
directly to the macro txt file. haven't found the documentation on that, though.

still, would be better if i could get the very straightforward 'MuteTracks' to work.

babag

steve
Site Admin
Posts: 81226
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: mute track macro not working

Post by steve » Sun Nov 08, 2020 7:06 pm

babag wrote:
Sun Nov 08, 2020 6:50 pm
i tried to mute a track using:

MuteTracks:

found that in the manual but it throws an error:

Your batch command of MuteTracks was not recognized.

same for 'unmutetracks.'
Works for me with Audacity 2.4.2 on Xubuntu.
Are you using an older version of Audacity?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

babag
Posts: 33
Joined: Fri Sep 18, 2020 10:09 pm
Operating System: Linux *buntu

Re: mute track macro not working

Post by babag » Sun Nov 08, 2020 7:08 pm

as for commenting with #, seems i can't use it to comment out a command as the command is read even if it follows the # symbol. seems to work for making notes but not for commenting out test commands.

babag
Posts: 33
Joined: Fri Sep 18, 2020 10:09 pm
Operating System: Linux *buntu

Re: mute track macro not working

Post by babag » Sun Nov 08, 2020 7:09 pm

thanks, steve. i'm on 2.3.3. it comes with ubuntu studio i think. don't think i installed it myself.

thanks again,
babag

steve
Site Admin
Posts: 81226
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: mute track macro not working

Post by steve » Sun Nov 08, 2020 7:11 pm

babag wrote:
Sun Nov 08, 2020 6:50 pm
second, somewhere in the manual i found a note that i could comment in macros with the # symbol but that also threw up an error.
That was an unofficial "feature". Again it works for me in Audacity 2.4.2, though the comment does not appear in the Macro editor.

In the next version of Audacity there is an official (supported) command for comments:

Code: Select all

Comment:_="This is a comment"
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

steve
Site Admin
Posts: 81226
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: mute track macro not working

Post by steve » Sun Nov 08, 2020 7:14 pm

babag wrote:
Sun Nov 08, 2020 6:50 pm
i'm confused as to why i have to check two (both) boxes to have the mute apply.
The first box selects to send or not sent the parameter.
The second box selects the value of the parameter (true / false).

I posted about this in more detail somewhere - I'll see if I can find it....
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

steve
Site Admin
Posts: 81226
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: mute track macro not working

Post by steve » Sun Nov 08, 2020 7:16 pm

steve wrote:
Sun Nov 08, 2020 7:14 pm
I posted about this in more detail somewhere - I'll see if I can find it....
Here: viewtopic.php?p=407665#p407665
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

babag
Posts: 33
Joined: Fri Sep 18, 2020 10:09 pm
Operating System: Linux *buntu

Re: mute track macro not working

Post by babag » Sun Nov 08, 2020 7:25 pm

thanks for all the info, steve. yeah, funnily enough, hahaha, that detailed description of checkboxes was also in response to me. obviously i remain confused. it does seem a pretty klunky way of handling things. i like the direct text entry for now. looks like at least one other user was also confused about the checkboxes too. wish there was a label or something like 'engage' or 'active' over one column of the boxes and 'value' over the other. might make things a little more transparent.

unfortunately, for now, i have to stick with 2.3.3 as i'm helping someone figure out how to do some of these things in audacity and this is the version she's on. need to maintain as much compatibility as i can.

thanks again,
babag

steve
Site Admin
Posts: 81226
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: mute track macro not working

Post by steve » Sun Nov 08, 2020 7:39 pm

I've added a note about this for the next version of the manual: https://alphamanual.audacityteam.org/ma ... Parameters
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

Post Reply