3.0 does not record or playback sound in Catalina 10.15.7

Feedback and bug reports for Audacity 3.0.3 alpha
Forum rules
This forum is only for feedback and bug reports for the specified version of Audacity.

All bug reports must include the following information:
  • Exact version number of Audacity
  • Operating system version
  • Brief description of the problem
  • Detailed, step by step instructions for how to reproduce the problem
Bug reports that do not include the above information will be deleted

Additional information and / or screenshots should be included as necessary to adequately describe the problem.
Post Reply
ricardo57
Posts: 7
Joined: Thu Dec 17, 2020 4:08 pm
Operating System: macOS 10.15 Catalina or later

3.0 does not record or playback sound in Catalina 10.15.7

Post by ricardo57 » Sun Mar 07, 2021 1:30 am

Hello,
I have been using Audacity for many years, but... since I moved from an old MacBook Pro to a new one (2019 - 2.3 GHz 8-Core Intel Core i9) running under Catalina 10.15.7, Audacity 3.0.0 or 2.x.x do not record or playback any sound.

I have tried everything I read in the Forum but nothing works.
Audacity does not show either in Preferences -> Security & Privacy -> Microphone.

Please, see the screen Shots attached.
Thanks for your help. Ricardo
Screen Shot 2021-03-06 at 8.26.00 PM.png
not playing back a sound file
Screen Shot 2021-03-06 at 8.26.00 PM.png (758.81 KiB) Viewed 392 times
Screen Shot 2021-03-06 at 8.27.22 PM.png
no recording
Screen Shot 2021-03-06 at 8.27.22 PM.png (641.25 KiB) Viewed 392 times

jademan
Forum Crew
Posts: 1274
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: 3.0 does not record or playback sound in Catalina 10.15.7

Post by jademan » Mon Mar 08, 2021 1:43 pm

ricardo57 wrote:
Sun Mar 07, 2021 1:30 am
Hello,
I have been using Audacity for many years, but... since I moved from an old MacBook Pro to a new one (2019 - 2.3 GHz 8-Core Intel Core i9) running under Catalina 10.15.7, Audacity 3.0.0 or 2.x.x do not record or playback any sound.

I have tried everything I read in the Forum but nothing works.
Audacity does not show either in Preferences -> Security & Privacy -> Microphone.
ricardo57, Windows guy here. I see you have been struggling with this issue for several months now. Quick question: do you get the error when you try to play a chirp or tone? Or is the issue always related to recording?

Have you tried the suggestion in this post? viewtopic.php?p=417869#p417869

ricardo57
Posts: 7
Joined: Thu Dec 17, 2020 4:08 pm
Operating System: macOS 10.15 Catalina or later

Re: 3.0 does not record or playback sound in Catalina 10.15.7

Post by ricardo57 » Mon Mar 08, 2021 9:26 pm

Hello jademan. Thanks for your post!!
Yes, I was having the same problem when generating a chirp sound.
I tried the different suggestions using Terminal but didn't work.

Now, I followed your suggestion and deleted the 142 plug-ins in the Library/Audio/Plug-Ins/Components folder and ... Audacity works!!
Great, many thanks...!!

Now the issue is that I was using a lot my plug-ins. I brought back some (about 6-7) to the Components folder and Audacity work and the plug-ins, too, but if I bring back all of those plug-ins, then nothing works. Is there a limit in the number of plug-ins Audacity recognizes now or is it a different problem? I had them all working in my previous version of Audacity 2.4.x using an older MacBook Pro running Mojave.

Thank you again!
Ideas about how to have the plug-ins working, are very welcomed :-)

steve
Site Admin
Posts: 81227
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: 3.0 does not record or playback sound in Catalina 10.15.7

Post by steve » Mon Mar 08, 2021 9:43 pm

ricardo57 wrote:
Mon Mar 08, 2021 9:26 pm
I brought back some (about 6-7) to the Components folder and Audacity work and the plug-ins, too, but if I bring back all of those plug-ins, then nothing works. Is there a limit in the number of plug-ins Audacity recognizes now or is it a different problem?
There isn't a limit to the number. There's probably a rogue plug-in in there that's causing the problem.
Try putting them in say 10 at a time. If Audacity stops working then take those ten out and replace them one at a time.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

jademan
Forum Crew
Posts: 1274
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: 3.0 does not record or playback sound in Catalina 10.15.7

Post by jademan » Mon Mar 08, 2021 10:49 pm

steve wrote:
Mon Mar 08, 2021 9:43 pm
There's probably a rogue plug-in in there that's causing the problem.
Try putting them in say 10 at a time. If Audacity stops working then take those ten out and replace them one at a time.
... and if you zero in on the offending rascal, please report back so others know so they aren't chasing their tails. And perhaps developers can even duplicate it and fix it. :D

ricardo57
Posts: 7
Joined: Thu Dec 17, 2020 4:08 pm
Operating System: macOS 10.15 Catalina or later

Re: 3.0 does not record or playback sound in Catalina 10.15.7

Post by ricardo57 » Tue Mar 09, 2021 3:12 am

Thanks, steve and jademan.
I couldn't identify any specific plug-in yet but will work on it and will report any findings.

Post Reply