Apple Silicon...

Feedback and bug reports for Audacity 3.0.3 alpha
Forum rules
This forum is only for feedback and bug reports for the specified version of Audacity.

All bug reports must include the following information:
  • Exact version number of Audacity
  • Operating system version
  • Brief description of the problem
  • Detailed, step by step instructions for how to reproduce the problem
Bug reports that do not include the above information will be deleted

Additional information and / or screenshots should be included as necessary to adequately describe the problem.
billw58
Forum Staff
Posts: 5589
Joined: Wed Aug 12, 2009 2:10 am
Operating System: macOS 10.15 Catalina or later

Re: Apple Silicon...

Post by billw58 » Fri Mar 19, 2021 6:53 pm

wissme wrote:
Thu Mar 18, 2021 3:24 pm
I have no check mark in the menus with options, also no arrow indicating a submenu. Am I the only one ???? Is is difficult to know what options is checked when ther is no check mark...
I do not have this problem on my M1 Macbook Air under Big Sur. We have had no other reports of this. You may be the only one.
-- Bill

jademan
Forum Crew
Posts: 1279
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: Apple Silicon...

Post by jademan » Fri Mar 19, 2021 9:04 pm

Thanks for trying to see if you can duplicate the problem with 3.0.0 :!:

I tried setting my Audacity language preference to Français here on Windows 10 with both Audacity 2.4.2 and Audacity 3.0.0 and am not able to duplicate your issue. :?

Perhaps someone on Mac can take a look your menu issue :?:

In the meantime, try Tools > Reset Configuration and/or rebooting.

I hope this helps. :D

Bill: I just saw you post now...

jademan
Forum Crew
Posts: 1279
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: Apple Silicon...

Post by jademan » Sat Mar 20, 2021 10:41 pm

wissme,

As you know, you are the only one using Audacity that has reported this problem so far. However, there appear to be reports of a similar issue with the wxWidgets software package, which is incorporated into Audacity.

The problem seems to be related to certain locale settings other than English, specifically German, French, and Russian. It has been reported to occur with Mac OS 11.1, 11.2, and 11.3 (beta). I do not know if it is specifically an M1 issue.

I have reported this issue to our developers on your behalf. However, I do not anticipate an overnight fix.
===
I have copied this post (with translation) to the French forum.

James Crook
Posts: 34
Joined: Thu May 28, 2015 7:35 pm
Operating System: Please select

Re: Apple Silicon...

Post by James Crook » Sat Mar 20, 2021 11:16 pm

For reference:

https://forums.wxwidgets.org/viewtopic.php?f=23&t=48118
https://trac.wxwidgets.org/ticket/19023

It seems to be macOS uses SVG in forming the menus, and numbers in the SVG are misread when using a language with comma as a decimal separator in numbers.

Post Reply