Missing audio data block file(s)

Bug reports for Audacity 2.3.1 alpha
Forum rules
This forum is only for feedback and bug reports for the specified version of Audacity.

All bug reports must include the following information:
  • Exact version number of Audacity
  • Operating system version
  • Brief description of the problem
  • Detailed, step by step instructions for how to reproduce the problem
Bug reports that do not include the above information will be deleted

Additional information and / or screenshots should be included as necessary to adequately describe the problem.
Post Reply
Sam_.hill
Posts: 2
Joined: Sun Aug 05, 2018 11:31 pm
Operating System: Windows 10

Missing audio data block file(s)

Post by Sam_.hill » Sun Aug 05, 2018 11:53 pm

I changed the name of my audacity project, I tgen opened straight after and it said error data not found. I then changed back to its original name and nothing came up. I go to file>import, then i imported the file back and it came up with the message; missing audio data block file(s), i then clicked; treat missing audio as silince (this session only) hoping to get everything back. It loads but all my audio is silinced. This project took my hours to make and I'm devestated, does anyone know how I can get my audio back

kozikowski
Forum Staff
Posts: 41531
Joined: Thu Aug 02, 2007 5:57 pm
Operating System: OS X 10.9 Mavericks

Re: Missing audio data block file(s)

Post by kozikowski » Mon Aug 06, 2018 2:25 am

I changed the name of my audacity project
You can only change the name of the Project inside Audacity, not in the file system.
opened straight after and it said error data not found.
Right. Because it was looking for the old _DATA folder name burned into the AUP file. Like This.

Image

If you open the AUP file in a text editor, it should still be there (don't save anything).
I then changed back to its original name
That should have worked. The AUP file and the _DATA folder have to have the same name and it has to be the name you gave it originally and the one burned into the AUP file. Both the AUP file and the _DATA have to be in the same location and folder or they won't be able to find each other.
It loads but all my audio is silinced.
I don't know. We should wait for a senior forum elf.

Koz

steve
Site Admin
Posts: 49006
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Missing audio data block file(s)

Post by steve » Mon Aug 06, 2018 9:07 pm

Sam_.hill wrote:
Sun Aug 05, 2018 11:53 pm
I changed the name of my audacity project
An Audacity project is not a single file. It is a "project file" (which has ".AUP" as the file extension) AND the audio data. In saved projects, the audio data is usually in a folder that has the same name as the project with "_data" added to the end.

When you say that you "changed the name of my audacity project", do you mean that you changed the name of the "project file" and that is all that you changed?

If you only changed the name of the Audacity project file, then (although you should not do that), the project will still work.
Sam_.hill wrote:
Sun Aug 05, 2018 11:53 pm
I tgen opened straight after and it said error data not found.
Changing the name of the project file will not cause that to happen.
Changing the name of the _data folder, or moving the _data folder, or deleting the _data folder, or moving the "project" file away from the _data folder can cause that error.

You must have done more than only changing the name of the project file. Any idea what you did?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

waxcylinder
Forum Staff
Posts: 9666
Joined: Tue Jul 31, 2007 11:03 am
Operating System: Windows 10

Re: Missing audio data block file(s)

Post by waxcylinder » Tue Aug 07, 2018 9:34 am

Whet version number (all three numbers) are you using?
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * FAQ * * * * * Tutorials * * * * * Audacity Manual * * * * * Audacity Wiki * * * * *

Sam_.hill
Posts: 2
Joined: Sun Aug 05, 2018 11:31 pm
Operating System: Windows 10

Re: Missing audio data block file(s)

Post by Sam_.hill » Tue Aug 07, 2018 1:10 pm

Well, i feel really stupid I changed the project name back to its original name and all the audio is back now. Lesson learnt, my apologies thankyou very much for your time.

Post Reply