possible bug on 2.2.2

Feedback and Reviews for Audacity 2.x
Forum rules
This board is ONLY for general feedback and discussion about Audacity 2.X.

If you require help, or think you have found a "bug", please post on the forum board relevant to your operating system.
Windows
Mac OS X
GNU/Linux and Unix-like
Post Reply
frantzgac
Posts: 0
Joined: Sun May 23, 2010 4:17 pm
Operating System: Please select

possible bug on 2.2.2

Post by frantzgac » Fri Jun 01, 2018 3:40 pm

Hello
I use toshiba tecra A11 computer with Windows Seven Pro.
Recording voice throuhg USB-122mkII Tascam (with two static microphone requiring phantom alim) with Audacity 2.2.2 some troubles happen :
Sometime the level sound heard in headphone turns down (but not disappears) during some ms .
I try five times to record voice during 20 sec, each time except one, this phenomenon appears to different time.
The curve doesn't show this fact (I catch printscreen of curve amplified). So I try to export projet to MP3 to eliminate reading cause process trouble. MP3 file (with VLC) produces also the phenomenon.
So i uninstall Audacity 2.2.2 and reinstal 2.1.0 and record again voice.
Three times not shows the problem.
As i use high Prefrences/Quality : 96000Khz / Best Quality to match with frequency of USB-122Mkii Tascam my questions are :
Is it possible that high frequency resolution troubles records ?
Is it possible thaht multiple background tasks of OS causes trouble during recording ?
And more : is there some precautions (stop some services..) to avoid trouble during recording in Windows environment
Thanks for advance

steve
Site Admin
Posts: 48679
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: possible bug on 2.2.2

Post by steve » Sat Jun 02, 2018 12:12 pm

Sorry but I don't understand your question.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

frantzgac
Posts: 0
Joined: Sun May 23, 2010 4:17 pm
Operating System: Please select

Re: possible bug on 2.2.2

Post by frantzgac » Tue Jun 05, 2018 5:57 pm

Sorry
I try easier and shorter explanations :
After recording voice with Audacity 2.2.1 I listen recording track.
I can hear that the sound turns down suddenly in [6,75-7,25] and [10-10,2]
I join project files as you can hear the problem
Thanks for help
Attachments
TestRec2Pb1_upload.aup
(1.23 KiB) Downloaded 26 times

steve
Site Admin
Posts: 48679
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: possible bug on 2.2.2

Post by steve » Tue Jun 05, 2018 6:40 pm

An AUP file is not an audio file, it is just part of an Audacity project (the other part is the "_data" folder that contains the audio data. For more information, see: https://manual.audacityteam.org/man/aud ... jects.html)
frantzgac wrote:I can hear that the sound turns down suddenly
That is probably caused by a "sound enhancement" in the Windows sounds settings. See here for how to turn Windows sounds enhancements off: https://manual.audacityteam.org/man/faq ... hancements
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

frantzgac
Posts: 0
Joined: Sun May 23, 2010 4:17 pm
Operating System: Please select

Re: possible bug on 2.2.2

Post by frantzgac » Wed Jun 06, 2018 1:53 pm

Thank for answer
Sorry I would join a zip file with set of audacity project but just one file has been sent.
I read link about "windows enhancement" and check tuning of mmsys.cpl without find any reasons to explain the problem.
I will try to reinstal 2.2.2 version to check again
Attachments
Test3Micro2BenesonUpload.zip
(1.44 MiB) Downloaded 12 times

steve
Site Admin
Posts: 48679
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: possible bug on 2.2.2

Post by steve » Wed Jun 06, 2018 3:44 pm

Try using a lower sample rate (44100 Hz)
The sound is getting mangled, which could be due to the computer failing to keep up with the very high sample rate.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

frantzgac
Posts: 0
Joined: Sun May 23, 2010 4:17 pm
Operating System: Please select

Re: possible bug on 2.2.2

Post by frantzgac » Tue Jun 12, 2018 4:37 pm

Problem appears also on Audcity 2.1.0.
Between microphone and computer there is a amplifier/digitaliser.
This device (tascam usb 122 mark ii) provides a 96000 Hz signal.
This is reason for tuning 96Khz.
But i will try to record on 44100 Khz

Thanks

frantzgac
Posts: 0
Joined: Sun May 23, 2010 4:17 pm
Operating System: Please select

Re: possible bug on 2.2.2

Post by frantzgac » Sun Jun 17, 2018 4:53 pm

Hi
To day I record many tracks without problem on 2.2.2 or 2.1.0 Audacity
It seems that special and rares conditions needs cause the alteration of signal recorded.

But I observe another fact very interesting.
Varying sample rate Windows sound parameters and in Audacity preferences I create conditions to another problems :

I record a short track, stop and record another track. Normaly a second track is created (for 2.1.0 version) when starts second record.
In some case the second record doesn't start and after 10 seconds a message appears "error while opening sound device"
To record again 2 solutions : delete the first layer or close/open Audacity.
This problem disappears if sample rate of device Tascam in windows properties is different than 44100 Hz.
The sample rate of Audacity has no effect on this behavior.

frantzgac
Posts: 0
Joined: Sun May 23, 2010 4:17 pm
Operating System: Please select

Re: possible bug on 2.2.2

Post by frantzgac » Wed Jun 20, 2018 12:35 pm

New fact

1) Error in previous post. The record freeze seems happen only if windows sample rate is higher than 44100 Khz
2) During record sequence, the record freeze also with 44100 Khz.

To resolve the problem : close Audacity, Off/On phantom alimentation of USB 122 Tascam, run again Audacity

The problem finally would not may be caused by sample rate...

Post Reply