segmentation fault when run (on Mac running Ubuntu 16.04)

Help for Audacity 2.x.x on GNU/Linux.
Forum rules
ImageThis forum is for Audacity 2.x.x on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
laertes
Posts: 9
Joined: Tue Aug 29, 2017 12:40 am
Operating System: OS X 10.11 El Capitan or later (macOS)

segmentation fault when run (on Mac running Ubuntu 16.04)

Post by laertes » Fri Jan 19, 2018 1:03 am

Hello Gurus. I installed a fresh version of Ubuntu 16.04.3 on my late-2015 retina Macbook Pro and was able to compile audacity 2.2.0 as follows:

Step 1: First, installed the required wxWidgets 3.0.2
Step 2: Second, installed audacity 2.2.0 by the following steps:
cd audacity directory (created when extracting the audacity zip file)
mkdir build
cd build
../configure --enable-debug
make -j4
sudo make install

When I run it I get a segmentation fault with the error messages shown in the screenshots.

Fairly new to both linux/Ubuntu and Audacity, so not sure where to start in solving this. Looked around but couldn't find any pre-existing remedies. Any ideas/suggestions would be greatly appreciated.

Thank you!
Shot1.png
Shot1.png (263.51 KiB) Viewed 908 times
Shot2.png
Shot2.png (237.04 KiB) Viewed 908 times

steve
Site Admin
Posts: 47940
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: segmentation fault when run (on Mac running Ubuntu 16.04

Post by steve » Mon Jan 22, 2018 1:46 pm

I can't tell from the screenshots what the problem might be - it could be anything.
Also, I've no experience running Linux on a Mac, and have no idea what gremlins may lie therein (but I'd guess there are lots).

The first thing that I'd be checking out is the sound system. Audacity is like the canary in a mine - if there's any problem with the sound system, Audacity will baulk.
Things to check:
  • Do simple audio I/O applications work (such as arecord and aplay)?
  • Is PulseAudio properly installed and working? (PulseAudio is the default sound server for Ubuntu)
  • Does PulseAudio Volume Control (pavucontrol) show input and output devices?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

laertes
Posts: 9
Joined: Tue Aug 29, 2017 12:40 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: segmentation fault when run (on Mac running Ubuntu 16.04

Post by laertes » Sat Jan 27, 2018 1:54 am

steve wrote:I can't tell from the screenshots what the problem might be - it could be anything.
Also, I've no experience running Linux on a Mac, and have no idea what gremlins may lie therein (but I'd guess there are lots).

The first thing that I'd be checking out is the sound system. Audacity is like the canary in a mine - if there's any problem with the sound system, Audacity will baulk.
Things to check:
  • Do simple audio I/O applications work (such as arecord and aplay)?
  • Is PulseAudio properly installed and working? (PulseAudio is the default sound server for Ubuntu)
  • Does PulseAudio Volume Control (pavucontrol) show input and output devices?
Ok, I'll start plugging away and will post to the forum anything useful I might discover along the way. Thank you!

Post Reply