Can not build 2.2.0

Help for Audacity 2.x.x on GNU/Linux.
Forum rules
ImageThis forum is for Audacity 2.x.x on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
lamainfroide
Posts: 3
Joined: Sun Sep 24, 2017 4:26 pm
Operating System: GNU/Linux other

Can not build 2.2.0

Post by lamainfroide » Sun Sep 24, 2017 4:32 pm

I can not build Audacity version 2.2.0-beta because a lot of things (e.g libidtag, libogg ...) are missing in lib-src ...
OS: Arch Linux 64 bits up to date (09.24.2017)

lamainfroide
Posts: 3
Joined: Sun Sep 24, 2017 4:26 pm
Operating System: GNU/Linux other

Re: Can not build 2.2.0

Post by lamainfroide » Tue Sep 26, 2017 12:13 pm

It's me again!..

The compilation was not possible with source from https://www.fosshub.com/Audacity.html

it is with source from github..

steve
Site Admin
Posts: 47293
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: Can not build 2.2.0

Post by steve » Tue Sep 26, 2017 2:09 pm

How far are you getting?
Do you have wxGTK 3.0.2 installed?
What error messages are you getting?
Have you been able to build any version of Audacity?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

Post Reply