Audacity set USB microphone with volume list

Help for Audacity 2.x.x on GNU/Linux.
Forum rules
ImageThis forum is for Audacity 2.x.x on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
luya
Posts: 1
Joined: Fri Feb 17, 2017 6:46 am
Operating System: Linux Fedora/RHEL

Audacity set USB microphone with volume list

Post by luya » Fri Feb 17, 2017 6:57 am

Hello Audacity team,
I would like to report a bug with Audacity 2.1.3 currently available on Fedora 25 about the setting while working with a client for online course video recording.
Once a USB external microphone (in my case a Samson Meteor (http://www.samsontech.com/samson/produc ... meteormic/) is properly detected, Audacity wrongly assigned it to the volume setting for recording while it should set to the microphone list thus disabling its volume. When it comes to playback, I had to manual set the volume to default to listen the recording. It is a minor inconvenience as I quickly figured out the workaround.

Could anyone with a USB microphone reproduce the mentioned bug above and fix it please?
Thank you for the excellent audio editor.

Luya

Gale Andrews
Quality Assurance
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10
Contact:

Re: Audacity set USB microphone with volume list

Post by Gale Andrews » Fri Feb 17, 2017 1:46 pm

luya wrote:I would like to report a bug with Audacity 2.1.3 currently available on Fedora 25 about the setting while working with a client for online course video recording.
Once a USB external microphone (in my case a Samson Meteor (http://www.samsontech.com/samson/produc ... meteormic/) is properly detected, Audacity wrongly assigned it to the volume setting for recording while it should set to the microphone list thus disabling its volume. When it comes to playback, I had to manual set the volume to default to listen the recording. It is a minor inconvenience as I quickly figured out the workaround.

Could anyone with a USB microphone reproduce the mentioned bug above and fix it please?
Thanks. 2.1.3 has not been released yet - it is due out on the 20th. Do you have some packaged Audacity build provided by Fedora?

If you build Audacity HEAD from source code does it have the same problem?

Also sorry but I don't understand your description. What list and volume setting are you referring to? ALSAMixer, or Pulse Audio Volume Control? Can you post a screen shot of what you are looking at?

Also please post Help > Audio Device Info... (top right of Audacity). Please see how to attach files to forum posts.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual

Post Reply