Audacity before 2.1.2 is unstable if built with wxWidgets 3.x

Help for Audacity 2.x.x on GNU/Linux.
Forum rules
ImageThis forum is for Audacity 2.x.x on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Locked
Gale Andrews
Quality Assurance
Posts: 25981
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Audacity before 2.1.2 is unstable if built with wxWidgets 3.x

Post by Gale Andrews » Sat Apr 04, 2015 5:32 pm

Some Linux distributions are supplying Audacity builds that are unstable because built with wxWidgets 3.x.

Audacity 2.1.1 and earlier do not support wxWidgets 3.x versions, therefore if Audacity is built with such a version there will be many bugs. This applies for example to Ubuntu "Daily Builds", Ubuntu Vivid and Debian Jessie. Please check Help > About Audacity... then the "Build Information" tab to check the version of wxWidgets that Audacity is built with.

If you find bugs in Audacity built with wx3 that are not already known about, please post on the Linux board of this Forum.
Last edited by Gale Andrews on Sat Dec 12, 2015 12:22 pm, edited 5 times in total.

Locked