Audacity-2 for x68-64 ?

Help for Audacity 2.x.x on GNU/Linux.
Forum rules
ImageThis forum is for Audacity 2.x.x on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
bvv2001
Posts: 2
Joined: Tue Mar 20, 2012 11:05 pm
Operating System: Please select

Audacity-2 for x68-64 ?

Post by bvv2001 » Tue Mar 20, 2012 11:12 pm

I use Slackware-13.1 x86-64 version. Then I do compile new version audacity for my PC I take this error

Code: Select all

configure: Checking that the chosen version of wxWidgets is 2.8.x
configure: error: Unable to locate a suitable configuration of wxWidgets v2.8.x or higher.
The currently available configurations are listed below.  If necessary, either
install the package for your distribution or download the latest version of
wxWidgets
from http://wxwidgets.org.

    Default config is gtk2-unicode-2.9

  Default config will be used for output
BUT wx-config --version-full give me 2.9.1.0 and wx-config --version - 2.9.1
What I do wrong?

steve
Site Admin
Posts: 47250
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: Audacity-2 for x68-64 ?

Post by steve » Tue Mar 20, 2012 11:43 pm

Does your WxWidgets installation include the development headers?
Another possibility is that 2.9.1 may be too recent - the most recent version that I've tried is 2.8.12.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

bvv2001
Posts: 2
Joined: Tue Mar 20, 2012 11:05 pm
Operating System: Please select

Re: Audacity-2 for x68-64 ?

Post by bvv2001 » Wed Mar 21, 2012 4:56 pm

In slackware soft installation FOREVER with development headers. Downgrade version wxWidgets? This is very-very bad idea. If I do it my another software my be broken (

Gale Andrews
Quality Assurance
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10
Contact:

Re: Audacity-2 for x68-64 ?

Post by Gale Andrews » Wed Mar 21, 2012 7:12 pm

Can you do (as root):

Code: Select all

apt-get build-dep audacity 
on Slackware (if you have not already)? That should show you if dependencies are missing.

Certainly on Windows, Audacity cannot be built against wx 2.9 without many changes, and that may be true on other platforms, but your error isn't saying that (yet). If you still have a problem please post your configure input.

If it is needed to build Audacity against wx 2.8.12 then compile and install 2.8.12 separately and do something like the following when configuring Audacity:

Code: Select all

WX_CONFIG=/usr/local/bin/wx-config ./configure 
where /usr/local/bin has the 2.8.12 install.



Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual

bgravato
Forum Staff
Posts: 2067
Joined: Wed Jan 13, 2010 8:56 pm
Operating System: Please select

Re: Audacity-2 for x68-64 ?

Post by bgravato » Wed Mar 21, 2012 11:35 pm

Gale Andrews wrote:Can you do (as root):

Code: Select all

apt-get build-dep audacity 
on Slackware (if you have not already)? That should show you if dependencies are missing.
As far as I'm aware, I think Slackware doesn't use apt. Well at least it didn't in the old days...
Apt package manager is usually only used by Debian and Debian-based distros, such as Ubuntu.

According to wikipedia (about Slackware's package management):
The package management system does not track or manage dependencies, instead it relies on the user to ensure that the system has all the supporting system libraries and programs required by the new package. If any of these are missing, there may be no indication until the newly installed software is used.
Include as much details as you can in your post (Audacity version, Operating System, Equipment used, etc).
Please post your question in the appropriate forum (regarding audacity version and operating system).

bgravato
Forum Staff
Posts: 2067
Joined: Wed Jan 13, 2010 8:56 pm
Operating System: Please select

Re: Audacity-2 for x68-64 ?

Post by bgravato » Wed Mar 21, 2012 11:38 pm

Like Gale said you can build a local copy of an older wxwidgets version and place it in a different directory, then build audacity against it.
In which case is probably good idea to build it statically so it doesn't depend on dynamic libs to be run and you should then be able to safely remove the unwanted wxwidgets version.
Include as much details as you can in your post (Audacity version, Operating System, Equipment used, etc).
Please post your question in the appropriate forum (regarding audacity version and operating system).

Post Reply