Audacity running in background but not showing up

Help for Audacity on GNU/Linux.
Forum rules
ImageThis forum is for Audacity on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
wharjack
Posts: 4
Joined: Wed May 05, 2021 3:23 am
Operating System: Linux *buntu

Audacity running in background but not showing up

Post by wharjack » Wed May 05, 2021 3:29 am

Hello Sir/Madame, I'm using Kubuntu 21.04 and Audacity was okay from the start. Then 2 days ago, I can't use it anymore. I don't know why but when I opened it, it only runs in the background but it's not showing up. I tried uninstalling, purging, reinstalling and also I tried uninstalling Kdenlive which I suspected was the culprit but no it wasn't. I tried to search for an answer to this problem but I can't find any solution. So now I decided to consult here. By the way, I don't have problems with Windows 10 only Kubuntu. Thanks for answering.

steve
Site Admin
Posts: 81357
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Audacity running in background but not showing up

Post by steve » Wed May 05, 2021 11:02 am

The first thing I would suggest is to reset Audacity back to factory settings.
To do that:

1. Reboot the computer (this ensures that there is nothing running that will interfere with the next steps)

2. Open your "home" folder in your file browser, and enable "hidden files" in the file browser options (can usually be done with "Ctrl + H")

3. Find the hidden folder in your home directory:

Code: Select all

.audacity-data
4. In the ".audacity-data" folder, delete the three files:
  • audacity.cfg
  • pluginregistry.cfg
  • pluginsettings.cfg


If that doesn't fix the problem, try launching Audacity from a Terminal window by entering the command:

Code: Select all

audacity
Copy all of the output from the Terminal window and paste it into your reply.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

wharjack
Posts: 4
Joined: Wed May 05, 2021 3:23 am
Operating System: Linux *buntu

Re: Audacity running in background but not showing up

Post by wharjack » Wed May 05, 2021 1:11 pm

Hello, I remembered I deleted system fonts on Kubuntu. I reinstalled the Pango Fonts (sudo apt-get install -y libsdl-pango-dev) because of this error and it was fixed:

(audacity:2253): Pango - CRITICAL**: 21:02:13:362 :pango_font_description_set_size: assertion 'size >= -' failed

by the way that error was looping

Now, what's left is this:

(audacity:9185): Gtk-WARNING **: 21:07:24.182: A floating object was finalized. This means that someone
called g_object_unref() on an object that had only a floating
reference; the initial floating reference is not owned by anyone
and must be removed with g_object_ref_sink(

wharjack
Posts: 4
Joined: Wed May 05, 2021 3:23 am
Operating System: Linux *buntu

Re: Audacity running in background but not showing up

Post by wharjack » Wed May 05, 2021 1:16 pm

Hello, I'm sorry I was wrong. I executed sudo audacity and the pango error still remains.

steve
Site Admin
Posts: 81357
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Audacity running in background but not showing up

Post by steve » Wed May 05, 2021 1:54 pm

wharjack wrote:
Wed May 05, 2021 1:16 pm
I executed sudo audacity
Never use "sudo" unless you are intentionally modifying the system.

To launch Audacity from a terminal, the command is just:

Code: Select all

audacity
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

wharjack
Posts: 4
Joined: Wed May 05, 2021 3:23 am
Operating System: Linux *buntu

Re: Audacity running in background but not showing up

Post by wharjack » Wed May 05, 2021 2:54 pm

Hello Sir Steve, thank you very much for trying to solve my mistake, I greatly appreciate your help. I decided to clean install Kubuntu again and it worked! Anyway I didn't have solution for this but I'll just give prevention.
  • Never delete your system fonts (preinstalled System Fonts from your OS)
  • Never

    Code: Select all

    purge
    Audacity (or any application) then be careful when using

    Code: Select all

    autoremove
    because there's no way to get those dependencies back.
Those are the factors that made the Audacity run in the background and the GUI wasn't appearing.

Post Reply