An assertion failed! - problem of memory size or something like that

Help for Audacity on GNU/Linux.
Forum rules
ImageThis forum is for Audacity on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
Posts: 1
Joined: Mon Mar 22, 2021 4:32 pm
Operating System: Linux Mint

An assertion failed! - problem of memory size or something like that

Post by audawm » Mon Mar 22, 2021 5:01 pm

Hello! Thank you for the Audacity, but there is some problem.
I worked fine about a month. Then soft was updated.

1. Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
2. Audacity 2.3.3
3. Installed through mintinstall program manager. I worked fine about a month. Than soft was updated by command:
sudo apt install audacity
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлен пакет audacity самой новой версии (2.3.3-1build1).
Следующие пакеты устанавливались автоматически и больше не требуются:
libllvm10 libu2f-udev linux-headers-5.4.0-40 linux-headers-5.4.0-40-generic
linux-headers-5.4.0-48 linux-headers-5.4.0-48-generic linux-headers-5.4.0-51
linux-headers-5.4.0-51-generic linux-image-5.4.0-40-generic
linux-image-5.4.0-48-generic linux-image-5.4.0-51-generic
linux-modules-5.4.0-40-generic linux-modules-5.4.0-48-generic
linux-modules-5.4.0-51-generic linux-modules-extra-5.4.0-40-generic
linux-modules-extra-5.4.0-48-generic linux-modules-extra-5.4.0-51-generic

I have got this each time when I record new audio. It happens when I'm trying to read my text in the same time and in the same paragraph. :(

An assertion failed!

../src/common/wincmn.cpp(1044): assert "(minW == wxDefaultCoord || maxW == wxDefaultCoord || minW <= maxW) && (minH == wxDefaultCoord || maxH == wxDefaultCoord || minH <= maxH)" failed in DoSetSizeHints(): min width/height must be less than max width/height!

[1] wxWindowBase::DoSetSizeHints(int, int, int, int, int, int)
[2] wxTopLevelWindowGTK::DoSetSizeHints(int, int, int, int, int, int)
[3] ProjectWindow::UpdateLayout()
[4] wxEvtHandler::TryHereOnly(wxEvent&)
[5] wxEvtHandler::ProcessEventLocally(wxEvent&)
[6] wxEvtHandler::ProcessEvent(wxEvent&)
[7] wxEvtHandler::ProcessPendingEvents()
[8] wxAppConsoleBase::ProcessPendingEvents()
[9] wxApp::DoIdle()
[10] g_main_context_dispatch
[11] g_main_loop_run
[12] gtk_main
[13] wxGUIEventLoop::DoRun()
[14] wxEventLoopBase::Run()
[15] wxAppConsoleBase::MainLoop()
[16] wxEntry(int&, wchar_t**)
[17] main
[18] __libc_start_main
[19] _start

Please give me some advice how to fix this. :?:

Post Reply