No sound through headphones

Help for Audacity 2.x.x on GNU/Linux.
Forum rules
ImageThis forum is for Audacity 2.x.x on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
PartTime
Posts: 19
Joined: Sun Sep 13, 2015 6:41 pm
Operating System: Linux *buntu

Re: No sound through headphones

Post by PartTime » Sat Jan 07, 2017 7:59 pm

Okay, I got it. I just need to switch from Built-In Analog Audio Stereo, to the interface. (Scarlett 2i2) To hear through the headphones.

Thanks for all the input!!

playinmyblues
Posts: 5
Joined: Mon Feb 12, 2018 3:25 pm
Operating System: Windows 10

Re: No sound through headphones

Post by playinmyblues » Tue May 15, 2018 8:50 pm

I had a problem before where I could not hear the audio playback of the input while I was recording. This time I am using an iRig Pro. I tried all the settings for the playback device to no avail. I knew I had come across the answer before and it is under the following:
Edit > Preferences > Recording > Software Playthrough of input
That option needs to be turned on. At that point, the playback devices that worked were: sysdefault and dmix.
I am running Ubuntu Mate 17.

steve
Site Admin
Posts: 49031
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: No sound through headphones

Post by steve » Tue May 15, 2018 9:33 pm

playinmyblues wrote:I had a problem before where I could not hear the audio playback of the input while I was recording. This time I am using an iRig Pro. I tried all the settings for the playback device to no avail. I knew I had come across the answer before and it is under the following:
Edit > Preferences > Recording > Software Playthrough of input
That option needs to be turned on. At that point, the playback devices that worked were: sysdefault and dmix.
I am running Ubuntu Mate 17.
The downside to using Software Playthrough is that there is a delay between the sound going into the microphone and coming out of the headphones, because the data has to be moved through buffers by the software. This is not a problem in some situations, such as recording cassettes, but can be a major distraction in others (such as recording vocals).

Some recording devices provide "zero latency monitoring", which is where you plug headphones into the recording device so that the sound signal can pass from microphone through to the headphones in hardware (through wires). This avoids the delays incurred by software routing.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

Post Reply