FFmpeg not found

Help for Audacity 2.x.x on Mac OS X.
Forum rules
ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
TECH198
Posts: 10
Joined: Wed Aug 06, 2014 1:53 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

FFmpeg not found

Post by TECH198 » Tue Dec 05, 2017 10:15 am

Hi all..

I'm using Audacity 2.2.0 on OS X Sierra, and have download the .zip file for ffmpeg at below link

I have located LAME, but FFMpeg is not found.. I point to the file libavcodec.55.dylib, but audacity is not accepting it.

If there anything more i can do ? I have tried closing/reopening.. copying libavcodec.55 to a folder on its own just to isolate the problem, but its still not picking it up.

I downloaded the .zip from here: http://lame.buanzo.org/#lameosxdl

and i downloaded the Binary ffmpeg-mac-2.2.2.zip

billw58
Forum Staff
Posts: 3792
Joined: Wed Aug 12, 2009 2:10 am
Operating System: OS X 10.11 El Capitan or later (macOS)
Location: Waterloo, Ontario

Re: FFmpeg not found

Post by billw58 » Tue Dec 05, 2017 5:28 pm

After you have un-zipped the FFmpeg archive, the best place to put it is:

/Library/Application Support/Audacity/libs

This is the same folder where the LAME installer puts the LAME files. You must put all the FFmpeg files there, not just libavcodec.55.dylib.

Note that this is not your user Library folder, but the system Library folder. You can get to this folder using the menu Go > Go to Folder, or by opening a Finder window on your startup disk, then opening the "Library" folder you see there. Once you have the FFmpeg files in that folder, Audacity should find them automatically.

-- Bill

TECH198
Posts: 10
Joined: Wed Aug 06, 2014 1:53 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: FFmpeg not found

Post by TECH198 » Tue Dec 05, 2017 8:08 pm

Attached..

Perhaps i must use installer?


There is no audacity in /library/Application Support... All Application support files for apps the user installs is in your user folder:
<home folder>/Library/Application Support/audacity/libs.

or Click "Go", hold down Option, and select "Library"
Attachments
Screen Shot 2017-12-06 at 4.20.06 am.png
Screen Shot 2017-12-06 at 4.20.06 am.png (180.55 KiB) Viewed 433 times

billw58
Forum Staff
Posts: 3792
Joined: Wed Aug 12, 2009 2:10 am
Operating System: OS X 10.11 El Capitan or later (macOS)
Location: Waterloo, Ontario

Re: FFmpeg not found

Post by billw58 » Wed Dec 06, 2017 1:30 am

TECH198 wrote:Attached..
Perhaps i must use installer?
There is no audacity in /library/Application Support... All Application support files for apps the user installs is in your user folder:
<home folder>/Library/Application Support/audacity/libs.

or Click "Go", hold down Option, and select "Library"
Yes, that key combination reveals the user Library folder.

Yes, try the FFmpeg installer on that same page.

-- Bill

TECH198
Posts: 10
Joined: Wed Aug 06, 2014 1:53 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: FFmpeg not found

Post by TECH198 » Thu Dec 07, 2017 3:41 am

I found out installer FFMpeg dmg created audacity/libs in root.

When i manually created these and copied files there Audacity detected.. No problem.

Post Reply