Chain ExportMP3 isn't working

Help for Audacity 2.x.x on Mac OS X.
Forum rules
ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
MacDork
Posts: 9
Joined: Thu Oct 12, 2017 12:34 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Chain ExportMP3 isn't working

Post by MacDork » Thu Oct 12, 2017 12:37 am

The built-in chain for exporting works great, but when I add ExportMP3 to the end of a chain to clean up a few files, the export never works

steve
Site Admin
Posts: 47311
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: Chain ExportMP3 isn't working

Post by steve » Thu Oct 12, 2017 10:38 am

Are you able to do a 'normal' (manual / not in a Chain) export as MP3?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

MacDork
Posts: 9
Joined: Thu Oct 12, 2017 12:34 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Chain ExportMP3 isn't working

Post by MacDork » Thu Oct 12, 2017 1:25 pm

Yep

steve
Site Admin
Posts: 47311
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: Chain ExportMP3 isn't working

Post by steve » Thu Oct 12, 2017 1:38 pm

MacDork wrote: The built-in chain for exporting works great
You mean if you include a step to export as WAV, then that works?
MacDork wrote:when I add ExportMP3 to the end of a chain to clean up a few files, the export never works
What does "never works" mean exactly?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

MacDork
Posts: 9
Joined: Thu Oct 12, 2017 12:34 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Chain ExportMP3 isn't working

Post by MacDork » Thu Oct 12, 2017 2:45 pm

Sorry, I'll clarify.

I installed Audacity two days ago, and it came w/ an example chain, and all it does is export to MP3 -- that works as expected.

When I create my own chain, ExportMP3 does not work.

When I manually choose the "File | Export Audio" menu item, I can create MP3s, as expected.

steve
Site Admin
Posts: 47311
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: Chain ExportMP3 isn't working

Post by steve » Thu Oct 12, 2017 3:05 pm

Open the folder
~/Library/Application Support/audacity//Chains
(you may need to use the "Go" menu in Finder because Mac hides this folder)

Locate the Chain file that you have made and attach it to your reply. See here for how to attach files to forum posts: viewtopic.php?f=49&t=64936
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

MacDork
Posts: 9
Joined: Thu Oct 12, 2017 12:34 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Chain ExportMP3 isn't working

Post by MacDork » Thu Oct 12, 2017 3:43 pm

Cool; thank you.

Here's an example.
Attachments
Test.txt
(178 Bytes) Downloaded 15 times

steve
Site Admin
Posts: 47311
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: Chain ExportMP3 isn't working

Post by steve » Thu Oct 12, 2017 4:23 pm

Are you applying the Chain to the current project, or to files?

Try removing all of the effects from the Chain except for "Export MP3" and see if that runs.
If it does, add the effects back one at a time and test each time. My guess is that one of the effects is crashing.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

MacDork
Posts: 9
Joined: Thu Oct 12, 2017 12:34 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Chain ExportMP3 isn't working

Post by MacDork » Thu Oct 12, 2017 4:32 pm

Ok, thanks -- I'll give that a shot tonight. I appreciate the help.

billw58
Forum Staff
Posts: 3792
Joined: Wed Aug 12, 2009 2:10 am
Operating System: OS X 10.11 El Capitan or later (macOS)
Location: Waterloo, Ontario

Re: Chain ExportMP3 isn't working

Post by billw58 » Thu Oct 12, 2017 6:33 pm

My bet is on the Equalization effect. If that's the case, try using the "Save / Manage Curves" button to name the curve you want to apply, then select that curve name in the chain.

-- Bill
Last edited by billw58 on Thu Oct 12, 2017 9:31 pm, edited 1 time in total.
Reason: typo

Post Reply