Nyquist effects missing

Help for Audacity 2.x.x on Mac OS X.

ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Re: Nyquist effects missing

Permanent link to this post Posted by ericb7799 » Fri Feb 03, 2017 6:28 pm

Wanted to update that finally got this resolved. First two suggestions didn't work but removing all existing installations/versions of Audacity and then installing one of newest alpha builds did the trick. I used DMG version, not sure if .zip verions works as well. Copied my plugins folder that were previously copied to external drive prior to deleting of older versions of Audacity. Once alpha build was installed, rebooted and ran add/remove effects. Rebooted again after that completed and upon relaunch of Audacity all plugins visible in effects menu and are working now.
ericb7799
 
Posts: 85
Joined: Wed Aug 26, 2015 6:58 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Nyquist effects missing

Permanent link to this post Posted by teqteq » Sun Feb 05, 2017 8:54 am

I can confirm this is resolved when I installed the latest Nightly Audacity 2.1.3 release from DMG:

http://www.audacity.homerow.net/index.p ... 0-31df61f/

Not sure of the stability of this release though.

I noticed the reason for this in another post:

viewtopic.php?p=321639#p321639

Re: ClipFix Effect is missing [SOLVED]
Permanent link to this post Posted by Gale Andrews » Fri Feb 03, 2017 9:35 am

Thanks for letting us know. The upcoming Audacity 2.1.3 will be codesigned with an Apple Developer ID and with some other precautions this problem should not happen when launching Audacity. It might still happen when closing project windows.
teqteq
 
Posts: 7
Joined: Sun Feb 05, 2017 8:21 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Nyquist effects missing

Permanent link to this post Posted by Gale Andrews » Sun Feb 05, 2017 12:30 pm

Thanks for testing. Not all machines are susceptible to this bug. We don't know exactly why.

To be clear, alpha builds are not releases and are not codesigned. We are close to release and so the current alphas are believed very stable. This will not be the case after 2.1.3 is released and we start developing for 2.1.4.

The latest alphas from the top of the homerow site do have a fix https://github.com/audacity/audacity/commit/a05d039 that aims to prevent the bug occurring when launching Audacity.

2.1.3 when released without alpha designation will be codesigned. The codesigning itself should offer further protection against the bug. Even there, the bug might still occur if you have multiple projects open and close one of them without saving. There may be other related symptoms such as very slow Gatekeeper verification.


Gale

teqteq wrote:I can confirm this is resolved when I installed the latest Nightly Audacity 2.1.3 release from DMG:

http://www.audacity.homerow.net/index.p ... 0-31df61f/

Not sure of the stability of this release though.

I noticed the reason for this in another post:

viewtopic.php?p=321639#p321639

Re: ClipFix Effect is missing [SOLVED]
Permanent link to this post Posted by Gale Andrews » Fri Feb 03, 2017 9:35 am

Thanks for letting us know. The upcoming Audacity 2.1.3 will be codesigned with an Apple Developer ID and with some other precautions this problem should not happen when launching Audacity. It might still happen when closing project windows.
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Nyquist effects missing

Permanent link to this post Posted by cyrano » Sun Feb 05, 2017 6:08 pm

FWIW...

I've been tracking a similar problem for a number of years now.

Apple has been building a new authorisation system. The two main goals are a better system for Apple Pay and one centralised logon for the different stores, the Apple developers site, the cloud and a number of other services, only available to Apple service providers and resellers.

AFAICT, the problem seems to surface on two kinds of machines: 2ndhand and upgraded machines. I'm pretty certain that the problem with 2ndhand machines is related to some keys not being erased, because they belong to the previous owner. And that seems to confuse some security system in OSX.

Why this also seems to happen to machines that underwent an update from one major version to the next, I don't know.

It is all just info cobbled together, as there is NO official documentation from Apple. Security through obscurity has always been there.

I know some keys (or parts) are stored on the SMC. That's how it happens with machines that were sold without harddisk. It's also why you can't steal keys or bypass disk encryption by simply putting the harddisk in another Mac. Even desoldering and transplanting the SMC won't help, as some numbers get calculated from serial number (which you still could transplant) and a number of other, mainboard related numbers. The point is that the key system is also used by Gatekeeper. I only wish I knew how.

It's known in the repair community that the SMC's memory suffers from memory-loss in certain cases, resulting in a machine that won't boot. My query started with one of my MB Pro's SMC going bad. When I put the harddisk from that machine into an exact same machine, everything worked as expected, except my Apple dev account. And recovering the password by mail, or doing a clean install didn't help. It wasn't resolved until I did a clean install on a third machine that it got resolved.

I suspect Apple knows about these problems and that's one reason why they will replace the SMC with a "Secure Enclave" ARM processor in future builds. The newest MB Pro's with TouchBar already have these, but they also still have the SMC, for backwards compatibility.

Reports about this are on the net. Usually under the moniker "Why can't I logon into my Apple dev account?" Of course, not all of these are related to the key problem. Humans do error sometimes too 8-)
cyrano
 
Posts: 1304
Joined: Fri Apr 17, 2015 11:54 pm
Operating System: OS X 10.9 Mavericks

Re: Nyquist effects missing

Permanent link to this post Posted by Gale Andrews » Sun Feb 05, 2017 7:07 pm

cyrano wrote:FWIW...

I've been tracking a similar problem for a number of years now.

Apple has been building a new authorisation system. The two main goals are a better system for Apple Pay and one centralised logon for the different stores, the Apple developers site, the cloud and a number of other services, only available to Apple service providers and resellers.

AFAICT, the problem seems to surface on two kinds of machines: 2ndhand and upgraded machines. I'm pretty certain that the problem with 2ndhand machines is related to some keys not being erased, because they belong to the previous owner. And that seems to confuse some security system in OSX.

In 2.1.3-alpha before the code fix I quoted above, I got the bug on Audacity launch very frequently. All plugins not shipped with Audacity disappear from the menus, and LAME and FFmpeg can't be accessed. My machine was bought new (a mid 2011 Mac Mini). Partitions that have been upgraded from earlier macOS and those having a fresh Sierra 10.12.1 or later install were equally affected.

The most likely explanation for the problems seems to be timing problems that mean things that should happen do so too slowly then as a result Gatekeeper no longer trusts Audacity.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Nyquist effects missing

Permanent link to this post Posted by cyrano » Sun Feb 05, 2017 8:03 pm

Still sounds like a problem with keys to me...

But it's good to know it also seems to happen with factory supplied OSX installations. I've never trusted those :D
cyrano
 
Posts: 1304
Joined: Fri Apr 17, 2015 11:54 pm
Operating System: OS X 10.9 Mavericks

Re: Nyquist effects missing

Permanent link to this post Posted by teqteq » Mon Feb 06, 2017 8:01 am

cyrano wrote:FWIW...

AFAICT, the problem seems to surface on two kinds of machines: 2ndhand and upgraded machines. I'm pretty certain that the problem with 2ndhand machines is related to some keys not being erased, because they belong to the previous owner. And that seems to confuse some security system in OSX.


For the record, I've owned this machine since new (Late-2013 MBP). Of course it's been through many major OS updates though.
teqteq
 
Posts: 7
Joined: Sun Feb 05, 2017 8:21 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Nyquist effects missing

Permanent link to this post Posted by chrispou777 » Sat Mar 03, 2018 3:09 pm

Hi,

I used Audacity yesterday... everything worked well.

Today: want to use it again... the "missing Nyquist files" message pops up.

I am using Audacity 2.0.3 on Mac OS X Yosemite 10.10.5

It worked well yesterday...
chrispou777
 
Posts: 1
Joined: Sat Mar 03, 2018 2:52 pm
Operating System: OS X 10.10 Yosemite

Re: Nyquist effects missing

Permanent link to this post Posted by steve » Sat Mar 03, 2018 5:03 pm

chrispou777 wrote:Today: want to use it again... the "missing Nyquist files" message pops up.

Are you sure that you are using the installed version, and not running Audacity from the downloaded (not installed) DMG file? Running Audacity from the DMG will give that error.

chrispou777 wrote:I am using Audacity 2.0.3 on Mac OS X Yosemite 10.10.5

Audacity 2.0.3 is pretty ancient. The current version (for OS X 10.6 and later) is Audacity 2.2.2, which you can get here: https://www.audacityteam.org/download/mac/
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46978
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Previous

Return to Mac OS X



Who is online

Users browsing this forum: No registered users and 4 guests