Nyquist effects missing

Help for Audacity 2.x.x on Mac OS X.

ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Re: Nyquist effects missing

Permanent link to this post Posted by Gale Andrews » Thu Nov 03, 2016 6:55 pm

Deejay3142 wrote:I tried entering the words "CODE: SELECT ALL" but Terminal would not accept the instruction.

You just have to enter the text in green "as is". The Select All link is just a convenience so you can correctly select all the text then copy it for pasting into the terminal.

The main thing about passwords that confuses first-time users of the terminal is that you can't see the password you are typing in, so it is easy to enter the password incorrectly.

Deejay3142 wrote:I suspect you already know this, but the primary problem appears to be one which Apple identifies as a "Repackaging Problem". You may find the video below interesting. The specific issue is discussed at about minute 22 or soon after.
https://developer.apple.com/videos/play/wwdce2016/706/?time=1339

Thanks for the video reference. Firstly, contrary to that video, the Gatekeeper option to "open anyway" if an app is not from Apple Store or not from an "identified developer" has not been restored to the Gatekeeper Preferences dialogue in Sierra. The option is now hidden as a Terminal command.

I assume from the video that the "repackaging problem" is actually intentional, in that "external" libraries or plugins outside the resource are not allowed to be used. The Nyquist and Plug-ins folders are of course not in the Audacity.app/Contents/Resources folder. The Nyquist and Plug-ins folders would be seen by Audacity if put there (but users would not then be able to add Nyquist plugins conveniently). I somewhat doubt that is really the problem but it would need testing on a new Sierra installation that never had Audacity before, or perhaps by removing all the Gatekeeper references to Audacity. It could still be a random Gatekeeper bug.

The video suggests that codesigning the DMG (making sure sufficient objects within it are codesigned) is a resolution to the "repackaging problem". If so then it's possible that 2.1.3 when released may not have this problem, because it is our intention to codesign, though not necessarily as an "identified" (meaning paid for) developer.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Nyquist effects missing

Permanent link to this post Posted by Tbook84 » Mon Nov 14, 2016 12:54 am

Im having the same issue as well, only after following the advice from page 1- i am now seeing the plugins listed in the "add/remove plugins" window... but after clicking "enable" and then "ok" the plugins still aren't usable.

1.Even if i click enable and OK...

Screen Shot 2016-11-13 at 7.51.26 PM.png
Screen Shot 2016-11-13 at 7.51.26 PM.png (219.48 KiB) Viewed 769 times


2.When i open the prompt again it still says "New"
Screen Shot 2016-11-13 at 7.51.36 PM.png
Screen Shot 2016-11-13 at 7.51.36 PM.png (207.32 KiB) Viewed 769 times
Tbook84
 
Posts: 9
Joined: Sun Nov 13, 2016 10:00 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Nyquist effects missing

Permanent link to this post Posted by Gale Andrews » Mon Nov 14, 2016 2:29 pm

Tbook84 wrote:Im having the same issue as well, only after following the advice from page 1- i am now seeing the plugins listed in the "add/remove plugins" window... but after clicking "enable" and then "ok" the plugins still aren't usable.

Is this your first ever install of Audacity on this startup disk?

Do the plugins on the USB drive get enabled?

What is the exact version of OS X/macOS that you have? Look at Apple menu > About this Mac.

Which of the solutions have you tried from http://forum.audacityteam.org/viewtopic.php?p=316041#p316041 ? Removing the quarantine xattribute is the most likely to work.

If that does not help, make sure you check in the AppStore app for latest updates to your operating system.

And if that does not help, does 2.1.3-alpha have the same problem? Try "audacity-macosx-2.1.3-3a99837.zip" or "audacity-macosx-2.1.3-3a99837.dmg" from http://www.audacity.homerow.net/index.php?dir=mac/audacity-nightly-2016.11.14-06.00-3a99837/.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Nyquist effects missing

Permanent link to this post Posted by Tbook84 » Mon Nov 14, 2016 5:36 pm

Gale Andrews wrote:
Tbook84 wrote:Im having the same issue as well, only after following the advice from page 1- i am now seeing the plugins listed in the "add/remove plugins" window... but after clicking "enable" and then "ok" the plugins still aren't usable.

Is this your first ever install of Audacity on this startup disk?

Do the plugins on the USB drive get enabled?

What is the exact version of OS X/macOS that you have? Look at Apple menu > About this Mac.

Which of the solutions have you tried from http://forum.audacityteam.org/viewtopic.php?p=316041#p316041 ? Removing the quarantine xattribute is the most likely to work.

If that does not help, make sure you check in the AppStore app for latest updates to your operating system.

And if that does not help, does 2.1.3-alpha have the same problem? Try "audacity-macosx-2.1.3-3a99837.zip" or "audacity-macosx-2.1.3-3a99837.dmg" from http://www.audacity.homerow.net/index.php?dir=mac/audacity-nightly-2016.11.14-06.00-3a99837/.


Gale



Oh wow, a new version!

I downloaded that and it still doesn't seem to be working.

I just purchased this laptop a few days ago so this is my first Audcaity install on this, yes. (2015 Macbook Pro running on Sierra v10.12.1)

Initially when i would open Audacity the plugins that i'd dragged into the plugins folder weren't even showing up in the list of plugins when looking for them in Audacity. The Nyquist prompt wasn't showing either.

However, I tried the Quarantine tip (xattr -r -d com.apple.quarantine /Applications/Audacity/) and then the plugins, along with the Nyquist prompt reappeared. But now when i click "add/remove plugins" and then "enable" next to the plugin, then "OK"-I still don't see any of the plugins (noisegate.ny for example) in the list of things that i can use. After this, when i click on "add/remove plugins" again, it just shows the plugins that i enabled as "new".
Tbook84
 
Posts: 9
Joined: Sun Nov 13, 2016 10:00 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Nyquist effects missing

Permanent link to this post Posted by Gale Andrews » Mon Nov 14, 2016 7:45 pm

Have you tried rebooting? It is possible that is needed for the xattribute change to take effect.


Gale

Tbook84 wrote:
Gale Andrews wrote:
Tbook84 wrote:Im having the same issue as well, only after following the advice from page 1- i am now seeing the plugins listed in the "add/remove plugins" window... but after clicking "enable" and then "ok" the plugins still aren't usable.

Is this your first ever install of Audacity on this startup disk?

Do the plugins on the USB drive get enabled?

What is the exact version of OS X/macOS that you have? Look at Apple menu > About this Mac.

Which of the solutions have you tried from http://forum.audacityteam.org/viewtopic.php?p=316041#p316041 ? Removing the quarantine xattribute is the most likely to work.

If that does not help, make sure you check in the AppStore app for latest updates to your operating system.

And if that does not help, does 2.1.3-alpha have the same problem? Try "audacity-macosx-2.1.3-3a99837.zip" or "audacity-macosx-2.1.3-3a99837.dmg" from http://www.audacity.homerow.net/index.php?dir=mac/audacity-nightly-2016.11.14-06.00-3a99837/.


Gale



Oh wow, a new version!

I downloaded that and it still doesn't seem to be working.

I just purchased this laptop a few days ago so this is my first Audcaity install on this, yes. (2015 Macbook Pro running on Sierra v10.12.1)

Initially when i would open Audacity the plugins that i'd dragged into the plugins folder weren't even showing up in the list of plugins when looking for them in Audacity. The Nyquist prompt wasn't showing either.

However, I tried the Quarantine tip (xattr -r -d com.apple.quarantine /Applications/Audacity/) and then the plugins, along with the Nyquist prompt reappeared. But now when i click "add/remove plugins" and then "enable" next to the plugin, then "OK"-I still don't see any of the plugins (noisegate.ny for example) in the list of things that i can use. After this, when i click on "add/remove plugins" again, it just shows the plugins that i enabled as "new".
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Nyquist effects missing

Permanent link to this post Posted by Tbook84 » Tue Nov 15, 2016 12:02 am

That didn't seem to fix it either. I suppose i could try doing the "xattribute" once again to see if anything different happens this time. This is so frustrating.

Edit: Holy crap!!! That fixed it somehow.

It seem to be working fine now. Thank you guys so much for all of your help. :D
Tbook84
 
Posts: 9
Joined: Sun Nov 13, 2016 10:00 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Nyquist effects missing

Permanent link to this post Posted by ericb7799 » Sat Nov 19, 2016 8:29 pm

i'm still having some similar issues on Mac OSX El Cap in that none of Steve Daulton effects will work. checked all files and [*] in libs , both sys lib and user lib and even copied those missing to multiple locations in other dirs. they are showing up in add remove effects and appear to enable but do not add to effect menu. running add remove and they are back to showing "new". this is on newer versions od audacity 2.12 and above. ran an older build 2.11 and before and those effects appear in menu and do work in those builds. any idea what is going on with this?
ericb7799
 
Posts: 85
Joined: Wed Aug 26, 2015 6:58 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Nyquist effects missing

Permanent link to this post Posted by steve » Sun Nov 20, 2016 12:23 pm

See this post for solutions: viewtopic.php?p=316041#p316041
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 47007
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Nyquist effects missing

Permanent link to this post Posted by Gale Andrews » Sun Nov 20, 2016 1:31 pm

ericb7799 wrote:i'm still having some similar issues on Mac OSX El Cap in that none of Steve Daulton effects will work. checked all files and [*] in libs , both sys lib and user lib and even copied those missing to multiple locations in other dirs. they are showing up in add remove effects and appear to enable but do not add to effect menu. running add remove and they are back to showing "new". this is on newer versions od audacity 2.12 and above. ran an older build 2.11 and before and those effects appear in menu and do work in those builds. any idea what is going on with this?

To be clear, we don't make any "2.11" and "2.12" version. Audacity 2.1.2 (and 2.1.1) may be obtained from http://www.audacityteam.org/download/mac.

The issue addressed in http://forum.audacityteam.org/viewtopic.php?p=316041#p316041 has only ever been reported in Sierra, and in 2.1.1 too, so I am not sure it is the same issue. Also please be aware of the correct locations for installing Nyquist plugins, The simplest place to put them is in the Audacity "Plug-Ins" folder. They will not be seen in your user Library or the system Library. Also make sure Nyquist effects are enabled in Effects Preferences.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Nyquist effects missing

Permanent link to this post Posted by ericb7799 » Sun Nov 20, 2016 5:15 pm

Answer is a yes to trying the above. Yes, I stand corrected in versioning, I am referring to builds 2.1.2 and above. Plugins are located in correct paths, both in user libs, sys libs and in the Audacity application folder, under applications/audcatiy/plug-ins and also in applications/audacity/nyquist. Am trying the xattribute fix and rebooting but so far not enabling those specific ones only. My current version of Audacity is 2.1.3-alpha-Oct 1 2016. Will try and dl a newer 2.1.3 from Mac OSX nightly Audacity build page and see if that helps.
ericb7799
 
Posts: 85
Joined: Wed Aug 26, 2015 6:58 am
Operating System: OS X 10.11 El Capitan or later (macOS)

PreviousNext

Return to Mac OS X



Who is online

Users browsing this forum: No registered users and 9 guests