Help with Plugins - macOS Sierra

Help for Audacity 2.x.x on Mac OS X.
Forum rules
ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Gale Andrews
Quality Assurance
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10
Contact:

Re: Help with Plugins - macOS Sierra

Post by Gale Andrews » Fri Feb 17, 2017 12:57 pm

stevemc wrote:
If you want to try the RC1 release candidate of 2.1.3 and give us feedback about it, please visit https://www.fosshub.com/Audacity.html/.
I tried the build and it worked perfectly. Its nice the way its a single package instead of a folder now.
Thanks for testing. Yes, having the contents inside the bundle should help with Gatekeeper too.

Let us know if you lose access to plugins or LAME/FFmpeg after closing project windows, or other times while using Audacity. That is still possible.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual

stevemc
Posts: 3
Joined: Wed Feb 15, 2017 3:44 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Help with Plugins - macOS Sierra

Post by stevemc » Fri Feb 17, 2017 7:05 pm

Thanks for testing. Yes, having the contents inside the bundle should help with Gatekeeper too.

Let us know if you lose access to plugins or LAME/FFmpeg after closing project windows, or other times while using Audacity. That is still possible.
In my case I had a clean machine I installed to. I installed the ffmpeg and lame plugins after installing audacity. I then opened Audacity and went to Library prefs. The MP3 library version was already listed as LAME 3.98.2 and the ffmpeg was not but when I clicked locate i got a msg saying it was already found and so I clicked no and it was populated correctly. So in short I think this build works fine with LAME and FFMPEG.

Note: I noticed an odd behavior. If I opend Audacity via keyboard thru spotlight (typing Cmd+Space and typing Auadicity) I get an error dialog stating "The application "Audacity.app" can't be opened." yet Audacity did open just fine. But when I Click the Audacity icon in applications thru the Dock I do not see this error. The error has no effect and Audacity opened just fine. So minor nuisance.

Gale Andrews
Quality Assurance
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10
Contact:

Re: Help with Plugins - macOS Sierra

Post by Gale Andrews » Sun Feb 19, 2017 2:05 am

Thanks for testing 2.1.3 RC1, stevemc.
stevemc wrote:Note: I noticed an odd behavior. If I opend Audacity via keyboard thru spotlight (typing Cmd+Space and typing Auadicity) I get an error dialog stating "The application "Audacity.app" can't be opened." yet Audacity did open just fine. But when I Click the Audacity icon in applications thru the Dock I do not see this error. The error has no effect and Audacity opened just fine. So minor nuisance.
Thanks, I logged this at http://bugzilla.audacityteam.org/show_bug.cgi?id=1593.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual

k2graphics
Posts: 1
Joined: Mon Sep 18, 2017 7:54 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Help with Plugins - macOS Sierra

Post by k2graphics » Mon Sep 18, 2017 8:34 pm

stevemc wrote:I'm so glad to sound this post. The "xattr command solution" solved my problem with seeing the nyquist plug-ins. I spent a couple of days off and on searching for a solution stumbling upon this page.

To save others time, I suggest that you add some information to the Mac OS download page and if possible the readme included in the download DMG (thought this may require new build so maybe that's not so easy). I see there is a "Known Issue" regarding security settings on the download page but the xattr solution is not shown and the one that is mentioned does not solve problem.

This is the OSX download page I'm referring to: http://www.audacityteam.org/download/mac/
Thanks, stevemc, for posting this info. And your link really helped | saved me from going in circles.

Post Reply