Slow Performance on 6 Core Mac Pro

Help for Audacity on macOS.
Forum rules
ImageThis forum is for Audacity on macOS 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
RodentiaPuppy
Posts: 2
Joined: Tue Aug 25, 2020 4:31 am
Operating System: macOS 10.14 Mojave

Re: Slow Performance on 6 Core Mac Pro

Post by RodentiaPuppy » Tue Aug 25, 2020 4:47 am

I know this is an odd question to ask, but what is your audio buffer length in Audacity? I've had issues with a low frame rate for the entire interface until I changed the audio buffer length as below:
Audacity buffer length.png
Audacity buffer length.png (976.64 KiB) Viewed 1908 times
My default was 100ms which limited the refresh of the interface to 10fps, so I've changed it to 33ms for 30fps. This sped up the interface all around.

RodentiaPuppy
Posts: 2
Joined: Tue Aug 25, 2020 4:31 am
Operating System: macOS 10.14 Mojave

Re: Slow Performance on 6 Core Mac Pro

Post by RodentiaPuppy » Wed Aug 26, 2020 12:12 am

I forgot to mention I did this on Audacity 2.4.2 though I think this may work on 2.3.x and 2.2.x as well.

Sv443
Posts: 1
Joined: Wed Nov 17, 2021 12:48 pm
Operating System: macOS 10.15 Catalina or later

Re: Slow Performance on 6 Core Mac Pro

Post by Sv443 » Wed Nov 17, 2021 12:54 pm

On MacOS Monterey the option to force low resolution is gone.
Now you instead have to mess with Audacity's Info.plist file to get it to work.
This is how to do it:

1. Navigate to "/Applications"
2. Right-click "Audacity.app", then click "Show Package Contents"
3. Open the file "Info.plist" in the "Contents" folder with any text editor
4. Search for "NSHighResolutionCapable"
5. On the line just below, set "<true/>" to "<false/>"

Source: https://apple.stackexchange.com/a/430002/379018

Post Reply