echo when applying effects

Help for Audacity 2.x.x on Mac OS X.
Forum rules
ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
tomfuller
Posts: 9
Joined: Thu Feb 05, 2015 6:16 pm
Operating System: Please select

echo when applying effects

Post by tomfuller » Mon Jun 11, 2018 3:58 pm

I am trying to record my voice, via a mixer and microphone, accompanied by an imported .mpg. It seems to work fine, until I play it back and apply effects (compressor, equalization, normalize). Then it adds an echo to the stereo accompaniment track, even tho I didn't select it. I tried selecting only the mono vocal track, when applying effects. The vocal track is grayed, and the stereo accompaniment tracks appear selected with clocks on the background. I'm new at this, and frustrated. How do I select only the vocal track to apply effects? And why does it add echo? Thanks. Tom in Texas

Trebor
Posts: 4600
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows Vista

Re: echo when applying effects

Post by Trebor » Mon Jun 11, 2018 4:38 pm

tomfuller wrote:The vocal track is grayed, and the stereo accompaniment tracks appear selected with clocks on the background
To get rid of the clocks see ... https://manual.audacityteam.org/man/syn ... roups.html

tomfuller
Posts: 9
Joined: Thu Feb 05, 2015 6:16 pm
Operating System: Please select

Re: echo when applying effects

Post by tomfuller » Mon Jun 11, 2018 6:05 pm

Ok...sorry I'm dense. So, if the clocks are in the background of the accompaniment tracks, does that mean the accompaniment tracks are selected, and subject to any effects I apply? I want to leave the accompaniment just as it is, and apply effects only to my voice, which is on a third mono track. Thanks. TnT

billw58
Forum Staff
Posts: 3807
Joined: Wed Aug 12, 2009 2:10 am
Operating System: OS X 10.11 El Capitan or later (macOS)
Location: Waterloo, Ontario

Re: echo when applying effects

Post by billw58 » Mon Jun 11, 2018 11:49 pm

Please see this page in the manual.

Effects are applied to selected audio. The clocks (sync-locked track groups) are irrelevant. Make sure that you select only the track you want to apply the effect to.

-- Bill

Trebor
Posts: 4600
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows Vista

Re: echo when applying effects

Post by Trebor » Tue Jun 12, 2018 12:29 am

tomfuller wrote:I am trying to record my voice, via a mixer and microphone, accompanied by an imported .mpg.
It seems to work fine, until I play it back ... Then it adds an echo ...
Try unchecking "Software playthrough of input" in Audacity preferences ...

Image

Post Reply