No Audacity in headphones despite settings.

Help for Audacity on macOS.
Forum rules
ImageThis forum is for Audacity on macOS 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
ajgarcia
Posts: 2
Joined: Sun Jun 13, 2021 7:52 pm
Operating System: macOS 10.15 Catalina or later

No Audacity in headphones despite settings.

Post by ajgarcia » Sun Jun 13, 2021 8:22 pm

Hi. I have been running Audacity happily on my older OS10 Macbook Pro for years. I now have a newer Macbook Pro (2020, Intel chips) that I am transitioning to, operating OS 11.4, with Audacity 3.0.2. I typically do much of my editing in wired headphones before auditing the work on a variety of speaker systems.

Today was my first use of Audacity on the new Mac; and to my surprise, no sound was in my headphones: it was coming from the computer's speakers. However, sound from any other app I use (browers, QuickTime, Adobe Premiere Pro) comes through the headphones as requested.

As the attached screenshots show, both the Mac and Audacity are pointed to External Headphones, yet I receive the error: "Error opening sound device. Try changing the audio host, playback device and the project sample rate." This does not seem to be addressed in the Forum. Looking at Mac's preference for Privacy, I don't see Audacity among apps that are listed requesting access to my Mac's Microphone or Accessibility: could that have anything to do with it? I’ve seen someone else reference perhaps a similar problem and refer to Blackhole, which I do not have in Applications. I also visited Transport>Rescan Audio Devices without positive effect.

Suggestions? Thanks!
Attachments
Screen Shot 2021-06-13 at 3.40.21 PM.jpg
Screen Shot 2021-06-13 at 3.40.21 PM.jpg (314.46 KiB) Viewed 201 times
Screen Shot 2021-06-13 at 3.40.53 PM.jpg
Screen Shot 2021-06-13 at 3.40.53 PM.jpg (350.51 KiB) Viewed 201 times
Screen Shot 2021-06-13 at 3.41.15 PM.jpg
Screen Shot 2021-06-13 at 3.41.15 PM.jpg (363.17 KiB) Viewed 201 times

steve
Site Admin
Posts: 81876
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: No Audacity in headphones despite settings.

Post by steve » Mon Jun 14, 2021 1:44 am

I was going to suggest that you try running "Rescan Audio Devices" from the "Transport" menu, but I see that you've already tried that.

Try changing the Project Rate (lower left corner of the main Audacity window) to 44100.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

ajgarcia
Posts: 2
Joined: Sun Jun 13, 2021 7:52 pm
Operating System: macOS 10.15 Catalina or later

Re: No Audacity in headphones despite settings.

Post by ajgarcia » Mon Jun 14, 2021 2:23 pm

Hi, Steve. MANY thanks for your time. Here's what transpired as I attempted your suggestion. I opened the same file in Audacity, and it wouldn't play back in headphones. I went to Mac Preferences, sorted out the headphone choice, rebooted Audacity; and this time it played back in headphones (whereas yesterday it wouldn't despite the same order of operations). When I experimented with changing the sample rate from 48 to 44, I received error messages. (I took a look at Audacity's opening of same and similar files on my older Mac and noted it opened them with one or the other rate depending on the file and work done.)

So at the moment I have no real answer as to how I received headphone sound today. It may simply be in the order of ops, though it seemed I had replicated it today and yesterday. Further thoughts from you or anyone are welcome. Best, Tony

Post Reply