Page 1 of 3

Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Fri Mar 02, 2018 8:06 pm
Posted by ericb7799
Yesterday saw the new update and installed in on my Windows 7 computer at my work. On this particular PC I'm restricted to not being able to run most Windows installers so I always update Audacity using the .zip files. As usual I opened the .zip and copied the contents to my existing Audacity directory. I am also restricted with read-only access to any directory other than User directories, including Program Files, and Program Files (x86). I am able to write to any User Directory including AppData. So as a workaround I have installed Audacity to c:\(Username)\Downloads\Audacity_._._\. In the past I had just followed the naming format as it is in the downloaded .zip file: audacity-win-2.2.1, audacity-win-2.1.3, audacity-win-2.2.2, etc.

In the past I would just copy the new files from the updated .zip to the existing audacity directory in my downloads directory and manually change the directory name to the updated version. audacity-win-2.2.1 changed to audacity-win-2.2.2 for example in this case. However, I've noticed that when I do that it causes the plugin config to get messed up, typically using the add/remove effects will show multiple directories for my VST effects, even when only the current directory actually exists.

Trying to load or use a plugin that is showing up under an incorrect directory will return a failure to initialize plugin error on attempt to load. So what I usually would have to do would be to only enable the effects in the current directory listing and manually disable those in any incorrect directories.

Since this most recent update I have started to get some specific error messages when attempting to add effects with add/remove effects menu. I'm attaching screenshots of the two errors. essentially they seem to be about the same:

Both say : Effect at :C:\(User)\Downloads\audacity-win-2.2.2\Plug-ins\ (effect name).dll failed to register. The second error just includes additional information of : Could not load the library.

So in order to fix this issue I attempted to just rename the Audacity directory in downloads folder to "Audacity" and leave out the version number. I then deleted the pluginregistry.cfg and pluginsettings.cfg and attempted to re-add/enable the plugins using the add/remove effects menu. The plugins are showing as "New" under the current directory c:\(User)\Downloads\Audacity\Plug-ins\.

However, I am getting the same error messages when attempting to enable them. I am certain the plug-ins I'm attempting to add work with Audacity and my other DAW, Reaper, still has no problem with loading them (after updating the VST config path in Reaper to include the current Audacity plug-in folder path). So that would seem to rule out corruption or similar issue with the actual plug-in.dll files.

I have also attempted to delete all Audacity .cfg files, including Audacity.cfg, and then deleting the entire audacity folder in AppData as well. It works to reset Audacity to initial configuration, and when add/remove effects is called the paths for the plug-ins is correct and shows the changed Audacity directory: c:\(user)\downloads\Audacity\Plug-ins\). But enabling them and clicking OK causes these error messages to come up on every single plugin that I'm trying to enable. So far I haven't had time to sit here and click OK on each and every one of them to see if can get through all the errors, the time listed is fluctuating up to many many hours, etc.

Anybody have any idea what the heck I can do here to be able to get plug-ins working again?

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Mon Mar 05, 2018 4:48 pm
Posted by lespaulplayer621
I have EXACTLY THE SAME issue. Whenever I'm trying to load my plugins, which works perfectly well in previous versions of Audacity, this error message occurs.

But there is one interesting thing - when I load every plugin that I want to use and close the error messages, I can use those plugins without any problem. So this error is a little bit weird.

plugin bug.jpg
plugin bug.jpg (136.65 KiB) Viewed 1410 times


I also wrote to the Audacity feedback contact email and I wonder what they will reply to me.

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Tue Mar 06, 2018 10:12 am
Posted by steve
I'm not on Windows, so perhaps you guys could give some additional details. Does this issue only occur with VST effects?

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Tue Mar 06, 2018 7:27 pm
Posted by ericb7799
Not sure if only occurs with VST. Guess really only other type on Windows would be LV2 or LADSPA?
Anyway, haven’t had time to sit here for an hour or more hitting OK for every single one of my plug-ins, but seems like that
is what it’s going to take to get all them working. Workflow comes to a screeching halt right now, so guess I’m going to have
to do that now.

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Tue Mar 06, 2018 9:20 pm
Posted by steve
This may help:

Try searching your computer for these two files:
Code: Select all
pluginregistry.cfg
pluginsettings.cfg

Delete or rename any instances that you find. They are normally in
Code: Select all
Users\<username>\AppData\Roaming\Audacity\

but I'm not totally clear how you have things set up.

Then, in the extracted program folder (the folder that contains "audacity.exe"), create a new folder called "Portable Settings".
If this folder is present, Audacity will save its settings / configuration files in there rather than in AppData\Roaming

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Thu Mar 08, 2018 2:16 am
Posted by ericb7799
Thanks Steve. Good to know how to set up as a portable installation. Unfortunately, it didn't resolve the errors. As lespaulplayer621 said, you can just click "OK" through the errors and after that the plugins show up and work as normal. It's just quite a hassle to have to manually click "OK" for every single plugin.

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Sat Mar 10, 2018 4:30 pm
Posted by lespaulplayer621
I have tried to delete above mentioned files (pluginregistry.cfg and pluginsettings.cfg), but i didn't work.

So as I wrote earlier, this must be some bug in Audacity itself. I didn't have that issue in previous version of this DAW.

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Tue Mar 13, 2018 12:49 pm
Posted by lespaulplayer621
I've also noticed that there is problem with live monitoring of plugin effects, so you can hear how certain effect will work with your input signal unless you record something and then edit it.
So I thnk that the only way to resolve this problem is just wait for new release of Audacity, and that the developers of this program will repair this issue.

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Wed Mar 14, 2018 2:16 am
Posted by steve
The only reports I've seen of this issue are the two cases here.
@ lespaulplayer621, you say you have "EXACTLY THE SAME issue". Are you also using the ZIP version of Audacity 2.2.2?

ericb7799 wrote:typically using the add/remove effects will show multiple directories for my VST effects

What are the directories?

lespaulplayer621 wrote:I've also noticed that there is problem with live monitoring of plugin effects

What do you mean by "live monitoring"? What exactly are you doing?

Re: Problem with re-enabling plug-ins since upgrade to 2.2.2

Permanent link to this postPosted: Wed Mar 14, 2018 2:59 am
Posted by Satamanster
Ok so I am a windows user and I installed audacity today. I never before tried to use any plugins but I decided to give it a go and voila... Getting the same error as you were guys. But then it hit me.. "Failed to register".. Hmmm... Shutdown audacity... Deep Breath... run audacity as ADMINISTRATOR.... And tcharaaan... IT WORKS NOW! NO anoying errors.