Mute while recording

Help for Audacity 2.x.x on Windows.
Forum rules
ImageThis forum is for Audacity 2.x.x on Windows.
Please state which version of Windows you are using,
and the exact three-section version number of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
steve
Site Admin
Posts: 49443
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Mute while recording

Post by steve » Thu Dec 13, 2018 9:51 am

I don't understand what you mean.

I understand that you are recording sound that is playing in your web browser.

When you connect the headphones, what happens:
1) to the sound coming through the headphones?
2) to the sound coming through the speakers?
3) to the recording in Audacity?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

waxcylinder
Forum Staff
Posts: 9769
Joined: Tue Jul 31, 2007 11:03 am
Operating System: Windows 10

Re: Mute while recording

Post by waxcylinder » Thu Dec 13, 2018 10:41 am

swvaroot wrote:
Thu Dec 13, 2018 1:55 am
Has anyone found a solution to the "mute speaker while recording from speakers" ??
Certainly. When I use the WASAPI loopback method recommended in the Manual:
https://manual.audacityteam.org/man/tut ... ndows.html

With that setup
a) I can use the speaker slider in the Audacity Mixer Toolbar to control the output level going to the speakers including down to zero.
Note that this does not affect the signal level that is being loopback recorded as that comes direct from the soundcard input.

b) Note that the Microphone slider in the Mixer Toolbar will not control the signal level - that must be managed at the signal source (e.g. the website that you are trying to record from).

----------------------------------------------------------------------------

In the days before we had WASAPI host and loopback I used to use MME host and "Stereo Mix" input device - with that setup turning down the speaker slider also turned down the signal - so I used to deal with that with a dummy 3.5mm jack (brand new headphones jack with nothing soldered on) inserted into the headphone jack. With that I got no perceivable distortion on the signal.


WC
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * FAQ * * * * * Tutorials * * * * * Audacity Manual * * * * * Audacity Wiki * * * * *

tweaker56
Posts: 1
Joined: Sat Jan 12, 2019 4:25 am
Operating System: Windows 7

Re: Mute while recording

Post by tweaker56 » Sat Jan 12, 2019 5:02 am

SOLUTION for my setup! I use Win 7 and Audacity 2.1.2.
I had the same issue. For years, I could mute while recording. Then yesterday, somehow Audacity's settings got reset and I lost the ability to mute and record. I tried to adjust so many settings but couldn't get the mute/recording setting back. I searched the net and then found this forum and then remembered that I took a screenshot last year of the settings I needed. I changed the settings back and voila...it works again! I can mute or even raise and lower the volume on the Windows speaker icon in the system tray near the clock with no effect on the recording. For me it was to set the Audacity Device Toolbar settings to:
Audio Host: Windows WASAPI
Recording Device: Speakers (Realtek High Definition Audio)(loopback)
Recording Channels: 2 (Stereo) Recording Channels
Playback Device: Speakers (Realtek High Definition Audio)(loopback)
You can also set this in Devices in Preferences.
I also set the Recording settings for Playthrough to Overdub, but I don't think that matters as it works with that deselcted as well. Hope this helps someone.
SEE ATTACHMENT FOR SCREEN CLIPPING
Cheers!
Attachments
Image 1.png
Image 1.png (46.2 KiB) Viewed 19 times

Post Reply