MP3 Render Missing Tracks But It Gets Weirder...

Help for Audacity on Windows.
Forum rules
ImageThis forum is for Audacity on Windows.
Please state which version of Windows you are using,
and the exact three-section version number of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
feraldrollery
Posts: 4
Joined: Sat May 08, 2021 12:18 am
Operating System: Windows 10

MP3 Render Missing Tracks But It Gets Weirder...

Post by feraldrollery » Sat May 08, 2021 12:26 am

5 Tracks, mixed down, levels ok, playback sounds OK, but then I rendered it and Bluetoothed the mp3 to my phone. Through my phone speakers there are missing track 4. And it's not even faint or ambiguous. But the weird part is that you can hear it just fine through the headphones. Hmmm, maybe I have a left or right channel out on my phone speakers? But I've been experiencing all kinds of issues with my levels. Anyway, maybe you could shed some light on it. Thanks!

kozikowski
Forum Staff
Posts: 69290
Joined: Thu Aug 02, 2007 5:57 pm
Operating System: macOS 10.13 High Sierra

Re: MP3 Render Missing Tracks But It Gets Weirder...

Post by kozikowski » Sat May 08, 2021 12:53 am

Can you trace where you got track 4 from?

I'm putting serious bets that the Left and Right of Track 4 are out of phase. Can you get track 4 on a timeline by itself? Tracks > Mix > Mix Stereo down to Mono. I bet it vanishes. Normal songs don't.

Does it? If it does, you can fix this song. Edit > UNDO and back out to the original stereo song. Menu on the left > Split Stereo Track. Select one of the two tracks > Effect > Invert.

Select the top track > Menu on the left > Make Stereo Track. Now make your sound file and I bet it works just fine.

It is super-duper important to know where you got that track from. It's possible you have a sound system that is damaging music files—and you have a lot of these.

This isn't a newbie problem. There was a recent National Public Radio interview where the interviewer's microphone was out of phase and she vanished when you listened to the show on a phone, but not on the radio.

Koz

steve
Site Admin
Posts: 81390
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: MP3 Render Missing Tracks But It Gets Weirder...

Post by steve » Sat May 08, 2021 5:17 pm

feraldrollery wrote:
Sat May 08, 2021 12:26 am
Through my phone speakers there are missing track 4.
Was track 4 a stereo track? If so, then I think kozikowski's diagnosis is very likely to be the answer.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

feraldrollery
Posts: 4
Joined: Sat May 08, 2021 12:18 am
Operating System: Windows 10

Re: MP3 Render Missing Tracks But It Gets Weirder...

Post by feraldrollery » Sat May 08, 2021 9:50 pm

Sorry, spaced it...
*Windows 10

feraldrollery
Posts: 4
Joined: Sat May 08, 2021 12:18 am
Operating System: Windows 10

Re: MP3 Render Missing Tracks But It Gets Weirder...

Post by feraldrollery » Sat May 08, 2021 10:03 pm

Track originated from a sampling audio app on my phone. It's an absolute turd of a phone, as well. ZTE.
BTW, would you/could you remark on another issue while we're here, so I don't have to start a new thread. I appreciate it immensely!

Multiple tracks, imported from FL Studio Mobile. Then I went to record some bass an vocals live. Waveforms of imported files look good, no peaks. I had to really crank up my live recording tracks (amped ALMOST to peaking), bring down my FL beats almost -20db, but the live tracks were still coming through very faintly. Different results between monitor speakers and headphones.

I was also wrestling with levels similarly in Reaper. I suspect this OP render/level issue is related. Feeling like a total noob over here. Thank you for your patience!

kozikowski
Forum Staff
Posts: 69290
Joined: Thu Aug 02, 2007 5:57 pm
Operating System: macOS 10.13 High Sierra

Re: MP3 Render Missing Tracks But It Gets Weirder...

Post by kozikowski » Sun May 09, 2021 12:22 am

I think you're the poster child for stereo phase problems.

https://www.kozco.com/tech/LRMonoPhase4.mp3

Here's a 40 second sound test in four parts. Left, Right, Mono, and intentionally phase damaged.

Listen to this on your speakers and headphones. All four parts should be about the same volume. The last part may sound a little weird, but should not drop in volume. I think there's zero chance you'll make it through the whole test.

Koz

feraldrollery
Posts: 4
Joined: Sat May 08, 2021 12:18 am
Operating System: Windows 10

Re: MP3 Render Missing Tracks But It Gets Weirder...

Post by feraldrollery » Sun May 09, 2021 2:11 am

Aye!! The phase part went blargly on my phone.

I do have this habit of playing around with phase/inversion. I get a mad kick out of that "in the room" sound. Back to the drawing board.

kozikowski
Forum Staff
Posts: 69290
Joined: Thu Aug 02, 2007 5:57 pm
Operating System: macOS 10.13 High Sierra

Re: MP3 Render Missing Tracks But It Gets Weirder...

Post by kozikowski » Sun May 09, 2021 2:28 am

playing around with phase/inversion.
Busted...

Koz

Post Reply