Confusion over Recording Devices labeled "loopback"

Help for Audacity on Windows.
Forum rules
ImageThis forum is for Audacity on Windows.
Please state which version of Windows you are using,
and the exact three-section version number of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
Coachjim
Posts: 1
Joined: Wed May 05, 2021 6:06 pm
Operating System: Windows 10

Confusion over Recording Devices labeled "loopback"

Post by Coachjim » Wed May 05, 2021 6:51 pm

Technical Context:
Audacity 3.0.2
Windows 10 Pro (10.0.19042 Build 19042)

Situational Context:
I recently replaced a failing desktop PC with a new shiny one, a Dell Precision 3640 Tower.
I've gotten into using OBS to upgrade my Zoom presentations. That's included downloading virtual VB-Cables and adding a second camera.
When I'm recording audio from what's playing through my system, I don't use my mic as an input device because I don't want to record the ambient sound.

The Problem:

I mostly use Audacity to record audio being played on my system. Typical use is when I want to learn from a video presentation. Because I'm not going to sit still for very many videos (TED talks, etc.), I use Audacity to grab the audio so I can either listen to it while on a walk or while driving.

With my old desktop, the process was super straightforward. I'd set the recording device to be my system's speakers and it worked. I may be wrong, but it seemed to me, the volume of my speakers had nothing to do with the recorded volume.

With my new rig, my options for recording devices have grown and lots of them include "loopback" in their name. Those loopbacks trigger an error code (9996). The only one that works is "Stereo Mix (Realtek(R) Audio). I activated the "Stereo Mix" via my Sound settings where I saw a post on-line somewhere suggesting my problem could be fixed by changing the Stereo Mix options to not allow enhanced settings. Frankly, I can't find where I made that setting.

Anyway, the only device I can record with is the Stereo Mix (Realtek(R) Audio). While that's fine, it records at such a low input level that, at first, I didn't think it was recording anything. I now use SoundForge 15 to books the volume by the max, 1000%.

My Questions:

First, what's the proper place in this forum to look for help?

Second, where did all the loopbacks come from?

Third, is my set-up messed up? If so, what should I do?

Finally, since I can get this to work, if I'm not messed up, is there a way to boost the input gain in Audacity OR should I just live with having to do the Sound Forge step?

Note the attached screen prints from Device Manager, Audacity's list of recording devices, and Audacity's error message.

Thanks for any help you can provide.

Jim
Attachments
Audacity Error Message.png
Audacity Error Message.png (4.94 KiB) Viewed 113 times
Audacity's List of Recording Devices.png
Audacity's List of Recording Devices.png (8.46 KiB) Viewed 113 times
From Device Manager.png
From Device Manager.png (11.41 KiB) Viewed 113 times

DVDdoug
Forum Crew
Posts: 9361
Joined: Fri Sep 10, 2010 11:30 pm
Operating System: Windows 10

Re: Confusion over Recording Devices labeled "loopback"

Post by DVDdoug » Wed May 05, 2021 9:17 pm

I've never used Virtual Audio Cable.

Loopback is similar to Stereo Mix and it's a Windows (or driver?) feature that allows you to "capture" whatever is playing through your soundcard.

...If you are listening through headphones plugged-into your Realtek soundcard, Realtek (loopback) should record everything you're hearing in your headphones.

jademan
Forum Crew
Posts: 1307
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Windows 10

Re: Confusion over Recording Devices labeled "loopback"

Post by jademan » Fri May 07, 2021 1:46 am

As with DVDdoug, I don't have experience with Virtual Audio Cable, and I shudder to think just what is VB-Audio Virtual Cable loopback. :roll:
Coachjim wrote:
Wed May 05, 2021 6:51 pm
Anyway, the only device I can record with is the Stereo Mix (Realtek(R) Audio). While that's fine, it records at such a low input level that, at first, I didn't think it was recording anything. I now use SoundForge 15 to books the volume by the max, 1000%.
1000%, yes, that seems excessive. Try boosting the speaker/headphone volume as you record and/or switching between MME and WASAPI.
Coachjim wrote:
Wed May 05, 2021 6:51 pm
My Questions:

First, what's the proper place in this forum to look for help?
Since you are on Windows, you've come to the right place.
Coachjim wrote:
Wed May 05, 2021 6:51 pm
Second, where did all the loopbacks come from?
I don't know but see: https://docs.microsoft.com/en-us/window ... -recording:
WASAPI provides loopback mode primarily to support acoustic echo cancellation (AEC). However, other types of audio applications might find loopback mode useful for capturing the system mix that is being played by the audio engine.
One might speculate that Microsoft wants to differentiate itself from Apple which has a vested interest in selling music and protecting its music library.
Coachjim wrote:
Wed May 05, 2021 6:51 pm
Third, is my set-up messed up? If so, what should I do?
I believe in the KISS sytem "Keep It Simple, Stupid". I would start by uninstalling the Virtual Audio Cables as that is a big unknown. See if you can get it working with a simpler system. Once you have achieved success, bring them back in. Have you followed the instructions at Tutorial - Recording audio playing on the computer
Coachjim wrote:
Wed May 05, 2021 6:51 pm
Finally, since I can get this to work, if I'm not messed up, is there a way to boost the input gain in Audacity OR should I just live with having to do the Sound Forge step?
Effect > Amplify

kozikowski
Forum Staff
Posts: 69275
Joined: Thu Aug 02, 2007 5:57 pm
Operating System: macOS 10.13 High Sierra

Re: Confusion over Recording Devices labeled "loopback"

Post by kozikowski » Fri May 07, 2021 9:57 am

Computers have two basic sound channels. Play from the internet or a sound file to your speakers, and record from your microphone to a sound file or send to an internet task. That's it. There's no natural pathway between them and that's what you need to record internet shows.

Something has to run the play system to get the content and then loop back the music or performance into the recording system.

Where the loopback captures the content counts. If it grabs the music from the speaker system which I believe is what Stereo Mix does, then the music will assume the volume of your speaker volume control. If you set up a recording and then turn the speaker down so it doesn't bother you, you just killed the capture volume.

Some of the fancier loopback systems grab the content before the speaker volume control and you don't get the low volume effect. There is also the legacy process of assigning playback to headphones instead of speakers. Leave the volume turned up and take the headphones off.

It's true Macs have never had built-in tools to do this. We've always had to use special software packages and setups.

Desperation method has us sending sound out to a stereo interface such as a Behringer UCA-202, and then loop back the sound with a physical cable.

viewtopic.php?p=406764#p406764

The UCA-202 has a place to plug headphones so you can hear what you're doing.

Koz

Post Reply