Page 2 of 5

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 2:48 pm
by BrianGygi
Here is the audacity.cfg from C:\Users\Brian\AppData\Local\Audacity\SessionData. I have also posted the plugin*.cfg files from there. I hope they tell you something!
Thanks again

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 3:20 pm
by steve
That looks OK.
I'm wondering if we've been looking in the wrong place.
Whenever I would try to save a project, or export a file, or anything that required interacting with Windows, I would get the following error screen (attached).
OK, so Audacity crashes on "save" or "export". What do you mean by "or anything that required interacting with Windows"?

Can you import this short WAV file without Audacity crashing:
chirp.wav
(516.84 KiB) Downloaded 2 times

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 3:42 pm
by BrianGygi
Hi Steve, when I try to Import that wav file (or anything else) I get that error screen I posted earlier and it generates the same zip file, with the same log.txt describing trying to load the FFmpeg libraries (below).
Sorry I'm really stumped here.
Thanks again for your help.

11:35:33: Audacity 3.0.0
11:35:33: Trying to load FFmpeg libraries...
11:35:33: Trying to load FFmpeg libraries from system paths. File name is 'avformat-55.dll'.
11:35:33: Looking up PATH environment variable...
11:35:33: PATH = 'C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Users\Brian\AppData\Local\Microsoft\WindowsApps;;C:\Program Files\JetBrains\PyCharm 2020.3.5\bin;'
11:35:33: Temporarily prepending ';' to PATH...
11:35:33: Checking for monolithic avformat from 'avformat-55.dll'.
11:35:33: Error: Failed to load shared library 'avformat-55.dll' (error 126: The specified module could not be found.)
11:35:33: Loading avutil from ''.
11:35:33: Error: Failed to load shared library '.dll' (error 126: The specified module could not be found.)
11:35:33: Loading avcodec from ''.
11:35:33: Error: Failed to load shared library '.dll' (error 126: The specified module could not be found.)
11:35:33: Loading avformat from 'avformat-55.dll'.
11:35:33: Error: Failed to load shared library 'avformat-55.dll' (error 126: The specified module could not be found.)
11:35:33: Error: Failed to load FFmpeg libraries.
11:35:33: Returning PATH to previous setting: C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Users\Brian\AppData\Local\Microsoft\WindowsApps;;C:\Program Files\JetBrains\PyCharm 2020.3.5\bin;
11:35:33: Error: Failed to find compatible FFmpeg libraries.

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 3:47 pm
by steve
Are you able to generate a tone? (Generate menu > Tone)
If so, can you play it?

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 3:55 pm
by jademan
Ivalogic wrote:
Sat Apr 17, 2021 5:19 pm
I'm not an expert on this, but you may have to delete some faulty plug-ins.
It looks suspicious, as stated in the debug report screenshot, that the debug report will be stored in a Wondershare software folder.
I think Ivalogic may be on to something here.... Have you tried parking all of your plugins by renaming your AppData > Roaming > audacity directory?

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 4:05 pm
by BrianGygi
Hi, I'm not sure what you mean by "parking" my plug-ins. So what should I rename my AppData->Roaming->audacity directory? And will I need to create a new, blank one?
Thanks

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 4:10 pm
by BrianGygi
Also, the PlugIns directory on C:\Users\Brian\AppData\Roaming\audacity is empty. Shouldn't there be something there?

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 4:37 pm
by steve
BrianGygi wrote:
Sun Apr 18, 2021 4:10 pm
Also, the PlugIns directory on C:\Users\Brian\AppData\Roaming\audacity is empty. Shouldn't there be something there?
On 64-bit Windows, the plug-ins shipped with Audacity should be in:
C:\Program Files (x86)\Audacity\Plug-Ins\

On 32-bit Windows:
C:\Program Files\Audacity\Plug-Ins\

Optional / 3rd party plug-ins are often installed to:
C:\Users\<username>\AppData\Roaming\audacity\Plug-Ins\
but in a fresh installation of Audacity that folder is not used (only if you add extra plug-ins).

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 6:52 pm
by jademan
BrianGygi wrote:
Sun Apr 18, 2021 4:10 pm
Also, the PlugIns directory on C:\Users\Brian\AppData\Roaming\audacity is empty. Shouldn't there be something there?
No, as Steve indicated, they may be located elsewhere. It makes no difference where they are located.
BrianGygi wrote:
Sun Apr 18, 2021 4:05 pm
Hi, I'm not sure what you mean by "parking" my plug-ins. So what should I rename my AppData->Roaming->audacity directory? And will I need to create a new, blank one?
Thanks
So what I do is
1) Exit audacity.
2) Rename ..AppData\Roaming\audacity to ..AppData\Roaming\audacityx
3) Restart audacity and observe possibly different behavior.

To return to prior state:
1) Exit audacity.
2) Delete ..AppData\Roaming\audacity
3) Rename ..AppData\Roaming\audacityx back to ..AppData\Roaming\audacity

No muss, no fuss.

Re: *NO* version of Audacity works for me in Windows 10

Posted: Sun Apr 18, 2021 10:24 pm
by BrianGygi
Hi, I did as you suggested:

Renamed ..AppData\Roaming\audacity to ..AppData\Roaming\audacitybackup
Went back into Audacity and observed exactly the same behavior.....

Aiyy - any other approaches to try?