Mono on Stereo fix

Help for Audacity 2.x.x on Windows.
Forum rules
ImageThis forum is for Audacity 2.x.x on Windows.
Please state which version of Windows you are using,
and the exact three-section version number of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
Post Reply
LadyThorne
Posts: 5
Joined: Fri Jan 15, 2021 8:44 pm
Operating System: Windows 10

Mono on Stereo fix

Post by LadyThorne » Fri Jan 15, 2021 8:59 pm

Ok, so I've been recording an audiobook for the last two weeks. I'm HOURS in and my test listeners have commented on the sound only coming through the left speaker, or just barely on the right. I am using Windows 10 with an Audiotechnica microphone on the focusrite scarlet solo. I just found out there's a fix for my year long problem of only being able to hear out of one earphone, which is to change my focusrite properties to 1 channel, instead of the default 2. Lo and behold I can hear out of both ears!

Problem: I'm 8 chapters in, about 5 hours of recording (which translates to 5 days of non-stop recording time which I cannot do again) and approaching my deadline. I have the tracks chosen as stereo, but they're only on one side, causing my sound issue. Is there a way to correct the issue (converting to actual stereo) without re-recording?
screenshot.jpg
screenshot.jpg (198.2 KiB) Viewed 142 times

DVDdoug
Forum Crew
Posts: 9061
Joined: Fri Sep 10, 2010 11:30 pm
Operating System: Windows 10

Re: Mono on Stereo fix

Post by DVDdoug » Fri Jan 15, 2021 9:13 pm

Click the little drop-down arrow to the left of the waveform and select Split Stereo To Mono. Then click the 'X' to delete the silent track. Now you have a mono file that will play from both speakers.

LadyThorne
Posts: 5
Joined: Fri Jan 15, 2021 8:44 pm
Operating System: Windows 10

Re: Mono on Stereo fix

Post by LadyThorne » Sat Jan 16, 2021 5:13 pm

Yeah, I found that the other day after I'd posted. But I've discovered another problem. after fixing my mono to stereo issue on one file (it DOES have several tracks) it will not allow it to export to MP3. It says something about an error at E?

I probably should mention when I opened the file it had an error, something about blank files and filling them with silence.
Attachments
error.png
error.png (9 KiB) Viewed 97 times

jademan
Posts: 812
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: Mono on Stereo fix

Post by jademan » Mon Jan 18, 2021 12:48 am

LadyThorne wrote:
Sat Jan 16, 2021 5:13 pm
it will not allow it to export to MP3. It says something about an error at E?

I probably should mention when I opened the file it had an error, something about blank files and filling them with silence.
So that would be your E: drive. Sometimes, putting special characters in you file name can cause this error.

However, based on your description, it seems more likely that your whole audacity project is being stored on drive E:. Is that a network or cloud drive or a memory stick? Audacity does not do well with remote drives or memory sticks. If you are able to zip up your projects files and post a link to it here, someone here might be able to take a look at it for you and try to replicate your error.

Be sure to include both the .aup file and the data file directory and sub-structure. See here: https://manual.audacityteam.org/man/aud ... jects.html and here: https://manual.audacityteam.org/man/sen ... thers.html

Post Reply