[RESOLVED] The Notch filter don't want to work !

Help for Audacity on Windows.
Forum rules
ImageThis forum is for Audacity on Windows.
Please state which version of Windows you are using,
and the exact three-section version number of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.
steve
Site Admin
Posts: 81944
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: The Notch filter don't want to work !

Post by steve » Tue Jun 22, 2021 4:56 pm

iBenny wrote:
Tue Jun 22, 2021 12:48 pm
So... anybody, can anyone try to clean this artifact @ 8476hz here using the "notch" filter ? :
There's actually two frequencies
The strongest one is at about 8480 Hz, and the other is at about 7880 Hz.

I used the Notch filter with:
Frequency = 8480
Q = 8

and then
Frequency = 7880
Q = 8

Here's the result:
KFwmVQQ3JBh_processed.wav
(448.45 KiB) Downloaded 30 times
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

iBenny
Posts: 32
Joined: Fri Jul 31, 2020 11:53 pm
Operating System: Windows 10

Re: The Notch filter don't want to work !

Post by iBenny » Tue Jun 22, 2021 5:05 pm

Hi Steve,

Excellent !

Was the decimal on your figures in the notch filter a period or a comma ?

Best regards
iBenny

steve
Site Admin
Posts: 81944
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: The Notch filter don't want to work !

Post by steve » Tue Jun 22, 2021 5:26 pm

iBenny wrote:
Tue Jun 22, 2021 5:05 pm
Was the decimal on your figures in the notch filter a period or a comma ?
My system uses the dot character as the decimal separator.

Note that changing the decimal separator character is risky because it MUST be consistent, and for most operating systems it MUST be set the same in multiple places. I've never had to worry about this because my computer has always use the dot character as the decimal separator.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

iBenny
Posts: 32
Joined: Fri Jul 31, 2020 11:53 pm
Operating System: Windows 10

Re: The Notch filter don't want to work !

Post by iBenny » Tue Jun 22, 2021 5:30 pm

Hi Steve

I have done NO special mod in audacity and it puts commas instead of periods as decimal symbol. Would gladly configure it to use periods but I don't know how... Even if I type a period, it converts it as a comma !!!

Best rgards
iBenny

steve
Site Admin
Posts: 81944
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: The Notch filter don't want to work !

Post by steve » Tue Jun 22, 2021 5:45 pm

iBenny wrote:
Tue Jun 22, 2021 5:30 pm
I have done NO special mod in audacity
There are no special settings in Audacity for the decimal separator. It takes the decimal separator settings directly from the operating system (in your case "Windows", in my case "Linux"). If there are conflicting settings for the decimal separator in the operating system, then it WILL cause problems.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

iBenny
Posts: 32
Joined: Fri Jul 31, 2020 11:53 pm
Operating System: Windows 10

Re: The Notch filter don't want to work !

Post by iBenny » Tue Jun 22, 2021 6:40 pm

Hi Steve,

I reverted the Windows 10 regional settings to english (US), rebooted the pc to no avail : same notch filter with commas decimal symbol.

The next step now is to fill a bug report (feature request) to the notch filter programmer (or audacity board) in order for him (them) to allow commas as decimal symbols. Where do I fill this report/request ? I NEED this notch filter ASAP...

Best regards
iBenny

steve
Site Admin
Posts: 81944
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: The Notch filter don't want to work !

Post by steve » Tue Jun 22, 2021 6:54 pm

iBenny wrote:
Tue Jun 22, 2021 6:40 pm
The next step now is to fill a bug report (feature request) to the notch filter programmer (or audacity board) in order for him (them) to allow commas as decimal symbols.
It isn't an Audacity bug. It seems that there is still a conflict somewhere in your Windows settings.

I can probably write a version of the Notch filter that isn't affected by the Windows settings, but you are still likely to have problems with other effects. You really need to fix the problem on your computer.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

steve
Site Admin
Posts: 81944
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: The Notch filter don't want to work !

Post by steve » Tue Jun 22, 2021 7:00 pm

steve wrote:
Tue Jun 22, 2021 6:54 pm
I can probably write a version of the Notch filter that isn't affected by the Windows settings
To show willing and help you with the immediate problem, here's a custom version that I think will work for you.
notch-custom.ny
(1.17 KiB) Downloaded 31 times
Note that:
1. As this is an unofficial customised version, there is no official support.
2. You still need to fix the problem on Windows.

Installation instructions for Nyquist plug-ins: https://manual.audacityteam.org/man/ins ... st_install
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

Trebor
Posts: 10003
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows 8 or 8.1

Re: The Notch filter don't want to work !

Post by Trebor » Tue Jun 22, 2021 7:27 pm

iBenny wrote:
Tue Jun 22, 2021 12:48 pm
So... anybody, can anyone try to clean this artifact @ 8476hz here using the "notch" filter ? :

https://www.cjoint.com/doc/21_06/KFwmVQ ... 476-hz.wav
spectral edit multi-tool is a notch filter.gif
2 applications of multi-tool required (Ctrl+R)
spectral edit multi-tool is a notch filter.gif (566.65 KiB) Viewed 1100 times
Attachments
KFwmVQQ3JBh_Artifact-8476-hz (before-after).flac
(513.83 KiB) Downloaded 50 times

iBenny
Posts: 32
Joined: Fri Jul 31, 2020 11:53 pm
Operating System: Windows 10

Re: The Notch filter don't want to work !

Post by iBenny » Tue Jun 22, 2021 8:01 pm

Hi Steve,

Installation of your custom notch filter successful but... same outcome : there were no decimal to mess with, great but... it returned the same window (that I figure now it is not an error window but an "info" window) :

Notch return.jpg
Notch return.jpg (21.36 KiB) Viewed 1095 times

with NO notch cleanup performed.

I wonder if that window is normal and usually shown regardless of the success of the operation, or shown only if a problem occurred ? You tell me !

Best regrads
iBenny

Post Reply