Very slow connecting to website

Suggestions and Questions About the Forum Web Site.
Forum rules
ImagePost here only if the Forum isn't working as you would like or expect.

If you require help using Audacity, or think you have found a "bug", please post on the forum board relevant to your operating system.
Windows
Mac OS X
GNU/Linux and Unix-like
Post Reply
PGA
Posts: 693
Joined: Thu Jan 19, 2012 9:16 pm
Operating System: Please select

Very slow connecting to website

Post by PGA » Sun Apr 29, 2012 9:45 am

It was incredibly slow to connect to the Home page this morning at c.06:30-07:00 GMT+1. Is this timeslot a regular scheduled maintenance slot that I should avoid? Is there a published schedule for the planned downtime on the server(s)?

The slowness was only in connecting to the Home page. Once in the forum, responses were normal. But when I closed the browser and then relaunched and re-connected it was slow to get to the Home page again. We're talking 20-30 seconds to complete the connection (including the automatic logon) - a process that normally takes no more than a second or two.
regards,
Peter

Gale Andrews
Quality Assurance
Posts: 25982
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Very slow connecting to website

Post by Gale Andrews » Mon Apr 30, 2012 1:50 am

PGA wrote:It was incredibly slow to connect to the Home page this morning at c.06:30-07:00 GMT+1. Is this timeslot a regular scheduled maintenance slot that I should avoid? Is there a published schedule for the planned downtime on the server(s)?

The slowness was only in connecting to the Home page. Once in the forum, responses were normal. But when I closed the browser and then relaunched and re-connected it was slow to get to the Home page again. We're talking 20-30 seconds to complete the connection (including the automatic logon) - a process that normally takes no more than a second or two.
regards,
Peter
Which "Home Page" - the Forum home page? For a good report, it's best to give the exact URL and your IP address ( http://www.whatismyip.com/ ).

Audacityteam.org is under more load since 2.0.0 because the FAQs have moved there, but Buanzo did make some tweaks a while ago.

Note that htttp://audacityteam.org/ has had recent issues according to a custom "404" page I've seen from time to time. You can check their status at http://sourceforge.net/sitestatus/ .



Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual

PGA
Posts: 693
Joined: Thu Jan 19, 2012 9:16 pm
Operating System: Please select

Re: Very slow connecting to website

Post by PGA » Mon Apr 30, 2012 5:46 am

Sorry I wasn't precise enough! :oops:

I was referring to the Forum Home Page (http://forum.audacityteam.org/). I have no idea what my IP address would have been yesterday. Today it is 86.2.18.194 according to that website you pointed me at. I have no idea whether this would have the IP address yesterday or whether my ISP assigns me one from a pool of them each day when I first connect? The problem of the slow response was occuring only when connecting to and logging in to the forum's Home Page (a process which is automated for me; presumably by a combination of "remember me" settings in Firefox and on the Forum website). Access to other websites (Google, BBC, other forums) before and after using the Audacity Forum was perfectly normal.

Once I was into the forum I could navigate within the forum with no unusual delays. The problem situation lasted from about 06:30 GMT+1 to about 07:00 GMT+1. Having had the slow response on first connection, I closed down the browser and started again. The second connection took just as long (20-30 seconds as against a more usual one or two seconds). After completing my early morning check on forum activity from overnight, I didn't try connecting to the Audacity forum again until later that morning.

Today (at 06:30-06:45 GMT+1) things are OK

regards,
Peter

ragnar.jensen
Posts: 118
Joined: Thu Jan 26, 2012 7:39 pm
Operating System: Please select

Re: Very slow connecting to website

Post by ragnar.jensen » Mon Apr 30, 2012 6:01 pm

I've heard that dreamhost.com - that hosts the DNS servers for the audacityteam.org domain - have had severe troubles in their data center the last couple of days. The symptoms you describe are consistent with one of their DNS servers being down.

--
Ragnar

Gale Andrews
Quality Assurance
Posts: 25982
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Very slow connecting to website

Post by Gale Andrews » Mon Apr 30, 2012 10:57 pm

Thanks for the further details, Peter.

Most ISP's give you a dynamic rather than static IP address, but knowing the IP address at the time of the problem helps Buanzo identify issues. Buanzo is away at the moment.

Whether you log in automatically or not is determined by whether you choose "log me on automatically each visit" which I believe sets an appropriate cookie.

I understand you were having this delay on the front page of the forum even when you did not have to explicitly log in, but please do reply if the issue recurs.

As I understand it, most of the audacityteam.org web site is not hosted any longer on DreamHost due to the kind of issues Ragnar notes, though some services are still are under DreamHost.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual

Post Reply