Rode Podcaster Help - XLR recordings have sharp 's' sounds / USB recordings sound much better?

Did you buy a new mixer? Do you need advice? Post here.
Forum rules
If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like
Post Reply
mullyaudio
Posts: 1
Joined: Sun Jan 03, 2021 4:32 pm
Operating System: macOS 10.15 Catalina or later

Rode Podcaster Help - XLR recordings have sharp 's' sounds / USB recordings sound much better?

Post by mullyaudio » Sun Jan 03, 2021 4:34 pm

Need some help with the rode podcaster mixer. Hope someone has a solution!

I bought the Rode RODECaster Pro mixer a few months ago so i could record more than one microphone for interviews (i was previously using a Maono usb mic which was great).

I bought two Rode PodMics to go with the mixer. Immediately after setting it all up, i noticed the recordings sounded harsher on 'S' sounds. I played around with the settings, and made sure the 'Rode PodMic' was selected in the settings. But couldn't fix it.

This week i bought the new Shure MV7. Which has both USB and XLR outputs. I tested it first through the Rode RODECaster mixer. Slightly different sound to the PodMic - but not massive. So i thought i'd test it via USB directly into my computer.

The USB recording is MUCH better - whereas the recording through the mixer still had the sharp 'S' sounds.

So i'm definitely going something wrong with the RODECaster Mixer. These are the settings under 'audio processing':

Compresser: On
High-pass Filter: On
De-esser: On
Noise Gate: On
APHEX
Aural Exciter: One
Big Bottom: On
Processing: On
----------------------------------

Anyone experienced this before? What am i doing wrong?

jademan
Forum Crew
Posts: 1279
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Please select

Re: Rode Podcaster Help - XLR recordings have sharp 's' sounds / USB recordings sound much better?

Post by jademan » Mon Jan 04, 2021 2:12 am

mullyaudio wrote:
Sun Jan 03, 2021 4:34 pm
The USB recording is MUCH better - whereas the recording through the mixer still had the sharp 'S' sounds.

So i'm definitely going something wrong with the RODECaster Mixer. These are the settings under 'audio processing':

Compresser: On
High-pass Filter: On
De-esser: On
Noise Gate: On
APHEX
Aural Exciter: One
Big Bottom: On
Processing: On
So what happens when you turn OFF ALL of the RODEcaster 'audio processing' ? If that fixes the problem then you could turn the adjustments back ON one at at time to find out why.

kozikowski
Forum Staff
Posts: 69231
Joined: Thu Aug 02, 2007 5:57 pm
Operating System: macOS 10.13 High Sierra

Re: Rode Podcaster Help - XLR recordings have sharp 's' sounds / USB recordings sound much better?

Post by kozikowski » Mon Jan 04, 2021 2:38 am

I remember this. This is the mixer you can use to manage and integrate a phone call. That right there would be worth the price if it worked well.

From the instructions, they expect the XLR connections to work really well and the only way you would know that is turn off all the processing, filters, effects, and corrections. See: Jademan.

When you get it "flat," record a short voice test with the digital USB service and record it again through the analog mixer connection.

https://www.kozco.com/tech/audacity/Tes ... _Clip.html

Use one second of silence and slate where the second silence would be. [silence......] "USB Microphone." "Catskill Farms......"

Koz

Trebor
Posts: 9877
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows 8 or 8.1

Re: Rode Podcaster Help - XLR recordings have sharp 's' sounds / USB recordings sound much better?

Post by Trebor » Mon Jan 04, 2021 3:13 am

mullyaudio wrote:
Sun Jan 03, 2021 4:34 pm
... the recording through the mixer still had the sharp 'S' sounds.

So i'm definitely going something wrong with the RODECaster Mixer. These are the settings under 'audio processing':

Compresser: On
High-pass Filter: On
De-esser: On
Noise Gate: On
APHEX
Aural Exciter: One
Big Bottom: On
Processing: On
If esses are harsh I would switch off the exciter.

If the processing is adjustable, (rather than just on or off), turn the de-esser up, and/or the compressor down.

Post Reply