Including LAME encoder

Anything you think is missing, or needs enhancement, goes here.
Forum rules
If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like
Post Reply
kimshako
Posts: 2
Joined: Tue Oct 10, 2017 4:33 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Including LAME encoder

Post by kimshako » Tue Oct 10, 2017 4:36 am

https://en.wikipedia.org/wiki/LAME#Pate ... gal_issues

As far as I know, LAME's patent is expired. Is it still not possible to embed LAME library inside the app distribution? Maybe possible with static library?

steve
Site Admin
Posts: 47309
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu
Contact:

Re: Including LAME encoder

Post by steve » Tue Oct 10, 2017 7:36 am

kimshako wrote:As far as I know, LAME's patent is expired.
Looks like it - at least, those that we know of.
kimshako wrote:Is it still not possible to embed LAME library inside the app distribution?
Too late for the next Audacity release, but hopefully yes in the future.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

kimshako
Posts: 2
Joined: Tue Oct 10, 2017 4:33 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Including LAME encoder

Post by kimshako » Tue Oct 10, 2017 12:17 pm

steve wrote:
kimshako wrote:As far as I know, LAME's patent is expired.
Looks like it - at least, those that we know of.
kimshako wrote:Is it still not possible to embed LAME library inside the app distribution?
Too late for the next Audacity release, but hopefully yes in the future.
That’d be awesome! Thanks!

Post Reply