Is Audacity, or is it wxWidgets, that is limited to 10.6

Building and customizing Audacity from the source code.

If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like

Is Audacity, or is it wxWidgets, that is limited to 10.6

Permanent link to this post Posted by rachalmers » Fri Feb 12, 2016 3:18 pm

Last question for the day
As the subject says, is it Audacity, or is it actually wxWidgets that it uses, that is limited to 10.6.SDK ?
rachalmers
 
Posts: 166
Joined: Wed Jan 06, 2016 10:53 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Is Audacity, or is it wxWidgets, that is limited to 10.6

Permanent link to this post Posted by steve » Fri Feb 12, 2016 4:35 pm

You mean when building on Mac OS X I presume?
I'm not certain (I'm very new to building on Mac) but I think that now we have updated WxWidgets it's Audacity that is the limiting factor. Hopefully not for much longer though. Work is currently starting to update to C++11 and to use a later version of gcc in our automated Linux builds. I'm guessing that updating the OS X build environment will not be far behind - I know that at least one of our lead developers is keen to update to a more recent version of Xcode.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46839
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Is Audacity, or is it wxWidgets, that is limited to 10.6

Permanent link to this post Posted by rachalmers » Fri Feb 12, 2016 4:53 pm

steve wrote:You mean when building on Mac OS X I presume?
I'm not certain (I'm very new to building on Mac) but I think that now we have updated WxWidgets it's Audacity that is the limiting factor. Hopefully not for much longer though. Work is currently starting to update to C++11 and to use a later version of gcc in our automated Linux builds. I'm guessing that updating the OS X build environment will not be far behind - I know that at least one of our lead developers is keen to update to a more recent version of Xcode.


Cool . Yes, Mac 10.11.3 XCode 7.2 SDK 10.11 Thanks for the heads up. I asked because earlier today I had wxWidgets pretty much built on my box here. and the Audacity ran pretty much to completion, although it still looked for 10.6 for something or other.

I gave it away at that point, as I have too much other work to do... the kind that pays the bills :-)

oh, and by the way, Audacity builds from the command line, but I haven't managed to get right what ever it needs to build in the XCode.app. But I'm not worried, as I don't have the time...
and in any case, now that the wizards are working on it.... :-)

Thanks for the pointers so far though. Interesting exercise.
rachalmers
 
Posts: 166
Joined: Wed Jan 06, 2016 10:53 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Is Audacity, or is it wxWidgets, that is limited to 10.6

Permanent link to this post Posted by steve » Fri Feb 12, 2016 5:06 pm

rachalmers wrote:oh, and by the way, Audacity builds from the command line, but I haven't managed to get right what ever it needs to build in the XCode.app.

I think that's mostly down to Apple. When I initially tried building on Mac, the Xcode GUI seemed very reluctant to work with anything other than its most recent SDK. Leland advised me to ignore the Xcode GUI and use the command line, and it's worked nicely ever since ;)
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46839
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Is Audacity, or is it wxWidgets, that is limited to 10.6

Permanent link to this post Posted by Gale Andrews » Sat Feb 13, 2016 4:03 pm

FWIW the Xcode 7.1 IDE builds Audacity OK for me on El Capitan. But you have to ignore its complaints about the 10.6 SDK being used, and not change any settings it suggests need changing.

Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Is Audacity, or is it wxWidgets, that is limited to 10.6

Permanent link to this post Posted by Gale Andrews » Sat Feb 13, 2016 4:07 pm

rachalmers wrote:As the subject says, is it Audacity, or is it actually wxWidgets that it uses, that is limited to 10.6.SDK ?

It was decided at the time that Audacity should still support OS X 10.6, because about 15% of Macs at the time still used that OS.

Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26087
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10


Return to Compiling Audacity



Who is online

Users browsing this forum: No registered users and 1 guest