Error in lauching Audacity

Building and customizing Audacity from the source code.
Forum rules
If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like
cmjone
Posts: 39
Joined: Fri Jul 06, 2012 12:00 am
Operating System: Windows 10

Re: Error in lauching Audacity

Post by cmjone » Wed Dec 10, 2014 12:24 am

Hi Edgar:

It is getting worse when I use the version you suggested. As usual, I created the two Release and Debug files and placed them in the proper place. I then double clicked the audacity.sln. Of course I needed to migrate or update the files for VS 2013. Immediately after migration, I found the Audacity directory had a red dot instead of green. The red dot also appeared in the win directory and the subdirectory Project. I went ahead and compiled Audacity. It did not work at all. I had no audacity.exe in the Release directory. Now I got 20 directories compiled successfully with 6 failed. It is worse than before. I also attach the build-output for you to review. Is it because of the VS 2013 or something is wrong with the code? Should I wait until after January next year? It is very frustrating.

Thank you in advance for your insight.
Attachments
Output-Build for vesion 13__.txt
(519.86 KiB) Downloaded 124 times

Edgar
Forum Crew
Posts: 1517
Joined: Thu Sep 03, 2009 9:13 pm
Operating System: Windows 7

Re: Error in lauching Audacity

Post by Edgar » Wed Dec 10, 2014 12:37 am

cmjone wrote: It is getting worse […] Is it because of the VS 2013 […] Should I wait
My apologies, 2.0.6 must be compiled with Visual Studio 2008 (you may have both VS 2008 & VS 2013 installed at the same time but, if you do and you want to use 2008, you must use "Open With" from the context menu (right click on the SLN icon).

As for waiting, you will need to decide that for yourself. I would strongly suggest not trying to use the current SVN HEAD for production work - it is still very much a work-in-progress and is undergoing comprehensive beta testing and bug fixing right now. If you need production code for the next 6 to 8 weeks you'll need to install VS 2008 and compile 2.0.6. However, there are some great new features in 2.1 and a lot of annoying bugs have been fixed - it must be compiled with VS 2013; I strongly suggest that you plan on updating to 2.1 as soon as practical.
-Edgar
running Audacity personally customized 2.0.6 daily in a professional audio studio
occasionally using current Audacity alpha for testing and support situations
64-bit Windows Pro 10

cmjone
Posts: 39
Joined: Fri Jul 06, 2012 12:00 am
Operating System: Windows 10

Re: Error in lauching Audacity

Post by cmjone » Thu Dec 11, 2014 12:01 pm

Hi Edgar:

I have no choice but to wait. I have de-installed VS 2008 from my computer and it is too much trouble to re-install it. When it January or February come, I will talk to you more. If you have more info, please send me a note.

Many thanks.

cmjone
Posts: 39
Joined: Fri Jul 06, 2012 12:00 am
Operating System: Windows 10

Re: Error in lauching Audacity

Post by cmjone » Fri Apr 17, 2015 4:47 am

Hello Everybody:
I am back. I got 2.1.0 successfully compiled for ASIO. I have been able to record and play. Now I am trying to make an installer by using the Inno setup compiler. After I opened up the .iss file, I know I had to change the code a bit to indicate the location of the Visual Studio. I un-commented Line 118 because the default drive letter is C and I changed it to D. Insert the word "source:" in front of the line and deleted the word "or". I then save/build/compile. Now I got an error message saying the DesDir was not indicated. I added this code ; DestDir: "{app}"; Flags: ignoreversion to Source: "D:Program FilesMicrosoft Visual Studio 12.0VCredistx86Microsoft.VC120.CRT". Then save/build/compile. Now I got an error message saying that the Microsoft file ....vc120.crt does not exist. But it is there. I am snowed. Would anybody shed some light on this problem.

cmjone
Posts: 39
Joined: Fri Jul 06, 2012 12:00 am
Operating System: Windows 10

Re: Error in lauching Audacity

Post by cmjone » Fri Apr 17, 2015 4:50 am

Hi:

I should also ask if there is anything else I need to know for making an installer.

Thanks.

Gale Andrews
Quality Assurance
Posts: 25982
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Error in lauching Audacity

Post by Gale Andrews » Fri Apr 17, 2015 11:11 pm

As I understand it you have now solved the INNO issues as per http://forum.audacityteam.org/viewtopic ... 19&t=84850.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual

steve
Site Admin
Posts: 48168
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Error in lauching Audacity

Post by steve » Mon May 25, 2015 12:55 am

saharmohamedali wrote:Thank you for all your responses really benefited from
Is your post related to this topic in some way?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

Post Reply