Problems compiling on linux

Building and customizing Audacity from the source code.

If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like

Problems compiling on linux

Permanent link to this post Posted by rhapsody0710 » Wed Mar 05, 2014 2:20 pm

Hi all!
I have just compiled Audacity successfully from svn codebase.
But still there are problems while linking:
3 "DSO missing error" with libX11.so, libogg.so and libvorbis.so.
I have to add them to link flag into src/Makefile manually.

So I wondered if there is any other method (maybe more elegant)
to correct this? I'm not familiar with autotools =_=

Thanks in advance!
rhapsody0710
 
Posts: 2
Joined: Wed Mar 05, 2014 2:02 pm
Operating System: Please select

Re: Problems compiling on linux

Permanent link to this post Posted by steve » Thu Mar 06, 2014 2:34 pm

It probably depends which distro you use.
On Debian based distros the steps 1 to 8 described here should usually work without additional options or configurations: http://wiki.audacityteam.org/wiki/Compi ... ux_Mint.29

autoreconf should only be required if there have been files added or removed since the makefile was last updated. I built on Debian stable a few days ago (r13063) and autoreconf was not required. I'm not aware of any added or removed files since then (https://groups.google.com/forum/#!forum/audacity-svn)
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 47011
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Problems compiling on linux

Permanent link to this post Posted by rhapsody0710 » Thu Mar 06, 2014 2:56 pm

Thank you steve.
My distro is Archlinux. And the Audacity version I compiled is also r13063.
rhapsody0710
 
Posts: 2
Joined: Wed Mar 05, 2014 2:02 pm
Operating System: Please select


Return to Compiling Audacity



Who is online

Users browsing this forum: No registered users and 2 guests