Audacity 1.3.13-beta & Slackware 13.1 & wxWidgets-2.8.12 OK

Building and customizing Audacity from the source code.
Forum rules
If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like
Post Reply
jesseg
Posts: 1
Joined: Wed Aug 17, 2011 3:44 am
Operating System: Please select

Audacity 1.3.13-beta & Slackware 13.1 & wxWidgets-2.8.12 OK

Post by jesseg » Wed Aug 17, 2011 4:06 am

Good day,

After hours of banging my head, I was about to ask if any version of Audacity can be compiled on Slackware 13.1, but then, thank the Lord, the solution dawned on me.

For those who're out of their minds trying to get Audacity 1.3.13-beta & Slackware 13.1 & wxWidgets-2.8.12 to work together, I found that wxWidgets of this version defaults to compile without unicode support (which can be overridden when you ./configure it with --enable-unicode) and I also found that Audacity of this version ./configure's by default with unicode support.

(However, if you need unicode, which you may for non-US character sets, you would probably want to recompile wxWidgets with unicode turned on.)


Moderator note: Added from duplicate post


Also had to remove ffmpeg import support in order to get Audacity to compile:

./configure --enable-unicode=no --with-ffmpeg=no && make && make install

I had to first install some other stuff, like libmad, libsndfile, and perhaps Ogg Vorbis, but those went without event


Jesse

Post Reply