SOLVED: Failed Build SND_PCM_TSTAMP_ENABLE Undeclared 1.3.11

Building and customizing Audacity from the source code.

If you require help using Audacity, please post on the forum board relevant to your operating system:
Mac OS X
GNU/Linux and Unix-like

SOLVED: Failed Build SND_PCM_TSTAMP_ENABLE Undeclared 1.3.11

Permanent link to this post Posted by pizzapie » Thu Mar 04, 2010 12:24 am

I am trying to build on gNewSense, but I get this error from building Audacity 1.3.11.
Code: Select all
src/hostapi/alsa/pa_linux_alsa.c: In function ‘PaAlsaStreamComponent_FinishConfigure’:
src/hostapi/alsa/pa_linux_alsa.c:1373: error: ‘SND_PCM_TSTAMP_ENABLE’ undeclared (first use in this function)
src/hostapi/alsa/pa_linux_alsa.c:1373: error: (Each undeclared identifier is reported only once
src/hostapi/alsa/pa_linux_alsa.c:1373: error: for each function it appears in.)
make[2]: *** [src/hostapi/alsa/pa_linux_alsa.lo] Error 1
make[2]: Leaving directory `/home/alex/audacity-src-1.3.11-beta/lib-src/portaudio-v19'
make[1]: *** [portaudio-v19-recursive] Error 2
make[1]: Leaving directory `/home/alex/audacity-src-1.3.11-beta/lib-src'
make: *** [audacity] Error 2

This was fixed by changing, "SND_PCM_TSTAMP_ENABLE," to, "SND_PCM_TSTAMP_MMAP," in file, "audacity-src-1.3.11-beta/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c," in line 1373. I hope this helps anyone else with this problem. It compiled successfully.
Posts: 3
Joined: Thu Mar 04, 2010 12:10 am
Operating System: Please select

Return to Compiling Audacity

Who is online

Users browsing this forum: No registered users and 1 guest