Latency Error==I can no longer overdub

This section is now closed.
Forum rules
Audacity 1.3.x is now obsolete. Please use the current Audacity 2.x.x package for your distribution or compile Audacity from the source code.
hsweet
Posts: 5
Joined: Wed Dec 21, 2011 2:39 pm
Operating System: Please select

Latency Error==I can no longer overdub

Post by hsweet » Wed Dec 21, 2011 2:59 pm

I've been using Audacity with no problems until 2 days ago when I started getting this message when attempting to record a 2nd track
(First track records fine)

Code: Select all

Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool (<---> or F5) to drag the track to the right place.
  • I'm using Audacity 1.3.13-beta/Ubuntu 11.10, recording from a H2/USB or Mobile-pre.
    Latency Correction -100ms
    If I remove latency correction, or start 2nd track after 0 it still does no longer record a 2nd track, but no error. It starts a track and turns off recording immediatly

steve
Site Admin
Posts: 80326
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Latency Error==I can no longer overdub

Post by steve » Wed Dec 21, 2011 3:17 pm

The error message is a bit misleading in this situation.
What has happened is that (for some reason) recording has stalled right at the beginning of the recording.
The new track (which may be just a few samples, or even no audio at all) was moved to the left, as per the "latency correction" settings, but because the track is so short, any existing audio data would be before time=0. Audacity has attempted to recover from this situation by "undoing" the latency correction.
The problem is not with the latency correction, but that the recording has stalled.

The most likely reason is that you have inadvertently changed a setting somewhere.
Check in the Transport menu that "Software Playthrough" is not enabled.
Check in "Edit > Preferences > Quality" that the default sample rate is the same as the sample rate selected on the H2.
Check in "Edit > Preferences > Recording > Latency" that the audio buffer is set to 100 (default).
Try restarting Audacity.

Also check that no other audio application has grabbed exclusive control of the sound system - Easy way to do that is to restart the computer and then try recording before launching any applications other than Audacity.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

hsweet
Posts: 5
Joined: Wed Dec 21, 2011 2:39 pm
Operating System: Please select

Re: Latency Error==I can no longer overdub

Post by hsweet » Wed Dec 21, 2011 9:48 pm

Thanks, but none of that seems to help. I'm not sure what I might have changed, either in or outside of Audacity.

But I just tried turning off Overdub and it seems to work again. :?: I don't remember changing that and I thought it needed to be on for overdubbing..
Check in the Transport menu that "Software Playthrough" is not enabled.
Check in "Edit > Preferences > Quality" that the default sample rate is the same as the sample rate selected on the H2.
Check in "Edit > Preferences > Recording > Latency" that the audio buffer is set to 100 (default).
Try restarting Audacity.

hsweet
Posts: 5
Joined: Wed Dec 21, 2011 2:39 pm
Operating System: Please select

Re: Latency Error==I can no longer overdub

Post by hsweet » Thu Dec 22, 2011 1:37 pm

Spoke too soon. If overdub is off I can record 2nd track BUT first track does not play, which defeats the purpose.

I just tried to run audacity from a terminal to capture the background stream. I get this when I try to record a 2nd track with overdub on...

Code: Select all

Expression 'err' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3282
Expression 'ContinuePoll( self, StreamDirection_In, &pollTimeout, &pollCapture )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3809
Expression 'PaAlsaStream_WaitForFrames( stream, &framesAvail, &xrun )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4181
I'm thinking bug. It points to the line in the source code. Would it make sense to try running with Jack?

Just for fun, here is the rest of the capture from startup

Code: Select all

ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4537
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4537
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4537
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4537
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4537
Expression 'err' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3282
Expression 'ContinuePoll( self, StreamDirection_In, &pollTimeout, &pollCapture )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3809
Expression 'PaAlsaStream_WaitForFrames( stream, &framesAvail, &xrun )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4181

steve
Site Admin
Posts: 80326
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Latency Error==I can no longer overdub

Post by steve » Thu Dec 22, 2011 1:56 pm

What device are you using for playback?
Have you checked the things in my previous post?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

steve
Site Admin
Posts: 80326
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Latency Error==I can no longer overdub

Post by steve » Thu Dec 22, 2011 2:01 pm

If you wish to add more information, please make a new post rather than editing an existing one. It can get very confusing if the messages are out of order.
Topic moved to Audacity 1.3.x forum
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

kozikowski
Forum Staff
Posts: 68649
Joined: Thu Aug 02, 2007 5:57 pm
Operating System: macOS 10.13 High Sierra

Re: Latency Error==I can no longer overdub

Post by kozikowski » Thu Dec 22, 2011 2:17 pm

That's what the Overdubbing setting does. It allows Playback and Recording of different tracks at the same time.

Just a suggestion from the error logs. You're trying to play and record from two different USB adapters? I can well imagine that might drive the system nuts because it's trying to juggle two different unsynchronized bitstreams at once. I've only gotten overdubbing to work reliably with one external device.

http://www.kozco.com/tech/audacity/pix/ ... Lenovo.jpg

Koz

hsweet
Posts: 5
Joined: Wed Dec 21, 2011 2:39 pm
Operating System: Please select

Re: Latency Error==I can no longer overdub

Post by hsweet » Thu Dec 22, 2011 3:25 pm

kozikowski wrote:st a suggestions from the error logs. You're trying to play and record from two different USB adapters
Not in the same session. I've been using the internal card for output, or I could until a few days ago.

But I tried setting in and outputs via the M-Audio USB adaptor and overdub worked, but the 2nd track was getting feedback
or something weird. But then I tried changing the output back to my internal sound card with in from the USB and everything is fine again.

thanks for the help

bgravato
Posts: 2080
Joined: Wed Jan 13, 2010 8:56 pm
Operating System: Please select

Re: Latency Error==I can no longer overdub

Post by bgravato » Mon Jan 02, 2012 6:32 pm

Just a little clarification about some of the Audacity error messages on the terminal...

On startup Audacity tries to probe for audio devices... That usually generates a lot of "fake error messages" on the terminal, which are not really error messages (in the sense that something is breaking).

For example this message...

Code: Select all

ALSA lib audio/pcm_bluetooth.c:1613:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
...is Audacity trying to probe for bluetooth audio devices... which you probably don't have, hence it generates that error messages, but that's something you don't need to worry about or that will cause any other kind of failure in Audacity.

I agree this error messages during device probing phase on startup can be a bit misleading, but I guess it's better to be too verbose than the opposite...
Include as much details as you can in your post (Audacity version, Operating System, Equipment used, etc).
Please post your question in the appropriate forum (regarding audacity version and operating system).

tbear2500
Posts: 1
Joined: Tue Apr 10, 2012 9:55 pm
Operating System: Please select

Re: Latency Error==I can no longer overdub

Post by tbear2500 » Tue Apr 10, 2012 10:01 pm

Did you ever get this problem solved? I'm having what seems to be the same problem and nothing fixes it. If I change my output to the MobilePre I get a weird feedback/echo effect (which I'm guessing is the same as what happened to the OP) and if I change it to, say, front (which is my laptop's headphone port and should be the same as default) the same thing happens. Recording stalls as it did for the OP if I use default output.

Locked