Не работают Calf Plugins в Audacity

Русский

Moderator: prokoudine

Forum rules
ImageБо́льшая часть сообщества Audacity говорит только по-английски, поэтому мы не обещаем ответ на вопросы по-русски.

Если ваш вопрос здесь остался без ответа и вы говорите по-английски, пожалуйста, попробуйте задать вопрос в секции, соответствующей вашей операционной системе (Windows, macOS, Linux).
Post Reply
userman
Posts: 50
Joined: Fri Nov 18, 2016 11:36 am
Operating System: Linux *buntu

Не работают Calf Plugins в Audacity

Post by userman » Wed Feb 10, 2021 1:09 pm

Операционная система, Linux Ubuntu Studio 20. LTS.

Проблема началась сразу же, в Audacity 2.4.2 криво работают Calf плагины.

Интерфейс у них не такой каким должен быть.

Некоторые не работают совсем. Хотя в том же Ardour отлично работают все плагины. С нужным интерфейсом.

В чем может быть проблема?

jademan
Forum Crew
Posts: 1339
Joined: Fri Jul 17, 2009 10:11 pm
Operating System: Windows 10

Re: Не работают Calf Plugins в Audacity

Post by jademan » Thu Feb 11, 2021 12:28 pm

userman wrote:
Wed Feb 10, 2021 1:09 pm
Operating system, Linux Ubuntu Studio 20. LTS.

The problem started immediately, in Audacity 2.4.2 Calf plugins work crookedly.

Their interface is not what it should be.

Some don't work at all. Although all plugins work fine in the same Ardor. With the right interface.

What could be the problem?
Not a unix guy here; perhaps someone will come along and comment. In the meantime, consider this. A 64-bit plugin will not work on a 32-bit system. If your Audacity is 32-bit, then you will need a 32-bit plugin.

I hope this helps. :D

steve
Site Admin
Posts: 81404
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Не работают Calf Plugins в Audacity

Post by steve » Thu Feb 11, 2021 12:40 pm

Ubuntu 18.04 LTS
Audacity 2.4.2 built from source code (https://github.com/audacity/audacity/re ... city-2.4.2)
Calf Studiogear 0.0.60-5 from Ubuntu repository.

-- Google Translate --
Ubuntu 18.04 LTS
Audacity 2.4.2 построен из исходного кода (https://github.com/audacity/audacity/re ... city-2.4.2)
Плагины Calf Studiogear 0.0.60-5 из репозитория Ubuntu.

Screenshot.png
Screenshot.png (372.33 KiB) Viewed 829 times
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

userman
Posts: 50
Joined: Fri Nov 18, 2016 11:36 am
Operating System: Linux *buntu

Re: Не работают Calf Plugins в Audacity

Post by userman » Fri Feb 12, 2021 8:20 am

jademan wrote:
Thu Feb 11, 2021 12:28 pm


Not a unix guy here; perhaps someone will come along and comment. In the meantime, consider this. A 64-bit plugin will not work on a 32-bit system. If your Audacity is 32-bit, then you will need a 32-bit plugin.

I have 64 bit Linux OS and all programs are 64 bit.

steve
Site Admin
Posts: 81404
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Не работают Calf Plugins в Audacity

Post by steve » Fri Feb 12, 2021 8:26 am

Audacity is usually 64-bit on 64-bit Linux. It definitely is if you build from source code. (See: viewtopic.php?f=19&t=111755)
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

userman
Posts: 50
Joined: Fri Nov 18, 2016 11:36 am
Operating System: Linux *buntu

Re: Не работают Calf Plugins в Audacity

Post by userman » Fri Feb 12, 2021 8:33 am

steve wrote:
Thu Feb 11, 2021 12:40 pm


-- Google Translate --
Ubuntu 18.04 LTS
Audacity 2.4.2 построен из исходного кода (https://github.com/audacity/audacity/re ... city-2.4.2)
Плагины Calf Studiogear 0.0.60-5 из репозитория Ubuntu.


В Ubuntu 16.04 и у меня отлично работают Calf Plugins, я же писал что речь идет о Ubuntu 20.04.

steve
Site Admin
Posts: 81404
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Не работают Calf Plugins в Audacity

Post by steve » Fri Feb 12, 2021 8:42 am

I don't yet have Ubuntu 20.04. I'll check this when I update Ubuntu.
У меня еще нет Ubuntu 20.04. Я проверю это, когда обновлю Ubuntu.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)

userman
Posts: 50
Joined: Fri Nov 18, 2016 11:36 am
Operating System: Linux *buntu

Re: Не работают Calf Plugins в Audacity

Post by userman » Fri Feb 12, 2021 11:47 am

На другом форуме опубликовали возможную проблему.
Хочу что бы разработчики Audacity обратили на это внимание.

"В 16.04 и 18.04 Audacity собран с GTK2. В 20.04 с GTK3. Но везде используется libwxgtk3.0-0v5"

Это один из возможных вариантов почему в Ubuntu 20.04. урезанный Gui в Audacity.

A possible issue was posted on another forum.
I would like the Audacity developers to pay attention to this.

"On 16.04 and 18.04 Audacity is compiled with GTK2. On 20.04 with GTK3. But libwxgtk3.0-0v5 is used everywhere."

This is one of the possible options why in Ubuntu 20.04. stripped down Gui in Audacity.

Post Reply