Zoom h2n and 9997 error

MacOS 11.3
Audacity 2.3.1

I’ve noticed a few others having problems recording with the Zoom H2N to audacity but no-one with my specific issue or one that provides answers. This one (https://forum.audacityteam.org/t/removing-part-of-a-vocal/8843/1) seems to be similar but no solution is provided.

Problem: 9997 error (invalid sample rate). Clicking on record or on mic monitor.

With the h2n set as an audio interface, it is set to 48kHz and can’t be changed. In Audacity preferences/quality, I set default sampling rate to 48000. This is never actuated as far as I can tell. I still get the error and, even creating new empty tracks from the Tracks menu, the tracks are set to 44.1kHz.

Any ideas?


The sample rate can be selected when you connect the H2n to the computer.

Press “>>|” to select “Audio IO I/F”
Press “o” (record)

“Frequency 48 kHz” press “o”

Use “|<<” or “|>>” to select 44.1 kHz
Press “o”

Use “|<<” or “|>>” to select “CONNECT”
Press “o”

I don’t get that Steve,

If you’re not connected via usb then you can adjust sample rate etc. Connected, I get USB AUDIO I/F ––> Stereo mix/Multi track (choose Stereo mix) ––> goes to level meter. Pressing the record button at any stage does nothing (because I have set USB AUDIO I/F I guess).

Happily, there is a solution (which – apologies – I should have checked before posting). Upgrading to the latest Audacity fixes the issue. Also, setting Audacity preferences/Quality to 48000 now works and new tracks are created with this.

A little testing in case anyone else has similar issues. As my H2N is stuck on 48000 (it seems) when connected via USB, Audacity preferences/Quality needs to also be set to 48000 before monitoring/recording. Setting it to 44100 now produces a cryptic 9986 error (Internal PortAudio error).


I’m glad you got it to work. :smiley:

Here are some detailed instructions to set the H2n to 41000Hz, should the need ever arise.


I see that it’s slightly different on the H2n from the original H2 which I’ve got.
For the H2n, see page 60 of the H2n user manual (available here: https://www.bhphotovideo.com/lit_files/67854.pdf)


But as noted, I don’t get the option to select sampling rate. Selecting ADUIO I/F, I then get the option to select either Stereo mix or Multi track and that’s it. I’m on the latest 3.0 firmware from Zoom. This was apparently released 2020 according to Zoom’s website but the file itself says 2017. Regardless, the system reports 3.0.


It’s definitely the black H2n I have. p.60 of the manual is not what I see. There is no option to change sampling rate – selecting Audio I/F goes to the selection of stereo or multi then to level monitoring (showing it at 48000).

I guess they changed something in later firmware. I’m not bothered as I can now record with the H2n to audacity (latest update) which is what I wanted.