YETI Playback Distortion

I have borrowed my buddy’s Yeti mic, and it works fine with Quicktime, Photobooth, Reaper, for both playback and recording. When I use Audacity, however, the Microphone records great, but playback is extremely distorted and static-y through the microphone. This is only the case through Audacity. This is remedied if I change the output to System Output, but that requires switching the headphones back and forth and that’s annoying, plus I know this can work!!!

Some things I have tried are fiddling with System Preferences regarding Sound Input + Output, selecting Hardware Playthrough under monitoring, and playing with levels on the mic and/or output to make sure it’s not an artifact of the mic settings… as I said, the file itself is not flawed because I can play it back through other devices with clear signal.

Please let me know if you have any ideas. Thanks.

What are you doing? Are you overdubbing to create three part harmony with yourself, or are you just playing a sound file that appears to play everyplace else?

Audacity > Preferences > Recording. Only one thing should be checked in that top block. Overdub OR Software Playthrough.

While you’re playing the file, reduce the Audacity playback volume with the Speaker +/- slider over the blue waves. Did that help? Did it change? It’s possible to get crackly playback under Mavericks with Audacity 2.0.5 even though everything else is working OK. Distorted is another matter.


This playback problem occurs whether or not it is audio I have recorded. So I can play back a take of me playing guitar, or an Mp3 imported as waveform, and either one will sound like crap through the mic. I have adjusted audacity’s volume like you mention, as well as all other volume settings (on the mic itself, Mac settings). Any sound file sounds crappy, frizzed-out like an 8-bit nintendo.

Settings in Preferences > Recording don’t have an effect.

If I plug headphones into the laptop, in lieu of the mic, the sound is clear; ditto using other programs with the mic as headphone out. Just audacity has this problem.

I have adjusted audacity’s volume like you mention, as well as all other volume settings (on the mic itself, Mac settings). Any sound file sounds crappy, frizzed-out like an 8-bit nintendo.

You missed a step. Did it change the volume when you did that?


Sure. I can make the volume loud or quiet. The playback isn’t in the red. Either way it is distorted playing back through the mic output, not so through the system output. What step do you think I have missed?

Just to be clear, I am talking about the headphone out on the USB microphone when I refer to “mic output,” if that wasn’t apparent.

What step do you think I have missed?

You told us the sound was distorted but not whether or not the volume changed. We can only go with what you tell us and I wanted to know if the tools seem to act normally even if the sound doesn’t.

Do you use Soundflower? You can get very serious science fiction feedback loops if you leave Soundflower in the sound pathway by accident.

Can you record the distortion? Hold your cellphone up to the speaker and run the Personal Sound Recorder. Record a voice so the cellphone processing doesn’t mess it up. Sometimes we can tell in four seconds the direction of the problem just by listening or roughly analyzing the distortion.


I made you a recording. When I play the Yeti version (distorted), I adjust the mic volume while playing so you can hear how the volume is irrelevant to the distortion.

Let me know what you think.

Perfect. Now we get to rip it apart and see if we can figure out what happened.

What version of OS X?

How did you record the M4A file - with Soundflower?

I don’t see any clipping (flat wave tops) in the bad recording, but it looks in Analyze > Plot Spectrum as if the audio has had much of the bass below 400 Hz removed.

Have you looked in /Applications/Audio MIDI Setup? Set the Yeti output to 48000 Hz and 16-bit 2 ch or 1 ch. Play with only one track present in Audacity. Set project rate bottom left to 48000 Hz. The point of the 48000 Hz (if it makes any difference) is that it’s the “native rate” of the Yeti.


Used my iPhone’s voice message recorder for the recording; that’s probably why there are reduced bass frequencies, too.

I tried 48000 on Audio-Midi, still got distortion. After, I tried Audio-Midi 48000 with Audacity set to 48000 as well and that did not seem to improve things (I just changed to 48000 for the Yeti because I didn’t think it would matter changing the system out. When I change everything to 48000 in Audio Midi, the system plays it fine, the mic output still distorts it.) :frowning:

The loss of bass was only in the second half of your recording that sounded bad.

If you did the entire recording of the sample you attached on the iPhone, then the cause is still unknown.

Does 2.0.2 or 1.3.13 have the same problem? Try the zip’s for Mac here: .


I went back and installed the older of the two… that one works fine! Not sure why, but good enough for me.

Thank you.

Thanks. If you get a chance to try 2.0.2 or 2.0.3, it might be useful to know - but I have no more idea than you.