wxWidgets crashes_third-party plugins

Just wanted to post a follow up to my initial post… Had a phone tech session with Apple/Logic Pro X support over the weekend and after 3 calls we finally got things (mostly) running again. Turns out that a somewhat helpful partial fix was to remove Logic Pro X preferences. Specifically: com.apple.logic10.plist.
I wasn’t aware that plist files could have such a terrible effect on the whole system performance like I was experiencing.

Does Audacity have any similar preferences files that can be relatively safely deleted when things aren’t working well?

The Wxwidgets debug dialog is still coming up from time to time, generally only happens when I have run a 3rd party plug-in, either VST or AU. Happens after applying the plug-in settings, but before can totally close out the plug-ins screen. Good news is that although the debug dialog is popping up, it is no longer crashing when I choose “cancel”.

As for removing expired plug-ins, I just went into the Library/Audio and manually removed/deleted AU components or VST’s I wanted out of the system. Otherwise seems much improved, other than dropping USB recorder interface. But that is easily fixed by powering off USB device and then back on and having Audacity re-scan audio devices.

One lingering issue I have still is that sometimes, especially when I have Audacity and some other Audio program open I get a system freakout (best I can really explain it). If you’re not offended by some blue language, I posted a YouTube Video to show Apple Support after I was tired of explaining the issue over and over again. Check out this video on YouTube:


Worst thing when this happens is that the files are not saved by Audacity and when I tried to re-open Audacity it failed to recover the files. I had a data folder in my default save location but there was not .aup file.
I ended up finding the files (I think) but they are now all out of order and are cut into 6 sec increments and all jumbled up. The method as shown here is not working for me:


Audacity has a configuration file, called audacity.cfg. It resides in

~/Library/Application support/audacity/

If you quit Audacity, remove or rename the file and restart Audacity, it’ll start up with a blank slate. I’ve never seen plists or cfg files affecting other programs, though.

Not all plugins are compatible with Audacity.

In fact, there’s no DAW out there that runs all plugins. Some are old, other have dodgy programming and some might be too new (VST3’s, fi). I’m currently testing approximately 50 free plugins, but none are 32 bit, none are VST3. Audacity is pretty stable, although it can’t run some of them. Most noteworthy, instrument VST’s ,as there is no MIDI in Audacity. Those I can’t test in Audacity, get tested in Reaper or in Sony’s Sound Forge Pro.

But I’m pretty certain there’s something fundamentally wrong with your system, after viewing the video.

Do you have another keyboard to try?

Have you tried starting up without your present keyboard? I know you can’t test everything without a keyboard, but it’s just to rule out a whacky keyboard. Failing hardware can result in hairloss, or swearing sometimes :smiley:

Also, you could download EtreCheck. It’s a system software listing tool. It provides a detailed report about the software on your system and if you post the results here, maybe someone might notice a problem there. See:


It’s been a long time since I’ve seen a Mac behaving like this. I hope we can find a fix…

Yeah ive dealt with the audacity.cfg before. I know this probably not the best or official procedure but i keep the audacity .zip files for all the versions back to 2.1.0, i just dont keep them in PATH or in apps dir. I usually only have the most current ver of Audacity in apps dir, save for a particular nightly build i got some months back that wotked pretty well. Its in apps and renamed audacity_nightly.app. Usually keep current version docked but can open audio with rt click and open with if want to run nightly build. I dont run them both at same time.

Ive had pretty good luck running almost any regular VST and AU plugins. On the mac almost everything runs, except virt instruments. Per initial post i sent message to Meldaproductions about crashes with a couple of theirs and funny enough they had just released a new version 9.17 feb 6th or so and they replied that they had identified a couple of issues similar to what i was seeing and voila, they released ver 9.18 something like only 6 days after 9.17. So anyone using their plugins should skip or trash ver 9.17.
The Crazy beh in the video hasnt come back yet since deleting the plist files for Logic Pro 10. yet.

So i guess the last annoying thing i have with audacity is with the vol and fader sliders for ind tracks. Anything more than 3 tracks and the fader slider isnt visible because the tracks are doing this auto minimize dance when file is playing. Is there anyway to zoom or freeze the track so that it stops auto collapsing the track im viewing or adjusting. I like to move sliders while file is playing and the auto min thing is driving me a bit crazy as have to keep manually expanding the track vertically to see the pan sliders. If that doesnt make sense ill be glad to post a video of that, minus the swearing. In other video i had just spent like 3 hours editing that project when it freaked out. If you noticed it didnt seem like was just randomly keystuck. Looked more like a script or something as it closed logic without saving then proceeded to open force quit and kill 3 open audacity projects. I ran malware bytes just in case, was clean.

There’s nothing wrong with your procedure. Renaming an Audicity version is fine. Even running two versions at the same time works, for TESTING purposes. I wouldn’t do production that way. It’s asking for trouble.

And you have to be aware that both Audacity versions will be using the same cfg file, UNLESS you install them “portable”. See:


Good to know! Thx.

Now I have to restart the test of Melda’s plugins :unamused:

Good. Sometimes even a restart of the machine is what you need.

I’ve never seen that - and I often have a lot of tracks in a project…

Still sounds as if something on your Mac is clicking on random buttons… Or is there some prefs setting I can’t remember?

It’s good to hear you are aware it could be malware. I was hesitant to write it before, but the thought crossed my mind too.

I’m still interested in seeing your EtreCheck report. It can show crapware, such as MacKeeper.

There are some nasty scripts around, but their distribution is low. There is even a very nasty backdoor around, but that is a targeted attack on govt staff in some countries. I suppose you’re not govt staff… :laughing:

It’s not random, but failing/stuck keyboards can send anything repeatedly. Like command-c, for cancel, as we were seeing in your video. Do you use any macro tool, or keyboard enhancer?

Hitting command-s to save will become a habit, I think. :mrgreen:

So can you confirm that Melda 9.18 plugins are not crashing now in Audacity?


Audacity > Preferences… and uncheck “Automatically fit tracks vertically zoomed”. That does not stop you using COMMAND + SHIFT + F at any time to fit tracks as far as possible into the vertical space.


What happened - a flat line track after recovery?

Note that if you were to restart the Mac and you had not yet saved a project, the reboot wipes the temporary data, because we don’t store the temporary data in a location that survives reboot. Hopefully that will be addressed in a future Audacity version.

If Automatic Crash Recovery is incorrect, post the log from Help > Show Log… here then Force Quit Audacity if you can’t leave it open. Force Quit will preserve the data and the temporary AUTOSAVE file Audacity was trying to recover from.

That “manually” process only works for unedited recordings.

There is no AUP file until you save a project at least once.


Do you mean this dialogue or something else?

Is this after pressing “Apply” in an effect?

Are you running a Debug nightly build of 2.1.3-alpha, or 2.1.2 release? Note that there are nightly builds in release configuration (the ones not marked “Debug”).

If you use 2.1.2 release or a nightly build in release configuration you might not see a wxWidgets Debug dialogue that you have to cancel.


Is this the choppy sound you mentioned? If so did you try reducing “Audio to buffer” in Recording Preferences as I suggested?

If the connection to the USB device is being lost, try a much higher buffer setting. Experiment.


So far the Melda 9.18 plug-ins are working pretty well with a couple exceptions where every once in a while the plug- in appears to loose the connection or synch to audacity host. Applying the plug in doesnt get written to the file and playing the file and adjusting settings in the plug in dont appear to affect the file. This doesnt just apply to Melda plug- ins. Not too often but once in a while.

Yes, it’s the same wxWidgets debug dialogue popup. Thankfully it no longer crashes the entire app when I hit cancel. Hitting yes or no doesn’t seem to do anything beneficial I can see anyway and would just rather not see it pop up. In the past I would also get an apple prompt about some debug app needing me to enter password. When those came up I would enter the password then it would still display the wxwidgets message, and selecting anything would just crash out the entire app.

Yes the Melda plug-ins seem to be working pretty well now, as well as all my other plug-ins on the Mac. The error I was mentioning in previous post isn’t just with Melda, also happens with all other plugins, Waves, Plug-in Alliance, etc. It’s a little frustrating because It’s sometimes hard to see exactly when it is happening. Will be using one plug in or another and can hear the changes being reflected in the playing audio. Then I’ll apply that plug-in setting, then open another plug-in for example and then all of a sudden the settings applied to that plug in are not making any audible difference in the playing audio. This was just easiest to notice using some particular Melda Plug-ins.

In my example I was using MAutoVolume and had applied those settings just fine, closed Auto Volume and opened MAutoAllign. This one will give an error message when the disconnect happens. So playing the audio file and pressing the analyze button will return an error about plug-in not detecting audio or plug-in bypassed. This is always corrected by either closing out all Audacity files/projects open and then restarting Audacity. Occasionally this doesn’t work but has always be fixed after rebooting the Mac.

Looks like version 9.17 had some serious issues as they don’t even post it on their site anymore under the previous versions of their plug-ins. Skips from 9.16 to the current 9.18 versions.

Actually, I’m not seeing the debug popup as much anymore since I’m using a nightly build from last weekend. The version I’m using mostly now is showing up as 2.1.3 alpha. I’ve seen that there are those two files, nightly and debug. Can you clarify what exactly are the differences?


Does it apply only to VST’s or only to Audio Units, or both?


Is that specific error message confined to the faulty 9.17 plugins?


The nightly builds on http://www.audacity.homerow.net/index.php?dir=mac/&sort=date&order=desc are supplied in debug configuration (the folder says “audacity-nightly-debug”) and release configuration (the folder says “audacity-nightly”).

Debug versions will often report assertion errors in the code that may or may not lead to crashes. Debug versions may also show extensive reporting at Help > Show Log… .

Release versions will usually not show assertion errors (except on Linux). The same scenario that causes an assertion error and crash in the Debug build may not create any problem in the Release build. The release build will have less reporting in the log.

All “nightly” builds between Audacity releases (like 2.1.1, 2.1.2 and so on) are alpha builds from latest source code. These alpha builds are intended for testing. We are pleased to receive reports of problems in these alpha builds but they should not be used for your regular production work because of the higher probability of serious bugs when new features are being implemented or changes being made.


So problems still happening. Made this video to send to Waves and Melda. If anyone here has any ideas that would be helpful also.

You’ll see some of the issues with Audacity on the video as well.


Thanks. I myself don’t have time to watch a half hour video but feel free to make a few succinct bullet points of any issues you think are directly relevant to Audacity and do not occur in other audio editing apps that you use.

Also name the plugins. You seem to show Greg Wells Waves plugins at the start, for example.


I’m going to edit it down but I’ll rewatch it and post some times especially relating to Audacity. I believe around 14 min I have Greg wells voice centric or mix centric open and you’ll see entire Audacity crash with the wxwidgets error and exec corpse notify message. Also will see how slow the computer is running with audacity, plugins or not up. Beach balling like crazy. I’ll post some specific times that may be of specific interest to Audacity folks.

Audacity crash is around 18:40

I have another short video with more specific Audacity issues. I’ll edit specific Audacity issues into one video less than 5 min with just the specific Audacity issues. I’ll post that link when I get it uploaded.