wxWidgets crashes_third-party plugins

2016.02.11.asl.zip (36.5 KB)
Mac mini.spx.zip (235 KB)
system.log (1.36 MB)
Audacity_2016-02-11-190720_Erics-Mac-mini.crash (59.7 KB)
Have many issues with crashes on el cap and logs all mostly pointing to wxwidgets issue. Crashing at various times, usually when starting or applying 3rd party plug-ins. Many errors related to “bad access”. Saw articles that version of audacity released all have wrong version of wxwidgets. Which one do i need to install 3.0.2 or something else. Current have audacity 2.1.2 but also a nightly build that shows as 2.1.3. But this issue no matter which audacity version tried. Lately no crash reports coming up anymore though. Once a debug report does come up, pressing any button crashes the app.

eric bruce

The point of that is that you can use Plug-in Manager to disable the plugins that are bad.

Please name the plugins that crash and give us a URL where we can download them. Are you saying all plugins crash? If so are they all VST’s, Audio Units or something else?

Please send us the Audacity Debug Report so we can see all the plugins you have. If you see the Debug Report window when Audacity crashes, send us that Debug Report.

If you don’t see the Debug Report window when Audacity crashes, restart Audacity and generate the report manually using Help > Generate Support Data… .


In your message to feedback@ and -quality your subject line suggests the crashes started after updating Xcode yesterday. Is that correct - these crashes only started yesterday?

Despite that do I understand the 2.1.3-alpha that crashes is a nightly build you downloaded and not a build you made yourself?


I’ve had the issue with these crashes off and on since 2.1.0 and 2.1.1. The particular plug-ins are from Waves and MeldaProductions. Mostly happens with Waves Vocal Rider stereo, and especially Waves Greg Wells mixcentric and vocal centric plugins. With MeldaProductions its with MAutoAllign and MAutoVolume. Also with Plugin Alliance Cleansweep Pro. Since the XCode update yesterday its causing crashes on my other DAWs logic pro x and studio one 3 where they crash loading AU plugins and before the program can even launch. Ill post some logs and screenshots on this thread as well.

Audacity_2016-02-11-190720_Erics-Mac-mini-2.txt (59.7 KB)
These crashes have been pretty frequent for me from day one using Audacity on Mac OS-X El Capitan. The Specific plug-ins I notice happens to the most are Waves Vocal Rider and Waves Greg Wells Mixcentric and Greg Wells Voice Centric. What usually happens is that I launch the plug-in and it usually opens and runs. I’ll get the setting for the plug-in the way I like it and then hit “apply”. It is after hitting apply that the Audacity debug log may come up. (it used to come up frequently this way on Audacity 2.1.1 but since 2.1.2 and the nightly debug version 2.1.2 alpha (or 2.1.3) the debug log no longer appears. Even so when it does appear no matter which option I select the entire thing will crash. Hitting yes, no or cancel all has the same effect, which is for audacity and the running plug in to crash. Now with the newer builds of Audacity it just silently crashes with no debug prompt or offer to send a debug report.

The crashes started becoming more common after the recent Xcode update, but these crashes have existed for me on Audacity 2.1.0, 2.1.1 and 2.1.2 and now on the debug version 2.1.2 alpha or 2.1.3 as i see it listed in about part of Mac. I have tried to run Audacity after disabling the System Integrity Protection in El Cap but that doesnt seem to have any effect. I’m currently running with that disabled so that I can use the extra features in Bartender and Xtra Finder. essage I’ll copy one of the Audacity Crash reports from the console app. Since the Xcode update yesterday it has gotten exponentially worse. For example, in a 1 hour period where I was trying to launch and use my audio apps, Studio One 3, Logic Pro X and Audacity I had nearly 4000 messages or alerts in console app. I am also using Plugins from Melda Productions (http://www.meldaproduction.com/) and they have similar crashes, usually after running the plug-ins and then the crash when hitting apply. A couple of exceptions, specifically running MedlaProductions Auto Align where has an option to morph the presets. I’ll attach the pdf for that plug-in and generally all the Meda ones are pretty similar. In that case as soon as I hit the morph button audacity crashes with no debug or any other options.
wxwidgetsdebugalerts.zip (1.8 MB)
Screen Shot 2016-02-11 at 7.06.12 PM.png
MAutoAlign_documentation.txt (57.8 KB)

here is one of the crash logs:
In general when Audacity is crashing the Specific errors are usually something similar to :

Process:               Audacity [659]
Path:                  /Applications/Audacity_nightly_2_8_16.app/Contents/MacOS/Audacity
Identifier:            net.sourceforge.audacity
Version:      (
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           Audacity [659]
User ID:               501

Date/Time:             2016-02-11 19:06:55.542 -0800
OS Version:            Mac OS X 10.11.3 (15D21)
Report Version:        11
Anonymous UUID:        A10D6347-C1A4-CDF4-C4C6-F7F76BBB7A02

Time Awake Since Boot: 3800 seconds

System Integrity Protection: disabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGTRAP)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x9a8bfe86 __kill + 10
1   libsystem_kernel.dylib        	0x9a8bcdb9 kill$UNIX2003 + 32
2   libsystem_c.dylib             	0x950862ab raise + 27
3   libwx_baseu_debug-	0x024f732a wxTrap() + 26
4   libwx_osx_cocoau_debug_core-	0x01b16beb wxGUIAppTraitsBase::ShowAssertDialog(wxString const&) + 427
5   libwx_baseu_debug-	0x024f938d ShowAssertDialog(wxString const&, int, wxString const&, wxString const&, wxString const&, wxAppTraits*) + 1085
6   libwx_baseu_debug-	0x024f8e61 wxAppConsoleBase::OnAssertFailure(wchar_t const*, int, wchar_t const*, wchar_t const*, wchar_t const*) + 209
7   libwx_baseu_debug-	0x024f9ffe wxDefaultAssertHandler(wxString const&, int, wxString const&, wxString const&, wxString const&) + 686
8   libwx_baseu_debug-	0x024f7e17 wxOnAssert(char const*, int, char const*, char const*, char const*) + 183
9   libwx_osx_cocoau_debug_adv-	0x0176efe8 wxSound::Create(unsigned long, void const*) + 120
10  net.sourceforge.audacity      	0x0043f461 ProgressDialog::Beep() const + 769
11  net.sourceforge.audacity      	0x0043f05b ProgressDialog::~ProgressDialog() + 235
12  net.sourceforge.audacity      	0x0043f727 ProgressDialog::~ProgressDialog() + 23
13  net.sourceforge.audacity      	0x0043f74a ProgressDialog::~ProgressDialog() + 26
14  net.sourceforge.audacity      	0x0009f8eb Effect::DoEffect(wxWindow*, double, TrackList*, TrackFactory*, SelectedRegion*, bool) + 3179
15  net.sourceforge.audacity      	0x004438b0 EffectManager::DoEffect(wxString const&, wxWindow*, double, TrackList*, TrackFactory*, SelectedRegion*, bool) + 208
16  net.sourceforge.audacity      	0x00206a2b AudacityProject::OnEffect(wxString const&, int) + 811
17  net.sourceforge.audacity      	0x000974df Effect::Apply() + 79
18  net.sourceforge.audacity      	0x000a6656 EffectUIHost::OnApply(wxCommandEvent&) + 902
19  libwx_baseu_debug-	0x024f850e wxAppConsoleBase::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&), wxEvent&) const + 126
20  libwx_baseu_debug-	0x024f85b8 wxAppConsoleBase::CallEventHandler(wxEvtHandler*, wxEventFunctor&, wxEvent&) const + 152
21  libwx_baseu_debug-	0x0267bb06 wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) + 246
22  libwx_baseu_debug-	0x0267b8fd wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) + 237
23  libwx_baseu_debug-	0x0267d733 wxEvtHandler::TryHereOnly(wxEvent&) + 147
24  libwx_baseu_debug-	0x0267ecd8 wxEvtHandler::TryBeforeAndHere(wxEvent&) + 72
25  libwx_baseu_debug-	0x0267d4d7 wxEvtHandler::ProcessEventLocally(wxEvent&) + 39
26  libwx_baseu_debug-	0x0267d448 wxEvtHandler::ProcessEvent(wxEvent&) + 392
27  libwx_osx_cocoau_debug_core-	0x01c7604a wxWindowBase::TryAfter(wxEvent&) + 186
28  libwx_baseu_debug-	0x0267d480 wxEvtHandler::ProcessEvent(wxEvent&) + 448
29  libwx_osx_cocoau_debug_core-	0x01c7604a wxWindowBase::TryAfter(wxEvent&) + 186
30  libwx_baseu_debug-	0x0267d480 wxEvtHandler::ProcessEvent(wxEvent&) + 448
31  libwx_baseu_debug-	0x0267d994 wxEvtHandler::SafelyProcessEvent(wxEvent&) + 36
32  libwx_osx_cocoau_debug_core-	0x01c6c93c wxWindowBase::HandleWindowEvent(wxEvent&) const + 44
33  libwx_osx_cocoau_debug_core-	0x01a42634 wxControl::ProcessCommand(wxCommandEvent&) + 36
34  libwx_osx_cocoau_debug_core-	0x01a03c19 wxButton::OSXHandleClicked(double) + 137
35  libwx_osx_cocoau_debug_core-	0x01b0a46f wxWidgetCocoaImpl::controlAction(NSView*, void*, void*) + 95
36  libwx_osx_cocoau_debug_core-	0x01b07adf wxOSX_controlAction(NSView*, objc_selector*, objc_object*) + 95
37  libobjc.A.dylib               	0x99d363ee -[NSObject performSelector:withObject:] + 70
38  com.apple.AppKit              	0x9cb2f235 __36-[NSApplication sendAction:to:from:]_block_invoke + 51
39  libsystem_trace.dylib         	0x9c3383c1 _os_activity_initiate + 85
40  com.apple.AppKit              	0x9cb2f156 -[NSApplication sendAction:to:from:] + 610
41  com.apple.AppKit              	0x9cb45a85 -[NSControl sendAction:to:] + 102
42  com.apple.AppKit              	0x9cb45979 __26-[NSCell _sendActionFrom:]_block_invoke + 176
43  libsystem_trace.dylib         	0x9c3383c1 _os_activity_initiate + 85
44  com.apple.AppKit              	0x9cb458a8 -[NSCell _sendActionFrom:] + 161
45  com.apple.AppKit              	0x9cde4ed9 __48-[NSCell trackMouse:inRect:ofView:untilMouseUp:]_block_invoke1010 + 43
46  libsystem_trace.dylib         	0x9c3383c1 _os_activity_initiate + 85
47  com.apple.AppKit              	0x9cb43c55 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 2744
48  com.apple.AppKit              	0x9cb9d42f -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 809
49  com.apple.AppKit              	0x9cb42284 -[NSControl mouseDown:] + 693
50  libwx_osx_cocoau_debug_core-	0x01b0852b wxWidgetCocoaImpl::mouseEvent(NSEvent*, NSView*, void*) + 459
51  libwx_osx_cocoau_debug_core-	0x01b0747f wxOSX_mouseEvent(NSView*, objc_selector*, NSEvent*) + 95
52  com.apple.AppKit              	0x9d1955b7 -[NSWindow _handleMouseDownEvent:isDelayedEvent:] + 6266
53  com.apple.AppKit              	0x9d1970ea -[NSWindow _reallySendEvent:isDelayedEvent:] + 2303
54  com.apple.AppKit              	0x9ca3a927 -[NSWindow sendEvent:] + 567
55  libwx_osx_cocoau_debug_core-	0x01ae8b95 -[wxNSPanel sendEvent:] + 261
56  com.apple.AppKit              	0x9ca36942 -[NSApplication sendEvent:] + 2919
57  libwx_osx_cocoau_debug_core-	0x019c33a1 -[wxNSApplication sendEvent:] + 209
58  com.apple.AppKit              	0x9c96118f -[NSApplication run] + 1159
59  libwx_osx_cocoau_debug_core-	0x01ad7138 wxGUIEventLoop::OSXDoRun() + 184
60  libwx_baseu_debug-	0x02645861 wxCFEventLoop::DoRun() + 33
61  libwx_baseu_debug-	0x025495e3 wxEventLoopBase::Run() + 291
62  libwx_baseu_debug-	0x024f7529 wxAppConsoleBase::MainLoop() + 185
63  libwx_baseu_debug-	0x024f708a wxAppConsoleBase::OnRun() + 26
64  libwx_osx_cocoau_debug_core-	0x01b163ca wxAppBase::OnRun() + 58
65  libwx_osx_cocoau_debug_core-	0x01a3e9a7 wxApp::OnRun() + 39
66  libwx_baseu_debug-	0x02591106 wxEntry(int&, wchar_t**) + 294
67  libwx_baseu_debug-	0x02591290 wxEntry(int&, char**) + 80
68  net.sourceforge.audacity      	0x00006c39 main + 137
69  net.sourceforge.audacity      	0x00002e85 start + 53

crashlogs.txt (60.3 KB)

Do you need Xcode for some reason, such as MacPorts?


Have you had a reply yet from Apple about the issue, considering you believe it affects other apps including their own Logic Pro?

Is GarageBand affected?



I’ve had to disable Melda plugins too. Don’t remember which ones, as I’ve replaced them and it was a while ago…

So I’m familiar with using the plug-in manager but it does not seem to be working correctly either. I am selecting those plug-ins that I want to enable from either the new or disabled selection and enabling them and then hitting OK. Audacity goes through the menu of verifying them or whatever and sometimes it will crash here also on a certain plug-in if it cannot verify if for some reason or some problem with the activation/ilok issues. But even when it does complete this process and I have the plug-in’s loaded in Audacity they are not removed from the plug-in manager. They may or may not show as enabled now, usually re-opening the plugin-manager will show the exact same config it had before the “new” or “disabled” ones were enabled. Quitting Audacity or rebooting the Mac don’t remove the ones I want it to skip or show those that are enabled in the the correct area, and they are usually still showing under “new”. I’ve had to get 32 Lives for some things on Logic Pro X but I’m not manually launching that app except when I’m going to try and load Logic Pro X.

A particular pain is plug-ins from Softtube, which along with Waves plug-ins requires licenses stored on my iLok. I had a bundle that came with one of my interfaces, and I had installed with their installer, which despite my selections to install only the plug-ins for my bundle, installed every single plug-in for Softtube and now when running the plug-in manager in Audacity I can see all these plug-ins that I do not have licenses for. I can’t see a way to remove them from the Audacity plug-in manager, and even when they show up as disabled they always continue to show up and no way to remove them or ignore them for the future. If one of those is accidentally enabled and Audacity tries to load/verify it, it will crash once the plug-in manager gets to it while verifying the plug-ins. Same situation for Waves plug-ins that I had demo-d and now the demo is expired. I cant seem to just remove that expired plug-in and when Audacity gets to those, they crash.

In both cases the manufacturers are not helpful at all and at the slightest mention of anything to do with Audacity I get the wonderful "we don’t support Audacity " comments and they won’t help at all with that.

Yes I’ve occasionally had to use MacPorts and Homebrew to compile some other things.
Since the most recent Xcode update have had new issues with Audio quality. In this case, I can open an Audacity project on my Mac, but as soon as I open most any plug-in now and preview or try to use the plug-in, the audio I hear is horrible. choppy, slowed down, sounds like water bubbling, or cracking, along with sometimes silence for first couple of seconds after playing the file, following by the audio coming in at some horrendous distorted volume. I sent the files in wav and mp3 to myself on my other computer and opening the exact same files in Audacity on my Windows computer sound fine. I think there is some issue with initializing Apple CoreAudio. Another issue where will, off and on, drop the USB interface connections and even with in the same Audacity session will lose access/connection to my recorder.

I have a phone appointment with Logic Pro support tonight to check on some of this and I’m hopeful that whatever they can do that affects Logic Pro will certainly help Audacity. All these companies seem a bit disgruntled and snobbish the second I mention anything Audacity. Frankly I’d use it almost exclusively if I could fix these annoying crash issues.

I don’t usually use Garageband but I’m assuming what affects Logic would probably be the about the same on Garageband.

What version of Waves is it, in case that cannot be found in the material you posted? v9 was believed working OK on OS X the last time a developer tested it.

Unfortunately it is hard for us as free software to test expensive restricted software that gets frequently updated at further considerable expense. Most of us don’t even have (or want) an iLok.


mac-mini_logs.zip (817 KB)
Waves_Version9_release_notes.txt (16.8 KB)
audacityonmac_crashlogs_etc.zip (593 KB)
It’s most current version of Waves Version 9-attaching release notes.

Yes, I am with everyone on hating ILok. only got into it after bought an interface that came with “Pro Tools Express”. So after having so many issues with getting the Pro Tools to run on a Windows computer I ended up taking everyone’s advice and getting a Mac. Only after all that and trying to install my “Pro Tools” did I find out that “Express” won’t install on anything after OS-X 10.7. So add Avid to my list of companies I hate dealing with. I recently tried an experiment to try and install that Pro Tools Express on my Linux-Ubuntu Studio distro and was actually able to get everything installed including Pro Tools drivers, Virtual Instruments, the Pro Tools DAW and the ILok License manager with the fatal exception that Linux cant seem to access the ILok when trying to open the Pro Tools Daw. It actually opens but then fails not being able to access the ILok.

With the WAVES plug-ins, they are no longer using ILok, they use the Waves Central App for installations, and they have ability with that to set up offline installers and download and move license files.
As with testing Waves on Audacity, I guess theoretically you could test with demo versions of all the WAVES plug-ins. They will give anyone a free 7 day trial of the full unrestricted plug-in on the site (waves.com). On the Mac at least, getting the WAVES plug-ins to run is no problem with either demo version or a full paid version. I don’t think it needs to access the ILok for any waves plug-ins. I do have some Antares plugins that use the ILok but Audacity has no problem with those.
Problem seems to happen after the trials expire and Audacity can no longer verify the plug-in. This is usually when running the plug-in manager in Audacity crashes. I can’t seem to find a good way to get Audacity to remove expired trial plug-ins. When it is behaving, the plug-in manager will give option to skip or re-scan plug-ins, so I can usually get past those crashes, but as to why they keep happening in the first place, I have no idea.
Interestingly, on my Windows computer with Audacity installed I cannot even get Waves plug-ins to show up at all in Audacity as individual plug-ins. I usually see a Waves Shell V9 listing but trying to launch that does nothing. Is there any way to get the individual plug-ins on Windows version to show up like the Mac version?

Final Note: And with all these crashes I’m reporting, the strangest thing is that none of them happen 100% of the time. I’d say the crashes are happening about 1/4 or 25% of the time, more so since XCODE update though. But when they do, they take down the whole program, with no ability to save the current project. Not to mention that I have the error about file inconsistencies every singe time, without fail, after Audacity has “recovered” a project after a crash.

Edit:Adding that I used a combination of Wine development builds and PlayonLinux to install the Protools stuff on my Ubuntu Studio.

Interesting. I suppose this is on El Capitan, since I have Xcode on Mavericks and haven’t seen any problem yet. So, please keep us updated.

And for me too, I avoid iLok completely as I’ve seen far too many problems with it over the years.

Yep, on El Cap. Most everything was working more or less up until the updates to XCODE 7.2 (? I think) that were applied day before yesterday. Have phone appt with Apple and Logic support to see what is going on there.

It would really surprise me that Xcode 7.2 had something to do with it. It’s a security update, fixing holes in Git.

Unless Apple is updating other stuff too and not telling anyone?

That wouldn’t surprise me at all… :laughing:

And BTW, Xcode 7.2.1 is available. Contains a lot of bugfixes, according to the grapevine…

Also, a Waves 9 update is available since februari 2, the same date as Apple’s 7.2.1 update for Xcode. Coincidence?

Yeah, I don’t see what Xcode would have to do with the crashes but who knows? I’m up to date on all the updates so it’s weird that the Xcode update would have been the cause, but who knows what else was in there also… a la Microsoft’s current Windows 10 shenanigans (for more on that, if interested, check out: http://answers.microsoft.com/en-us/windows/forum/all/kb3035583-installing-windows-10-using-windows/e8dc58af-18c4-4ab6-9906-02658b8f402d. Currently buzzing with 50 pages of irate former and soon to be former Windows users comments. It may be the last time you do anything on a Windows machine, at least was the start of why I’m running away from anything Microsoft as fast as I can).

I have an expired recent version of Waves Debreath on El Capitan. It causes no problem on that machine if I enable it in Audacity’s Plug-in Manager, even if the waveshell is disabled. I can press “Skip”, or I can press the button to Rescan licences which causes a beachball for a few seconds then I can press Skip and continue.

I must have done that a few dozen times.

The Plug-in Manager does not have any way to choose not to scan in a particular folder that it normally searches for the existence of plugins. Would you like it to do that?

Normally if you did not want Audacity to list a particular plugin in Plug-in Manager, you would remove it from the paths Audacity searches for that plugin type, as per the links on http://manual.audacityteam.org/o/man/effect_menu.html#Contents.

But WAVES are shell plugins, so as I understand it, one DLL or component controls the appearance of all WAVES plugins. Is your situation that you have paid for some WAVES plugins and other WAVES plugins have expired licenses? Have you asked WAVES if you can disable or uninstall only the expired trials?

Do you mean show up in the the Effect Menu? The plugins should be listed individually in Effect Menu as far as I know. From recollection, after a WAVES plugin was enabled in Plug-in Manager on Windows, only the Waveshell item then showed up in the Plug-in Manger, but I can’t be sure about that.

Is that 25% for properly licensed WAVES plugins or for when Audacity finds only unlicensed WAVES plugins?

If you quit Audacity then delete ~/Library/Application Support/audacity/pluginregistry.cfg and start over enabling plugins in Plug-in Manager, is Audacity more stable for a while?

Are the problem WAVES plugins on Mac AU or VST?

Those inconsistencies are probably left over orphan files for the Undo mechanism that could not be deleted because Audacity did not quit properly.


Has this Xcode update caused increase CPU use? Is Xcode running, and does it need to?

To improve playback have you tried reducing Audio to buffer in Audacity > Preferences… > Recording: http://manual.audacityteam.org/o/man/faq_playback.html#mac_buffer ?

Have you tried the Manage button in the effect, then Options… then change buffer or latency compensation?

Try turning Xcode and/or WiFi off. Prevent AppNap for Audacity (right-click Audacity.app > Get Info…) .