WSAPI error - -9996 and distortion

Windows: Home 10.0.19041
Audacity: 2.4.2

When I select WSAPI as Audio Host, and Speakers (Realtek(R) Audio) (loopback) as the Recording Device, the following message appears when I try to record a new track, eg with Shift+R:

Error opening recording device.
Error code: -9996 Invalid device.

When I select WSAPI as Audio Host, and Stereo Mix (Realtek(R) Audio) as the Recording Device, Audacity seems to record the output OK, but on playback, the sound is massively distorted. The same result happens when I select Windows Direct Sound as the Audio Host. Recording levels are all set correctly - well within clipping tolerances.

Recording is working fine through the microphone.

Any help gratefully received.

The same thing happens to me. :frowning:

I cannot duplicate this distortion. I suppose you could try [speaker icon]>Sounds>Recording>Stereo Mix>Properties>Enhancements>Disable All Sound Effects.

I hope this helps. :smiley:

Many thanks, Jademan. It worked! I never even knew the option existed - I mean, it’s not in the Sound Settings menu.


(Still get the same -9996 error, though. Ho hum.)

In the Windows Sound control panel, ensure that the Realtek device is set to “2 channels, 44100 Hz” in both the Recording tab and the Playback tab.

To open the Windows Sound control panel:

  1. open the run dialog with Windows logo + R
  2. enter: control mmsys.cpl
  3. press the OK button

It doesn’t appear on the Playback setting: only Digital Output (AMD High Definiton Audio Device) whcih stated it’s “Not plugged in” and Speakers. It’s there on the Recording setting, along with Microphone.

It’s on the Recordings tab, along with Microphone. But on the Playback tab, there’s “Speakers” and “Digital Output - AMD High Definition Audio Device - Not plugged in.”

My guess is that “Speakers” is the one that you want. (I’m assuming that you don’t have any USB speakers connected).

Well, that seems to have worked, - Lord knows why!

Though the “loopback” option needs a lot of level adjustment.

Sincere thanks, Steve. I now have a functioning laptop for recording.

I think there’s something weird about your device drivers - the settings that you had shouldn’t be possible. However, as it’s working now, best not to change it (If it’s not broken, don’t fix it) :wink: