working on one machine, no playback on the other.

After upgrading to Catalina on my MBP and iMac, I reinstalled Audacity (error message said it “couldn’t be opened” otherwise.)
Audacity ver 2.3.3

It runs fine on my MBP. The iMac will open a file, but when I try to play the file I get:

“Error opening sound device.
Try changing the audio host, playback device and the project sample rate”

I don’t know what “Change audio host” means.
I’ve tried my Apogee Duet and internal speakers as playback devices and multiple different sample rates. Same error every time I hit Play.

I’ve read the help page on the website and the appropriate pages in the manual, but nothing solves this issue.

Suggestions? Thanks!


iMac Retina 5k 27" 2017
3.8.GHz Quad-Cor Intel Core i5
Ver 10.15.4

Mac Book Pro
(Retina, 15-inch, Early 2013)
.4 GHz Quad-Core Intel Core i7
8 GB
Ver 10.15.4

Hi there,

It seems that there are some issues with AUdacity 2.3.3 and Catalina. I think this will be fixed in the next release (2.4.0). But maybe I am wrong. I cannot tell 100%. There is no way to downgrade your OS version, right?

Maybe the new Audacity version will be released not too far away in the future. So maybe be a little bit patient? :wink:

Thank you.

Hello Victor,

Thanks for the reply! After a couple of back-and-forths with Martin we got it sorted. The new version (2.7.5) seems to have worked out this particular bug and I’m back in business.

Martin sent me a link to download the new version, which installed fine but wouldn’t open without and auth code, which I didn’t have. And neither did Martin, because I bought AP from the App Store, which seems to not report sales back to Martin. Deep joy.

Again, all working now. Thanks for the reply and take care!


What program are you referring to? There isn’t a “2.7.5” version of Audacity.
Also, there is no-one called Martin in the Audacity team.

WRONG FORUM - (face palm)

I’m currently dealing with multiple, concurrent software bugs; Audacity, Amadeus Pro and Apple. All start with “A” and I CLEARLY need more coffee!

Martin is over at Amadeus ? Harier. That problem got fixed.

AUDACITY is still not working on my iMac but is on MacBook Pro.

APPLE is… Apple.

Very sorry for the confusion! As you were.

Do you have Catalina on both?
Unfortunately, Apple broke support for Audacity with Catalina. This problem has been fixed in the next version of Audacity (2.4.0) which is scheduled for release near the beginning of May. For now there is a workaround for Audacity 2.3.3:

Thanks for the work-around suggestion!

Alas, it did not work for me. Audacity opens. It (or Terminal) asked for permission to access an external drive, which I granted, but:

Hitting Record gives the error:
Error opening recording device.
Error code:-9997 Invalid sample rate

Opening an existing file:
Opens the file and displays the waveform, but pressing Play gives:
Error Opening sound device.
Try changing the audio host, playback device and the project sample rate.
(this happens with both “built-in audio” and “Apogee Duet” selected as audio source)

So, no joy.

Again, this is Audacity 2.3.3
MacOS 10.15.4

Works on MBP, does not work on iMac.

Thanks again.

I’m having same issue. Just installed version 2.4.1 on mac catalina 10.15.4 and no playback.

I get the message “Error opening sound device. Try changing audio host, etc.” I followed suggestion in faq and settings seem to be correct.

Interestingly, I’m able to import and export, files, just can’t playback.